Начало работы

 Вперед

Начало работы

Клиентский терминал является частью информационно-торговой системы. Он устанавливается на компьютере трейдера и предназначен для:

  • получения котировок и новостей в режиме реального времени;

  • выполнения торговых операций;

  • контроля и управления состоянием открытых позиций и отложенных ордеров;

  • проведения технического анализа;

  • написания советников, пользовательских индикаторов, скриптов и функций на языке MetaQuotes Language 4 (MQL 4);

  • тестирования и оптимизации торговых стратегий.

Чтобы принять решение о проведении торговых операций, необходима оперативная и надежная информация. Для этого в терминал встроены функции поставки котировок и новостей в режиме реального времени. На основе оперативно поступающих котировок можно проводить анализ рынков с использованием технических индикаторов и линейных инструментов. Наличие советников позволяет освободиться от рутины наблюдения за состоянием рынков и собственных позиций. Кроме того, чтобы обеспечить более гибкое управление позициями, в терминал встроено несколько видов ордеров.

Клиентский терминал может работать под управлением операционных систем Microsoft Windows 98SE/ME/2000/XP/2003. Требования к аппаратной части ограничиваются требованиями к операционным системам.


Начало работы — Установка терминала

Установка терминала

Для установки терминала необходимо скачать дистрибутив и запустить его. Далее, потребуется выбрать каталог установки программы и следовать подсказкам визарда. По завершении установки произойдет автоматический запуск терминала.

Также можно инсталлировать терминал поверх уже установленной версии. При этом все настройки терминала останутся в том состоянии, в каком они были сохранены в предыдущей версии. Исключением могут быть: профиль и шаблон DEFAULT, а также стандартные MQL4-программы, входящие в комплект поставки. Поэтому рекомендуется не изменять стандартные шаблоны и профили, а MQL4-программы создавать под уникальными именами.

Если необходимо работать с несколькимим счетами одновременно, то нужно устанавливать соответствующее количество терминалов в различные директории. При этом каждый терминал имеет индивидуальные настройки за исключением регистрационных данных и языка интерфейса, которые записываются в системный реестр.


Начало работы — Запуск терминала

Начало работы — Запуск

Запуск терминала

По завершении установки в меню "Пуск" создается группа программ клиентского терминала, а на рабочем столе дополнительно помещается ярлык программы. С их помощью можно запускать клиентский терминал.

Внимание: нельзя запускать одновременно две копии клиентского терминала из одной директории. Чтобы одновременно запустить несколько терминалов, необходимо установить соответствующее количество программ в разные директории.

Терминал можно запускать из командной строки, задав определенные параметры. В качестве параметра можно использовать номер счета и название профиля. Если был указан номер счета, то при старте программы произойдет попытка авторизовать этот счет. Если был указан профиль, он будет автоматически загружен. Например, terminal.exe "123456-'British Pound'", где "123456" — номер счета, British Pound — название профиля. Если в командной строке встречаются пробелы (как в вышеприведенном названии профиля), необходимо ставить двойные кавычки. Если пробелы не встречаются, двойные кавычки ставить не надо. Одинарными кавычками оформляется название профиля. Например,terminal.exe 123456-'GBPUSD'. В командной строке можно использовать либо только логин, либо логин и профиль, профиль без логина использовать нельзя.

Также имеется возможность запускать терминал с предустановленными настройками. Более детальная информация находится в разделах "Конфигурация при старте" и "Datacenter.ini".


Начало работы — Открытие счетов

Открытие счетов

Терминал позволяет работать с двумя видами счетов: демонстрационными (тренировочными) и реальными. Демонстрационные счета дают возможность работать в тренировочном режиме без реальных денег, но при этом качественно отработать торговую стратегию. Они обладают теми же функциональными возможностями, что и реальные счета. Отличие состоит в том, что демонстрационные счета можно открывать без соответствующих инвестиций и, следовательно, нельзя претендовать на прибыль с них.

Открытие демонстрационного счета

Чтобы открыть демонстрационный счет, необходимо выполнить команду меню "Файл — Открыть счет" или одноименную команду контекстного меню окна "Навигатор — Счета". Кроме того, во время первого запуска программы будет предложено открыть демонстрационный счет, чтобы сразу приступить к работе.

При открытии счета будут запрошены следующие данные:

  • Имя — полное имя пользователя;

  • Страна — страна проживания;

  • Область — область (регион, край, штат и так далее) проживания;

  • Город — город проживания;

  • Индекс — почтовый индекс;

  • Адрес — точный адрес проживания (улица, дом и квартира);

  • Телефон — контактный телефон;

  • Email — адрес электронной почты;

  • Тип счета — тип счета, который выбирается из списка, определенного брокерской компанией;

  • Валюта депозита — базовая валюта депозита, которая автоматически устанавливается в зависимости от выбранного типа счета;

  • Кредитное плечо — соотношение заемных и собственных средств для совершения торговых операций;

  • Депозит — размер начального депозита в базовой валюте.

Чтобы активировать кнопку "Далее" и продолжить регистрацию, необходимо выставить флажок "Я согласен получать новости по почте". Затем нужно выбрать сервер, к которому будет производиться подключение. В списке указаны адреса доступных серверов, их названия и пинг. Самым предпочтительным является сервер с наименьшим пингом. По окончании успешной регистрации появится окно, содержащее информацию об открытом счете: "Логин" — номер аккаунта, "Пароль" — пароль для доступа, "Инвестор" — инвесторский пароль (режим подключения, при котором можно просматривать состояние счета, анализировать динамику цен и прочее, но нельзя проводить торговых операций). По завершении регистрации новый счет появляется в окне "Навигатор — Счета", и с ним уже можно работать. При этом сервер также отсылает на терминал письмо с логином и паролями для данного счета. Это письмо можно найти в окне "Терминал — Почтовый ящик". Кроме того, после успешной регистрации счета происходит его автоматическая авторизация.

Внимание: в случае возникновения проблем при регистрации счета следует обратиться в службу технической поддержки брокерской компании.

Открытие реального счета

Реальные счета, в отличие от демонстрационных, не могут быть открыты из терминала. Они открываются брокерскими компаниями на определенных условиях. Реальные счета помечаются соответствующим значком в окне "Навигатор — Счета". Чтобы перейти к работе с ними, необходимо выполнить авторизацию.


Начало работы — Авторизация

Авторизация

Авторизацией называется подключение терминала к серверу с использованием логина и пароля. Она дает право управлять торговым счетом. В терминале реализовано два вида доступа к счету: основной и инвесторский. Авторизация с использованием основного пароля дает полные права при работе с терминалом. При инвесторской авторизации можно просматривать состояние счета, проводить анализ ценовых данных и работать с советниками, но нельзя совершать торговые операции. Инвесторский доступ является удобным инструментом для демонстрации торгового процесса на данном счете.

Для авторизации необходимо выполнить команду "Логин" контекстного меню счета (контекстное меню вызывается нажатием правой кнопки мыши на номере счета) в окне "Навигатор" или меню "Файл". Затем в появившемся окне следует указать номер счета, один из его паролей (основной или инвесторский) и выбрать сервер. Указав все данные, необходимо нажать кнопку "Логин".

Внимание: если включена опция "Хранить личную информацию", при следующем запуске терминала будет происходить автоматическая авторизация последнего использованного счета. Опция "Сохранять личные настройки и данные при старте" в настройках терминала выполняет то же действие.


Начало работы — Система безопасности

Система безопасности

Весь обмен информацией между клиентским терминалом и сервером идет с использованием шифрования на основе 128-битных ключей. Этого достаточно для обеспечения безопасности торговых операций. Однако, помимо этой системы, терминал позволяет использовать еще одну — систему безопасности на основе алгоритма электронно-цифровых подписей RSA. Это ассиметричный алгоритм шифрования, который подразумевает наличие публичного и секретного ключей. Публичный ключ может свободно распространяться и использоваться для проверки подлинности сообщения, которое подписывается с помощью секретного ключа. Гарантируется, что, зная публичный ключ, невозможно за приемлемое время вычислить секретный. Вычисление секретного ключа на основе публичного даже на мощных современных компьютерах может занять десятки и сотни лет.

Внимание: дополнительная система безопасности на основе электронно-цифровых подписей (ЭЦП) включается на сервере.

В режиме дополнительной безопасности при первом подключении к серверу появится специальное окно, предназначенное для генерации открытого и закрытого ключей. Для создания ключей необходимо поводить курсором мыши по черной области окна, чтобы создать случайную последовательность данных. Тогда на ее основе произойдет генерация ключей. Сгенерированная пара ключей (публичный и секретный) сохраняется на жестком диске, а публичный ключ отсылается на торговый сервер. В будущем, используя публичный ключ, сервер будет проверять достоверность подписанной информации.

Внимание:

  • если для торгового счета включена дополнительная система безопасности, то при работе на другом компьютере необходимо перенести на него сгенерированные ключи (публичный и секретный). Они представляют собой файлы с раширением KEY и находятся в папке /CONFIG;

  • в случае утери или повреждения любого из ключей необходимо обратиться в службу технической поддержки брокерской компании.


Начало работы — Автоматическое обновление

Автоматическое обновление

В терминал встроена система автоматического обновления. Она позволяет оперативно получать и устанавливать новые версии программы. Эта система постоянно включена, ее отключить нельзя.

Во время подключения к серверу терминал проверяет наличие новых версий программы. Если была обнаружена более новая версия, появится новое окно "Live Update" и будет предложено скачать это обновление. Чтобы начать скачивание обновленных файлов, необходимо нажать кнопку "Start". При этом в окне можно будет видеть ход процесса обновления и список скачиваемых файлов. По завершении скачивания произойдут автоматическая установка и перезапуск новой версии терминала.

Внимание:
  • если отсутствует подключение к серверу, автоматическое обновление не начнется;
  • в случае возникновения проблем с автоматическим обновлением следует обратиться службу технической поддержки;
  • при обновлении примеры использования экспертов, индикаторов и скриптов, поставляемых вместе с клиентским терминалом, могут быть перезаписаны.


Настройки клиентского терминала

Настройки клиентского терминала

Общие настройки клиентского терминала производятся в отдельном окне, которое можно вызвать командой меню "Сервис — Настройки" или при помощи клавиш-акселераторов Ctrl+O. Все настройки сгруппированы по назначению и располагаются во вкладках:

  • Сервер — установка параметров соединения с сервером, конфигурация используемых прокси-сервера и Дата Центров, а также другие важные настройки;

  • Графики — общая настройка отображения ценовых графиков. Здесь можно определить, будут ли показываться разделители периодов, уровень Ask-цен, строка OHLC. Кроме того, в этой вкладке можно задать количество хранимых и отображаемых на графике баров;

  • Объекты — настройка параметров управления объектами. Выделение объектов после их создания, их немедленная настройка и параметры примагничивания задаются именно здесь;

  • Торговля — параметры открытия новых ордеров по умолчанию. К ним относятся: финансовый инструмент, количество лотов и отклонение;

  • Советники — общие для всех экспертов настройки. К ним относятся: запрет работы советников, возможность импорта функций из внешних DLL-библиотек и советников, а также ряд других возможностей;

  • Почта — настройка параметров электронной почты. Если есть необходимость отсылать электронные сообщения прямо из терминала, следует обязательно настроить параметры используемого почтового ящика;

  • Публикация — настройка публикации отчетов в интернете. Терминал позволяет в режиме реального времени публиковать отчеты о состоянии счета в интернете. Для этого используется соединение по ftp-протоколу, которое можно настроить в этой вкладке;

  • События — настройка сигналов о системных событиях. Сигналы об отсутствии связи, получении новостей и другие существенно облегчают работу.


Настройки клиентского терминала — Сервер

Вкладка Сервер

В этой вкладке собраны наиболее важные настройки, изменения в которых могут вызвать серьезные проблемы в работе терминала вплоть до полного отключения. Клиентский терминал изначально сконфигурирован так, чтобы обеспечить нормальную бесперебойную работу. Поэтому настоятельно не рекомендуется изменять какие-либо параметры в этом окне без особой на то необходимости.

В окне "Настройки — Сервер" можно:

  • выбрать сервер для подключения;

  • cконфигурировать прокси-сервер;

  • настроить работу через Дата Центры;

  • задать и изменить пароли;

  • включить экспорт котировок по протоколу DDE;

  • включить получение новостей.

Сервер

Практически вся работа клиентского терминала построена на основе непрерывно поступающих от сервера данных (новостей и котировок). Если клиентский терминал не получает котировки, с его помощью невозможно вести торговую деятельность. В этом режиме терминал позволяет лишь анализировать уже имеющиеся данные с помощью индикаторов и линейных инструментов, а также тестировать советники. Такая ситуация может возникнуть по ряду причин, одной из которых является неверная настройка соединения с сервером.

Для подключения клиентского терминала к серверу необходимо точно знать IP-адрес (или доменное имя) сервера и порт подключения. После установки программы все эти данные уже указаны, их не нужно менять. Однако, если возникла необходимость подключиться к другому серверу, следует указать его адрес и порт в поле "Сервер". Запись должна иметь формат: "[интернет-адрес сервера] : [номер порта]" (без пробелов). Например, "192.168.0.1:443", где "192.168.0.1" — адрес сервера, а "443" — номер порта. По завершении ввода необходимо нажать кнопку "OK".

Вновь установленные адрес сервера и порт сохраняются на жестком диске. Эти данные не влияют на работу клиентского терминала до тех пор, пока не будет сделана попытка открыть новый счет. Именно с этого момента терминал начинает использовать указанные адрес сервера и порт. Адрес нового сервера будет добавлен в список серверов при регистрации счета, и его можно выбрать. Если соединение с сервером было установлено успешно, новый счет будет открыт. В противном случае рекомендуется проверить все настройки и повторить попытку.

Внимание: неверная настройка подключения к серверу не является единственной причиной, по которой не может быть открыт новый счет.

Прокси-сервер

Подключение к интернету через прокси-сервер может быть еще одной причиной, по которой не происходит соединение с сервером. Прокси-сервер представляет собой промежуточное звено между компьютером трейдера и торговым сервером. Чаще всего он устанавливается у поставщика интернет-услуг или в локальной сети. В случае возникновения проблем с подключением следует обратиться к своему системному администратору или провайдеру. Если используется прокси-сервер, необходимо настроить терминал соответствующим образом. Флажок "Разрешить прокси-сервер" включает поддержку прокси-сервера и активирует кнопку "Прокси...". По нажатии этой кнопки открывается окно, в котором задаются параметры прокси-сервера (эту информацию можно узнать у системного администратора или провайдера):

  • Сервер — адрес прокси-сервера и его тип (HTTP, SOCKS5, SOCKS4);

  • Логин — учетная запись для доступа к прокси-серверу. Если логин не требуется, следует оставить поле пустым;

  • Пароль — пароль для доступа к прокси-серверу. Если пароль не требуется, следует оставить поле пустым.

По завершении рекомендуется нажать кнопку "Тест" для проверки работоспособности настроек. Получив сообщение об успешном тестировании настроек, необходимо нажать кнопку "OK", чтобы настройки вступили в силу. Сообщение об ошибке свидетельствует о неправильной настройке прокси-сервера. Для выяснения причин нужно повторно связаться с системным администратором или провайдером.

Дата Центры

Дата Центры (точки доступа) входят в состав торговой платформы и представляют собой специализированные прокси-серверы. Они позволяют экономить общий трафик: одинаковые котировки и новости выдаются сразу нескольким клиентским терминалам. Точки доступа располагаются между сервером и клиентским терминалом. Причем у одного сервера может быть несколько точек доступа, через которые будут подключаться все трейдеры. После установки терминала подключение к Дата Центрам настраивается автоматически. Настоятельно не рекомендуется что-либо изменять. Неверная настройка подключений к Дата Центрам может явиться причиной отсутствия соединения терминала с сервером.

Если возникла необходимость в изменении настроек Дата Центров, рекомендуется предварительно связаться с отделом технического обслуживания. Там можно получить всю информацию, требуемую для корректной настройки Дата Центров. В большинстве случаев необходимо лишь выставить флажок "Автоконфигурация Дата Центра". При этом клиентский терминал будет автоматически выбирать наиболее предпочтительные точки доступа.

В случае ручной настройки точек доступа необходимо убрать этот флажок. Затем в активизировавшемся поле "Дата Центр" ввести IP-адрес (или доменное имя) и номер порта. Запись должна иметь вид "[интернет-адрес Дата Центра] : [номер порта]". По завершении ввода рекомендуется проверить настройки, нажав кнопку "Тест" справа от поля. Если настройки работоспособны, появится соответствующее сообщение. После этого можно будет приступить к работе. В случае появления сообщения об ошибке следует связаться со службой технической поддержки для разрешения проблемы.

Внимание:
  • не рекомендуется настраивать доступ к Дата Центрам вручную без особой на то необходимости;
  • при настройке доступа к Дата Центрам вручную настоятельно рекомендуется прочесть справку по этой программе.

Аккаунт и логин

Клиентский терминал может подключаться к серверу и работать только с использованием аккаунта (счета). В клиентском терминале существуют логин (номер счета), основной и инвесторский пароли. Для авторизации необходимы номер счета и один из двух паролей. Основной пароль дает полный доступ к счету, в то время как инвесторский — ограниченный доступ. Авторизация с инвесторским паролем дает право просматривать графики, проводить технический анализ и тестировать советники, но не позволяет проводить торговые операции. Инвесторский доступ является удобным инструментом для демонстрации торгового процесса на данном счете.

После создания счета, если выставлен флажок "Сохранять личные настройки и данные при старте", его данные (номер, основной и инвесторский пароли) записываются на жесткий диск. При повторном запуске программы эти данные используются для автоматического подключения счета. Если флажок не выставлен, при каждом запуске терминала необходимо будет вводить пароль вручную.

В поля "Логин" и "Пароль" вписываются номер текущего счета и пароль. В эти поля можно ввести данные другого счета, и по нажатии кнопки "ОК" произойдет попытка его авторизации. В случае неудачной авторизации необходимо проверить указанные данные и авторизоваться повторно. Если это не помогает, следует обратиться в службу технической поддержки.

Нажав кнопку "Изменить", в появившемся окне можно задать новые пароли. При этом необходимо знать текущий пароль. Его можно найти в письме, присланном от сервера после регистрации демо-счета. Новый пароль записывается в соответствующем поле. При этом, если выставлен флажок "Заменить пароль инвестора", изменяется не основной, а инвесторский пароль.

Экспорт данных по протоколу DDE

Поступающие в терминал котировки могут экспортироваться в другие приложения по протоколу "DDE" (Dynamic Data Exchange). Для включения экспорта котировок необходимо выставить флажок в "Разрешить DDE сервер" и нажать кнопку "ОК". Сразу после этого начнется поставка данных. Более подробная информация об экспорте котировок находится в соответствующем разделе.

Новости

Терминал позволяет оперативно получать финансовые новости. Они начинают поступать только после подключения к серверу. В терминале не появится ни одна новость, вышедшая в то время, когда он был отключен. Для включения поставки новостей необходимо выставить флажок "Разрешить новости". В окне "Терминал" появится вкладка "Новости", в которую они будут поступать по мере выхода.

Внимание: если выставлен флажок "Разрешить новости", но ни одна новость не выходила, вкладка "Новости" в окне "Терминал" не появится.


Настройки клиентского терминала — Графики

Вкладка Графики

Графики отражают динамику изменения цен финансовых инструментов. В этой вкладке сгруппированы настройки отображения графиков и параметров исторических данных. Изменение параметров в этой вкладке не повлечет за собой глобальных перемен в работе терминала.

  • Торговые уровни
    Располагаемые прямо на графике линии открытых и отложенных ордеров позволяют наглядно увидеть, где именно была открыта позиция, когда сработает отложенный ордер, Stop Loss или Take Profit. Эта опция облегчает работу трейдеров и позволяет избежать некоторых ошибок, вызванных человеческим фактором. Для ее включения необходимо выставить флажок "Показывать торговые уровни" и нажать кнопку "ОК". При этом на графике появятся линии, соответствующие ценам открытия позиций и выставленных ордеров. Разумеется, если не выставлен ни один ордер или не открыта ни одна позиция, никаких уровней на графике отображаться не будет. Также следует помнить, что эта опция действует только для открытых позиций и ордеров. Ни одна закрытая позиция не подпадают под действие этой опции.

  • Ask-цена
    Бары в терминале строятся и отображаются только по Bid-ценам. Однако при открытии длинных позиций и закрытии коротких всегда используется Ask-цена. При этом она никак не отражена на графике, ее нельзя увидеть. Чтобы более точно контроливать свою торговую деятельность, можно включить параметр "Показывать линию Ask". По выполнении этой команды на графике появится дополнительная горизонтальная линия, соответствующая Ask-цене последнего бара.

  • Строка OHLC
    Графики отражают динамику цен, но зачастую точные парметры бара определить на глаз очень сложно. Опция "Показывать OHLC" помогает в этой ситуации. Она помещает в левый верхний угол каждого графика дополнительную информационную строку. В ней, кроме названия инструмента и периода графика, перечислены также цены последнего бара. Запись цен имеет формат: OPEN, HIGH, LOW и CLOSE (OHLC) — цена открытия бара, максимальная цена бара, минимальная цена и цена закрытия соответственно. Таким образом, перед глазами всегда оказывается точное значение последнего бара.

  • Разделители периодов
    На горизонтальной оси графика отображаются дата и время каждого бара. Ценой деления этой горизонтальной шкалы является выбранный период (таймфрейм). Опция "Показывать разделители периодов" наносит на график дополнительные вертикальные линии, соответствующие границам более крупного таймфрейма. Так, для графиков с периодом от M1 до H1 строятся дневные разделители, H4 — недельные, D1 — месячные, а W1 и MN1 — годовые.

  • Цветная печать
    Терминал позволяет печатать не только черно-белые, но и цветные графики движения цен. Они более удобны для аналитических целей, чем черно-белые. Чтобы включить эту опцию, необходимо выставить флажок "Цветная печать" и нажать кнопку "ОК". После этого, если позволяет принтер, печать всех графиков будет цветной.

  • Сохранение шаблонов удаленных графиков
    Терминал позволяет восстанавливать удаленные из рабочей области графики. Если включена опция "Сохранять удаленные окна для переоткрытия", при удалении графика в каталоге /DELETED сохраняется его шаблон. В будущем, воспользовавшись командой меню "Файл — Открыть удаленный", можно восстановить любой удаленный график. Например, закрыв четырехчасовой график EURUSD, можно восстановить его. При этом график будет также четырехчасовым, и все его настройки вместе с наложенными элементами (индикаторами, линейными инструментами) будут также восстановлены.

  • Количество баров в истории и на графиках
    Существует разница между хранимыми в истории и отображаемыми на графиках барами. Она обусловлена тем, что на жестком диске может храниться любое количество баров, на которое хватает объема. В то же время отображение баров на графиках ограничено ресурсами компьютера. Для расчета значений технических и пользовательских индикаторов также используются бары, отображаемые на графике. При одновременном использовании множества индикаторов и большом количестве отображаемых данных свободные ресурсы компьютера (загрузка центрального процессора и объем свободной оперативной памяти) могут быстро закончиться. Чтобы избежать подобных проблем, можно самостоятельно задать объем отображаемых на графиках данных. Это можно сделать, выбрав подходящее значение из выпадающего списка или записав вручную в поле "Макс. баров на графике". В поле "Макс. баров в истории" задается количество хранимых на жестком диске баров. В дальнейшем это значение будет использоваться для тестирования советников. Здесь можно записать любое количество баров.

Внимание:
  • при закрытии графика сохраняется не большее количество баров, чем указано в поле "Макс. баров в истории";
  • при открытии графика загружается не большее количество баров, чем указано в поле "Макс. баров на графике". При этом в процессе подкачки котировок количество баров на графике может превышать это значение;
  • значения опций "Показывать линию Ask", "Показывать OHLC" и "Показывать разделители периодов", заданные в этом окне, являются параметрами по умолчанию. Для каждого конкретного графика эти же параметры могут быть заданы индивидуально в окне настройки;
  • значения опций "Показывать торговые уровни", "Цветная печать" и "Сохранение шаблонов удаленных графиков", заданные в этом окне, влияют на все графики и вступают в силу сразу же после нажатия кнопки "ОК".


Настройки клиентского терминала — Объекты

Вкладка Объекты

В этой вкладке сгруппированы настройки, касающиеся работы с графическими объектами. К графическим объектам относятся все инструменты, расположенные на одноименной панели управления и в меню "Вставка". К ним относятся: технические индикаторы (включая пользовательские индикаторы), линейные инструменты, геометрические фигуры, текст и значки. Сгруппированные в этой вкладке параметры облегчают работу с графическими объектами и не могут вызвать критических изменений в работе терминала.

  • Показывать параметры после создания
    Все графические объекты обладают определенными свойствами. Например, толщина и цвет линии тренда, период сигнальной линии индикатора и т.д. Большинство трейдеров использует стандартные настройки всех графических объектов, однако в ряде случаев необходимо настраивать инструменты индивидуально. Опция "Показывать параметры после создания" позволяет настраивать объекты непосредственно после наложения. Это бывает удобно, когда на графике много объектов с индивидуальными настройками.

  • Выделять объекты после создания
    В отличие от индикаторов, такие объекты, как линейные инструменты, текст, значки и геометрические фигуры, позиционируются на графиках вручную. После наложения объекта может понадобиться переместить его, например, более точно расположить трендовую линию. Для этого необходимо сначала выделить нужный объект. Опция "Выделять объекты после создания" позволяет сделать это непосредственно после наложения объекта на график.

  • Выделять объекты одиночным кликом мыши
    Графические объекты в терминале можно выделять двойным или одиночным кликом левой кнопки мыши. Эта опция позволяет переключить метод выделения объектов. Если она отмечена флажком, все объекты выделяются по одиночному клику. При этом двойной клик вызывает окно свойств объекта. Если опция отключена, все объекты выделяются по двойному клику.

  • Примагничивание
    Терминал позволяет "примагничивать" контрольные точки объектов к различным ценам баров для более точного расположения. В поле "Примагничивание" можно задать чувствительность этой опции в пикселях. Например, если задано значение 10, то при появлении контрольной точки объекта в радиусе 10 пикселей от ближайшей цены бара (OHLC) он автоматически примагничивается к ней. Для отключения этой опции необходимо выставить параметр 0.


Настройки клиентского терминала — Торговля

Вкладка Торговля

В этой вкладке сгруппированы настройки открытия ордеров. Задаваемые отсюда параметры облегчают работу при открытии ордеров и не могут вызвать критических изменений в работе терминала.

  • Символ по умолчанию
    Опция "Символ по умолчанию" позволяет автоматически задавать значение символа в окне "Ордер" при совершении торговой операции. Параметр "автоматический выбор" означает, что в этом поле будет устанавливаться символ активного графика, "последний использованный" — символ предыдущей торговой операции. Чтобы всегда устанавливался один и тот же символ, необходимо отметить параметр "по умолчанию" и выбрать требуемый финансовый инструмент из списка.

  • Лоты по умолчанию
    Аналогично можно задать изначальное количество лотов (опция "Лоты по умолчанию"): "последнее использованное значение" — параметр, использовавшийся в предыдущей операции, а "по умолчанию" — постоянное, задаваемое вручную значение.

  • Отклонение
    За время формирования ордера цена инструмента может измениться. В результате цена подготовленного ордера не будет соответствовать рыночной, и позиция открыта не будет. Опция "Отклонение" позволяет избежать этого. В этом поле можно задать максимально допустимое отклонение цены от значения, указанного в ордере. При несоответствии цен программа сама модифицирует ордер, что позволит открыть новую позицию.


Настройки клиентского терминала — Советники

Вкладка Советники

В этой вкладке сгруппированы настройки, касающиеся работы с советниками (экспертами). Советниками в терминале называются программы, написанные на языке MetaQuotes Language 4 и позволяющие вести аналитическую и торговую деятельность в автоматическом режиме (автотрейдинг). Информация о создании и использовании советников находится в разделе "Автотрейдинг". В данном разделе описаны только общие для всех экспертов настройки:

  • Включить советники
    Эта опция позволяет разрешить или запретить использование всех советников. Если она отключена, с приходом нового тика для всех экспертов перестает запускаться функция start(). При этом вместо смайликов напротив названий экспертов в правом верхнем углу графиков появляются крестики. Чтобы включить советники, необходимо выставить флажок и нажать кнопку "ОК". С приходом нового тика советники начнут работать, а крестики в правом верхнем углу графика вновь станут смайликами.
    Включить или выключить советники можно также нажатием кнопки Разрешить/запретить использование советников панели инструментов "Стандартная".

    Внимание:
    • эта опция распространяется только на советники и не позволяет автоматически отключать пользовательские индикаторы и скрипты;
    • действие этой опции не распространяется на уже запущенные эксперты, то есть советник не будет остановлен во время выполнения функции start().

  • Отключить советники при смене счета
    Эта опция представляет собой защитный механизм, отключающий советники при смене счета. Она бывает полезна, например, при переключении с демонстрационного счета на реальный. Чтобы включить механизм, необходимо выставить флажок и нажать кнопку "ОК".

  • Отключить советники при смене профиля
    В профилях сохраняется большое количество информации о текущих настройках всех графиков в рабочей области. В частности, в профилях сохраняется информация о прикрепленных советниках. Эксперты, входящие в состав профиля, с приходом нового тика начнут работать. Включив эту опцию (выставив флажок), можно не допустить запуска экспертов при смене профиля.

  • Разрешить советнику торговать
    Советники способны работать в автономном режиме, без участия трейдера. Они могут как анализировать динамику цен, так и вести торговую деятельность. Эта опция предназначена для ограничения торговой деятельности экспертов. Такое ограничение бывает полезно при тестировании аналитических способностей эксперта в режиме реального времени (не путать с тестированием советника на исторических данных).

  • Ручное подтверждение
    Опция "Ручного подтверждение" активируется только в том случае, если советникам разрешено торговать. Если она включена и советник пытается провести торговую операцию, можно будет либо подтвердить ее, либо прервать вручную. Иными словами, при помощи ручного подтверждения можно контролировать торговую активность советника. При этом появляется окно совершения торговых операций с заполненными полями. Это может быть полезно при тестировании торговых функций советника в режиме реального времени (не путать с тестированием советника на исторических данных).

  • Разрешить импорт DLL
    Для расширения функциональности советники могут использовать DLL-библиотеки. Выставив этот флажок, можно использовать такие библиотеки без каких-либо ограничений. Если эта опция отключена, ни один эксперт не сможет воспользоваться внешними DLL-библиотеками. Рекомендуется запрещать импорт при работе с неизвестными экспертами.

  • Подтверждать вызов функций DLL
    Эта опция активируется только в том случае, если был разрешен импорт из DLL-библиотек. Она позволяет контролировать выполнение каждой вызываемой функции вручную. Если флажок не установлен, импорт из внешних библиотек контролироваться не будет. При работе с неизвестными библиотеками рекомендуется включать эту опцию.

  • Разрешить импорт внешних экспертов
    Если при работе советника требуется импортировать функции из других экспертов или библиотек MQL4, необходимо включить эту опцию. Если она отключена, ни один из запущенных экспертов не сможет запрашивать функции из других MQL4-программ. Рекомендуется отключать эту опцию при работе с неизвестными советниками.

Внимание: значения опций "Разрешить советнику торговать", "Ручное подтверждение", "Разрешить импорт DLL", "Подтверждать вызов функций DLL" и "Разрешить импорт внешних экспертов", заданные в этом окне, являются параметрами по умолчанию для вновь прикрепляемых MQL4-программ. Они не влияют на работу уже запущенных экспертов, пользовательских индикаторов и скриптов.


Настройки клиентского терминала — Почта

Вкладка Почта

В этой вкладке производится настройка электронного почтового ящика. В дальнейшем эти настройки будут использоваться для отсылки сообщений по команде советника или по сработавшему сигналу. Чтобы приступить к настройке, необходимо поставить флажок "Разрешить" и заполнить следующие поля:

  • SMTP Сервер — адрес используемого SMTP-сервера и порта. Этот сервер будет использоваться для отсылки сообщения. Запись должна быть в формате "[интернет-адрес сервера] : [номер порта]". Например, "smtp.mail.ru:25", где "smtp.mail.ru" — адрес сервера, а "25" — номер порта.

  • Логин — логин для авторизации на почтовом сервере. Обычно это электронный ящик. Пример: your_name@mail.ru

  • Пароль — пароль для авторизации (пароль доступа к электронному ящику).

  • От кого — адрес электронной почты, с которого будут отсылаться сообщения. В этом поле необходимо прописать имя и адрес электронного ящика на том же почтовом сервере, SMTP-протокол которого будет использоваться. Как правило, имя совпадает с первой частью электронного адреса, но может отсутствовать. Пример: your_name, your_name@mail.ru

  • Кому — адрес электронной почты, на который будут отсылаться сообщения. Часть адреса «Ваше имя» может отсутствовать. В общем случае в поле «Кому» указывается любой существующий электронный адрес. Пример: any_name, your_name@mail.ru

Внимание: в поля "От кого" и "Кому" можно записать только по одному адресу. Несколько адресов, написанных с разделителями или без них, восприниматься не будут.

Кнопка "Тест" отсылает тестовое письмо с использованием указанных настроек, что позволяет проверить их работоспособность. В случае успешной проверки необходимо нажать кнопку "ОК", чтобы применить эти настройки. В случае неудачной проверки рекомендуется проверить еще раз все настройки, перезапустить терминал и повторно отослать тестовое сообщение.


Настройки клиентского терминала — Публикация

Вкладка Публикация

Терминал позволяет автоматически публиковать отчеты о состоянии счета в интернете. Для этого небходимо настроить параметры соединения с интернет-узлом по FTP-протоколу. Это можно сделать во вкладке "Публикация":

  • Разрешить — флажок включает поддержку публикации отчетов. Если флажок не выставлен, остальные поля недоступны;

  • Номер счета — номер счета, отчет по которому требуется опубликовать;

    Внимание: публикации подлежат только отчеты активного счета. Если номер введенного в этом поле счета не совпадёт с текущим, отчеты публиковаться не будут.

  • Обновлять каждые — периодичность отправки отчета на веб-сервер (указывается количество минут);

  • FTP сервер — адрес FTP-сервера, на который будет отправляться отчет. Пример: ftp.your_domain_name.com

  • FTP каталог — имя каталога на FTP-сервере, в который помещается отчет. В этом поле необходимо указать путь (начиная с корневого каталога), по которому будет посылаться отчет. Пример: /report_shots

  • FTP логин — логин для авторизации на FTP-сервере.

  • FTP пароль — пароль доступа к FTP-серверу.

  • Пассивный режим передачи данных — переключить из активного режима передачи данных в пассивный.
    В активном режиме на клиентском терминале выделяется свободный порт (из динамического диапазона 1024-65535), к которому подключается сервер, чтобы установить соединение для передачи данных. FTP-сервер подключается к заданному номеру порта клиента, используя со своей стороны номер TCP-порта 20 для передачи данных. В пассивном режиме сервер сообщает клиенту номер TCP-порта (из динамического диапазона 1024-65535), к которому можно подключиться для установки соединения и передачи данных.

    Главное различие между активным и пассивным режимами FTP — это сторона, которая открывает соединение для передачи данных. В активном режиме клиент должен принять соединение от FTP-сервера. В пассивном режиме клиент всегда инициирует соединение, а сервер принимает его.

Кнопка "Тест" отсылает отчет о состоянии активного счета с использованием указанных настроек, что позволяет проверить их работоспособность. В случае успешной проверки необходимо нажать кнопку "ОК", чтобы настройки вступили в силу. В случае неудачной проверки рекомендуется проверить все настройки еще раз и провести повторный тест.


Настройки клиентского терминала — События

Вкладка События

В терминале можно настраивать оповещения о системных событиях (не путать с сигналами). Это очень удобное средство, информирующее об изменениях состояния терминала. В этой вкладке можно настроить оповещения. Для этого необходимо сначала выставить флажок "Разрешить". При этом таблица со списком системных событий и соответствующих действий станет активной. К системным событиям относятся:

  • Connect — соединение с сервером. Оповещение об успешном соединении с сервером;

  • Disconnect — отсутствие связи с сервером. Оповещение о том, что связь с сервером прервалась;

  • Email Notify — получение сообщения по электронной почте. Если сработало это оповещение, рекомендуется проверить окно "Терминал — Почта";

  • Timeout — на выполнение торговых операций отводится определенное время. Если по какой-то причине этот период времени был превышен, операция не совершится, и сработает это оповещение;

  • OK — успешное совершение торговой операции. При выполнении торговой операции не произошло никаких ошибок;

  • News — получение новостей. Если сработало это оповещение, рекомендуется проверить окно "Терминал — Новости";

  • Expert Advisor — это оповещение срабатывает при выполнении советником любой торговой операции;

  • Expert Confirmation — запрос советником подтверждения торговой операции. Такое оповещение может сработать только в том случае, если опция "Ручное подтверждение" включена;

  • Alert — выполнение советником функции Аlert();

  • Requote — изменение цены во время подготовки торговой операции;

  • Trailing Stop — срабатывание одноименного ордера.

Если требуется отключить какое-либо из оповещений, необходимо дважды щелкнуть левой кнопкой мыши на его названии или пиктограмме. Чтобы вновь активизировать его, также необходим двойной клик. При срабатывании оповещения запускается файл, указанный в поле "Действие" соответствующего события. Дважды кликнув на названии файла можно сменить его. При этом появится выпадающий список с доступными файлами, которые назначаются на события. Выбор любого файла в этом списке с последующим нажатием клавиши Enter означает его назначение соответствующему событию. Для подтверждения всех сделанных изменений необходимо нажать кнопку "ОК".

Внимание: в качестве оповещения событию может быть назначен любой исполняемый в операционной системе файл.


Руководство пользователя

Пользовательский интерфейс

Пользовательский интерфейс

Интерфейс терминала включает следующие элементы:

  • Заголовок общего окна
    В заголовке программы указываются номер текущего счета, имя приложения, а также имя активного окна графика и его период.

  • Главное меню
    В главном меню собраны все команды и функции, которые можно выполнять в клиентском терминале. В главное меню программы входят: "Файл", "Вид", "Вставка", "Графики", "Сервис", "Окно", "Справка".
    Более детальная информация находится в разделе "Главное меню".

  • Панели инструментов
    В терминал встроены четыре панели инструментов: "Стандартная", "Графики", "Графические инструменты" и "Период графика". В панелях продублированы основные команды и функции главного меню. Однако эти панели - настраиваемые, и в них можно собрать только наиболее часто используемые элементы управления.
    Более детальная информация находится в разделе "Панели инструментов".

  • Обзор Рынка
    В данном окне представлен список финансовых инструментов. При помощи команд этого окна можно управлять торговыми позициями и графиками.
    Более детальная информация находится в разделе "Обзор рынка".

  • Окно данных
    В этом окне отображается информация о ценах, а также о наложенных индикаторах и советниках. Это информационное окно не позволяет совершать каких-либо действий.
    Более детальная информация находится в разделе "Окно данных".

  • Навигатор
    В навигационном окне сгруппированы открытые счета, советники, индикаторы и скрипты. При помощи окна "Навигатор" можно быстро управлять этими объектами.
    Более детальная информация находится в разделе "Навигатор".

  • Терминал
    Терминал — это многофункциональное окно, предназначенное для работы с торговыми позициями, новостями, историей счета, алертами, внутренней почтой, а также логами программы и советников. Кроме того, окно "Терминал" позволяет открывать и модифицировать различные ордера и управлять торговыми позициями.
    Более детальная информация находится в разделе "Терминал".

  • Тестер
    Данное окно предназначенно для тестирования советников. Кроме тестирования и просмотра различных отчетов, в окне также можно производить оптимизацию параметров эксперта.
    Более детальная информация находится в разделе "Тестер".

  • Ценовые графики
    Ценовой график — основа анализа данных. Кроме динамики цен, на графике могут располагаться различные аналитические объекты: линейные инструменты, технические и пользовательские индикаторы, текст и геометрические фигуры.
    Более детальная информация находится в разделе "Работа с графиками".

  • Статусная строка
    Для визуализации дополнительной информации в терминале дополнительно используется статусная строка. В строке расположены индикатор подключения к серверу, наименование активных шаблона и профиля, а также отображаются подсказки команд и ценовые данные.

  • Средства быстрой навигации
    Для быстрой работы с терминалом предназначены горячие клавиши, клавиши-акселераторы и строка быстрой навигации. Управление при помощи клавиш позволяет оперативно выполнять различные команды программы, а строка быстрой навигации позволяет точно перемещать график по временной оси, менять его период и даже сам инструмент.
    Более детальная информация находится в разделе "Средства быстрой навигации"


Пользовательский интерфейс — Главное меню

Главное меню

Главное меню терминала расположено под заголовком программы и представляет собой набор меню более низкого уровня. В нём собраны все команды и функции, которые можно выполнять в клиентском терминале. Главное меню состоит из:

  • Файл
    Работа с графиками, управление профилями, сохранение исторических данных и графиков, а также печать.

  • Вид
    Настройка панели инструментов, управление служебными окнами ( "Обзор рынка", "Окно данных", "Навигатор", "Терминал", "Тестер") и язык интерфейса программы.

  • Вставка
    Управление техническими индикаторами, линейными инструментами, и другими объектами.

  • Графики
    Настройка отображения баров, масштаб, управление наложенными объектами, наличие сетки, свойства графика.

  • Сервис
    Общие настройки клиентского терминала, архив котировок, глобальные переменные и MetaEditor (редактор MetaQuotes Language 4).

  • Окно
    Список открытых графиков и их расположение.

  • Справка
    Руководство пользователя и информация о программе.


Главное меню — Файл

Меню Файл

В этом меню объединены команды для работы с графиками, управления профилями, сохранения исторических данных и графиков, а также печать графиков. В меню доступны следующие команды:

  • Новый график — открыть новое окно графика финансового инструмента. При выполнении команды появляется список доступных финансовых инструментов. Выбрав один из инструментов списка, можно открыть новый график.
    Для выполнения тех же действий можно воспользоваться кнопкой New Chart панели инструментов "Стандартная";

  • Открыть автономно — открыть график инструмента в оффлайне. По команде можно будет выбрать необходимый файл с сохраненными историческими данными. При этом новые котировки по данному инструменту отображаться на графике не будут. Оффлайновый график может быть полезен при тестировании советников;

  • Открыть удаленный — восстановить удаленный график. Сохранение удаленных графиков происходит, если в настройках терминала выставлен флажок "Сохранять удаленные окна для повторного открытия". В каталоге /DELETED сохраняются все шаблоны удаленных графиков. При выполнении данной команды происходит обращение к этим шаблонам, и открывается соответствующий график;

  • Профили — открыть подменю управления профилями. В этом подменю можно сохранять или удалять профили, а также загружать ранее сохранённые.
    Вызвать подменю управления профилями можно также кнопкой Вызвать меню управления профилями панели инструментов "Стандартная".
    Более детальная информация находится в разделе "Профили и шаблоны";

  • Закрыть — закрыть активный график;

  • Сохранить как — сохранить исторические данные в виде текстового файла форматов "CSV", "PRN" и "HTM";

  • Сохранить как рисунок — сохранить изображение графика в формате "BMP" или "GIF".
    Те же действия выполняются одноименной командой контекстного меню графика;

  • Открыть счет — открытие нового демонстрационного счета. Такие счета открываются без внесения денежных средств на депозит и позволяют качественно отработать свою торговую систему.

    Чтобы открыть счет, также можно выполнить одноименную команду контекстного меню окна "Навигатор — Счета" или нажать клавишу Insert;

  • Логин — авторизоваться. При выполнении этой команды происходит попытка подключения к серверу с использованием выбранного аккаунта. В случае успешной авторизации в терминал начнут поступать котировки и новости, можно будет совершать торговые операции.
    Также можно авторизоваться, выполнив команду "Логин" контекстного меню окна "Навигатор — Счета" или дважды щёлкнув на наименовании счета;

  • Настройка печати — общая настройка параметров печати — выбор принтера, размер бумаги, ориентация страницы и так далее;

  • Предварительный просмотр — просмотр графика перед печатью. При этом используются настройки выбранного принтера. При помощи этой команды перед печатью можно проверить, все ли требуемые данные попадут на бумагу.
    Те же действия можно выполнить, нажав на кнопку Предварительный просмотр графика панели инструментов "Стандартная" или выполнив одноименную команду контекстного меню графика;

  • Печать — печать графика. Если в настройках программы включена опция "Цветная печать", можно распечатать не черно-белый график, а цветной.
    Те же действия можно выполнить, нажав на кнопку Печать графика панели инструментов "Стандартная", клавиши-акселераторы Ctrl+P или выполнив команду контекстного меню графика "Печать";

  • Выход — закрыть терминал.

    Внимание: при выключенном терминале советники и трейлинг стопы не исполняются.


Главное меню — Вид

Меню Вид

В этом меню сгруппированы команды управления служебными окнами, панелями инструментов и языком интерфейса программы. Часть этих команд продублирована на панели инструментов "Стандартная". В меню доступны следующие команды:

  • Languages — вызвать подменю управления языками клиентского терминала. Выбрав требуемый язык из списка, можно переключить интерфейс терминала на него. Чтобы изменения вступили в силу, необходимо перезапустить программу;

  • Панели инструментов — вызвать подменю управления панелями инструментов. Галочкой помечены активные панели инструментов. Выбрав любую панель, можно включить или выключить ее.
    Также командой "Настроить панель инструментов" можно любой панели назначить любые кнопки. При этом появится новое окно с перечнем доступных элементов панели инструментов. Кнопки "Включить" и "Удалить" позволяют добавить или убрать элемент с панели. Кнопки "Вверх" и "Вниз" предназначены для определения положения кнопок на панели. Чтобы вернуть вид панели инструментов к первоначальному состоянию, необходимо нажать кнопку "Сброс";

  • Статусная строка — включить/выключить статусную строку, расположенную в нижней части окна терминала. В этой информационной строке расположены (слева направо): меню управления профилями, время и цены выбранного бара, а также индикатор подключения к серверу и объем входящего/исходящего трафика. Нажав на наименование текущего профиля, можно открыть меню управления профилями. В этом подменю можно сохранять или удалять профили, а также загружать ранее сохраненные.
    Подменю управления профилями можно также вызвать командой меню "Файл — Профили";

  • Панель переключения графиков — включить/выключить строку заголовков (вкладок) окон графиков, расположенную в нижней части рабочего пространства. При помощи этой строки можно быстро переключаться между открытыми графиками;

  • Обзор рынка — открыть/закрыть служебное окно "Обзор рынка", в котором публикуются текущие котировки.
    То же действие можно выполнить при помощи клавиш-акселераторов Ctrl+M либо при помощи кнопки Обзор рынка панели инструментов "Стандартная";

  • Окно данных — открыть/закрыть "Окно данных". В этом окне публикуются цены выбранного бара и информация о наложенных индикаторах.
    То же действие можно выполнить при помощи клавиш-акселераторов Ctrl+D либо кнопки Окно данных панели инструментов "Стандартная";

  • Навигатор — открыть/закрыть окно "Навигатор". В нем в виде дерева расположены списки открытых счетов, технических индикаторов, экспертов, собственных индикаторов и скриптов.
    То же действие можно выполнить при помощи клавиш-акселераторов Ctrl+N либо кнопки Навигатор панели инструментов "Стандартная";

  • Терминал — открыть/закрыть окно "Терминал". В этом окне можно управлять ордерами и сигналами, просматривать историю счета, новости, почтовые сообщения, журнал событий и журнал советников.
    То же действие можно выполнить при помощи клавиш-акселераторов Ctrl+T либо кнопки Terminal панели инструментов "Стандартная";

  • Тестер стратегий — открыть/закрыть окно "Тестер". Это окно предназначено для тестирования и оптимизации советников.
    То же действие можно выполнить при помощи клавиш-акселераторов Ctrl+R либо кнопки Тестирование Стратегий панели инструментов "Стандартная";

  • Полный экран — включить/выключить полноэкранный режим. При включении этой опции происходит отключение панелей инструментов, статусной строки и закрытие всех служебных окон. На экране остаются строка заголовка клиентского терминала, главное меню, рабочая область (графики) и вкладки окон графиков. При повторном выполнении команды происходит возврат к исходному состоянию.
    То же действие можно выполнить при помощи клавиши F11 либо кнопки Full Screen панели инструментов "Стандартная".


Главное меню — Вставка

Меню Вставка

В меню "Вставка" собраны объекты, накладываемые на график. К ним относятся линейные инструменты и технические индикаторы, а также геометрические фигуры, значки и текст. В подменю "Индикаторы" сгруппированы все встроенные технические индикаторы. Выбрав наимнование в списке, можно наложить индикатор на активный график. Линейные инструменты сгруппированы в соответствующем подменю: "Линии" — различные линии, "Каналы" — набор каналов, "Ганн" — инструменты Ганна, "Фибоначчи" — инструменты, построенные на основе ряда Фибоначчи. Кроме того, в конце списка находятся не вошедшие ни в одну из групп "Вилы Эндрюса" и "Циклические Линии". Более детальная информация по работе с линейными инструментами описана в соответствующем разделе.

Кроме того, из этого меню на график можно накладывать:

  • Фигуры — геометрические фигуры (прямоугольник, треугольник и эллипс), позволяющие выделять различные области на ценовом графике;

  • Значки — символы (стрелочки, значки проверки, остановки, ценовые метки), позволяющие выделять на графике наиболее значимые точки;

  • Текст — текст, предназначенный для добавления комментариев на график. Он привязывается к графику и при прокрутке графика перемещается вместе с ним;

  • Текстовая Метка — текст, предназначенный для добавления комментариев и привязанный к координатам окна, а не графика. При прокрутке графика текстовая метка не перемещается.

Внимание: все команды меню "Вставка", кроме подменю управления индикаторами, продублированы на панели "Графические инструменты".


Главное меню — Графики

Меню Графики

В меню "Графики" объединены команды управления графиком и наложенными на него техническими индикаторами. В этом меню доступны следующие команды:

  • Список индикаторов — вызвать окно управления индикаторами, наложенными на активный график. В появившемся окне приводится полный список наложенных индикаторов (включая Собственные Индикаторы). Выделив индикатор, можно изменить его настройки или удалить с графика.
    То же действие можно выполнить одноименной командой контекстного меню графика или при помощи клавиш-акселераторов Ctrl+I;

  • Объекты — вызвать подменю управления наложенными объектами. В подменю доступны следующие команды:

    • Список Объектов — вызвать окно управления наложенными объектами. К объектам относятся: линейные инструменты, значки, фигуры и текст. В этом окне можно изменить (кнопка "Правка") или удалить выбраный объект, нажав одноименную кнопку. Кроме того, команда "Показать" перемещает активный график к месту наложения выбранного объекта;

    • Удалить последний — удалить из окна графика объект, нанесенный последним.
      Это же действие можно выполнить нажатием клавиши Backspace;

    • Удалить все выделенные — удалить из окна графика все выделенные объекты.
      Это же действие можно выполнить нажатием клавиши Delete;

    • Удалить все объекты — удалить из окна графика все объекты;

    • Снять все выделения — снять выделение со всех нанесенных на график объектов;

    • Отменить удаление — вернуть на график удаленный объект.
      Это же действие можно выполнить при помощи клавиш-акселераторов Ctrl+Z;

  • Бары — представить график в виде последовательности баров.
    Выполнение данной команды аналогично нажатию кнопки Bar Chart панели инструментов "Графики" или клавиш-акселераторов Alt+1;

  • Японские свечи — представить график в виде последовательности "японских свечей".
    Выполнение данной команды аналогично нажатию кнопки Candlesticks панели инструментов "Графики" или клавиш-акселераторов Alt+2;

  • Линия — представить график в виде ломаной линии, соединяющей цены закрытия баров.
    Выполнение данной команды аналогично нажатию кнопки Line Chart панели инструментов "Графики" или клавиш-акселераторов Alt+3;

  • График сверху — график "первым планом". Если эта функция включена, все аналитические объекты (технические индикаторы и графические объекты) располагаются "под графиком", а не поверх его;

  • Период — выбрать период графика. После выполнения этой команды появится подменю, в котором можно выбрать период активного графика.
    Период графика можно также изменить, воспользовавшись панелью управления "Период";

  • Шаблон — вызвать подменю управления шаблонами. Из этого подменю на активный график можно наложить любой шаблон. Кроме того, можно сохранить новый шаблон на основе активного графика или удалить уже имеющийся.

    Внимание: шаблон DEFAULT удалить нельзя.

    Более детальная информация о работе с шаблонами находится в разделе "Профили и шаблоны".
    Вызвать подменю управления шаблонами можно также нажатием кнопки Профили панели инструментов "Графики" либо одноименной командой контекстного меню графика;

  • Обновление — обновить исторические данные. При этом произойдет загрузка всех недостающих данных в пределах имеющейся истории. То же действие можно выполнить одноименной командой контекстного меню графика;

    Внимание: история за пределами уже имеющихся данных подгружаться не будет.

  • Сетка — показать/скрыть сетку в окне графика.
    Эти же действия можно выполнить одноименной командой контекстного меню графика и нажатием клавиши-акселератора Ctrl+G;

  • Объемы — показать/скрыть объемы на графике.
    Эти же действия можно выполнить одноименной командой контекстного меню графика или нажатием клавиши-акселератора Ctrl+L;

  • Автопрокрутка — разрешить/запретить автоматически смещать график влево после начала формирования нового бара. Если эта опция включена, на графике всегда отображается последний бар.
    Выполнение данной команды аналогично нажатию кнопки Функция "Auto Scroll" панели "Графики";

  • Сдвиг графика — отодвинуть график от правого края окна до метки сдвига графика. Метку сдвига графика (серый треугольник в верхней части окна) можно перемещать мышкой по горизонтали в пределах 10 — 50% размера окна.
    Выполнение данной команды аналогично нажатию кнопки Функция "Chart Shift" панели "Графики";

  • Увеличение — увеличить масштаб графика.
    Это же действие можно выполнить нажатием клавиши "+" или кнопки Zoom In панели "Графики", а также перемещая курсор вправо при нажатой на горизонтальной шкале левой кнопке;

  • Уменьшение — уменьшить масштаб графика.
    Это же действие можно выполнить нажатием клавиши "-" или кнопки Zoom Out панели "Графики", а также перемещая влево курсор при нажатой на горизонтальной шкале левой кнопке;

  • Шаг за шагом — сдвинуть график на один бар влево.
    Это же действия можно выполнить нажатием клавиши F12;

  • Свойства — настройка параметров графика. По выполнении этой команды появится окно настройки графика.
    Те же действия можно выполнить одноименной командой контекстного меню графика и клавишей F8.

Внимание: большинство команд меню "График" продублировано на одноименной панели инструментов и в контекстном меню графика.


Главное меню — Сервис

Меню Сервис

В меню "Сервис" объединены служебные команды и настройки терминала. В этом меню можно:

  • Новый ордер — вызвать окно управления ордерами. Из этого окна можно выставлять рыночные или отложенные ордера. Более детальная информация по работе с ордерами находится в соответствующем разделе.
    Окно "Ордер" можно также вызвать командами контекстного меню окон "Обзор рынка" и "Терминал — Торговля", двойным щелчком мыши на финансовом инструменте в окне "Обзор рынка", клавишей F9 или нажатием кнопки Новый ордер панели инструментов "Стандартная";

  • Архив котировок — вызвать окно управления историческими данными. В архиве котировок можно редактировать котировки, которые используются для построения графиков.
    Вызвать это окно можно также нажатием клавиши F2;

  • Глобальные переменные — вызвать окно со списком глобальных переменных терминала. Глобальными называются переменные, общие для всех советников, пользовательских индикаторов и скриптов. Более детальная информация по глобальным переменным находится в соответствующем разделе.
    Окно управления глобальными переменными можно также вызвать клавищей F3;

  • Редактор MetaQuotes Language — открыть редактор советников MetaEditor. При помощи редактора MetaEditor можно создавать и редактировать эксперты, собственные индикаторы и скрипты. Более детальное описание работы с MetaEditor приведено в одноименном разделе.
    Редактор Советников можно также вызвать клавишей F4;

  • Настройки — вызвать окно настройки параметров клиентского терминала. В этом окне можно установить параметры подключения, торговли, графиков, экспертов и другие. Более детальная информация находится в разделе "Настройки клиентского терминала".
    Окно настроек можно также вызвать клавишами-акселераторами Ctrl+O.


Главное меню — Окно

Меню Окно

В этом меню объединены команды управления окнами графиков. Отсюда можно выбрать способ расположения графиков в рабочей области или открыть новое окно:

  • Новое окно — создать новое окно графика финансового инструмента. По выполнении команды откроется подменю, содержащее список доступных финансовых инструментов. Выбрав наименование инструмента из списка, можно открыть соответствующий график.
    Открыть новое окно можно также нажатием кнопки New Chart панели инструментов "Стандартная" или командой меню "Файл — Новый график";

  • Каскадом — расположить окна графиков каскадом;

  • Горизонтально — расположить окна графиков горизонтально;

  • Вертикально — расположить окна графиков вертикально;

  • Разместить значки — упорядочить свернутые окна. При этом окна всех открытых графиков сворачиваются и располагаются в нижней части рабочей области. Это бывает полезно при одновременной работе с множеством графиков.

В нижней части данного меню расположен список всех открытых окон графиков. Галочкой отмечено активное окно. Чтобы активировать другой график, необходимо выбрать соответствующий инструмент из этого списка.


Главное меню — Справка

Меню Справка

Меню "Справка" — вспомогательное. Выполнение команд этого меню не оказывает никакого влияния на работу терминала. Из этого меню можно:

  • Вызов справки — открыть встроенный справочник, содержащий данное "Руководство пользователя". В нем описаны все настройки и функции клиентского терминала.
    Клавиша F1 выполняет то же действие;

  • О программе — открыть окно "О программе", где можно найти информацию о компании, ее координатах, а также о версии терминала.


Пользовательский интерфейс — Панели инструментов

Панели инструментов

В терминал встроено четыре панели инструментов. На них в виде кнопок продублированы основные команды терминала. Обычно панели инструментов располагаются под главным меню, но они являются плавающими, и их можно располагать в любой области окна программы. Показать или скрыть панели инструментов можно командой меню "Вид — Панели инструментов". Все панели являются настраиваемыми, что позволяет помещать на них только необходимые, часто используемые команды. Для настройки панели необходимо открыть ее контекстное меню (щелчок правой кнопкой мыши) и выполнить команду "Настроить панель инструментов".

Все команды сгруппированы в панелях инструментов по их назначению:

  • Стандартная — общие команды управления терминалом;

  • Графики — команды управления графиками;

  • Графические инструменты — управление объектами, накладываемыми на графики;

  • Период — управление периодом графиков.


Панели инструментов — Стандартная

Панель инструментов Стандартная

В этой панели объединены общие команды управления терминалом:

  • Открыть график финансового инструмента — создать новое окно графика финансового инструмента. По команде открывается список финансовых инструментов, выбрав в котором требуемое наименование, можно открыть новый график.
    Те же действия происходят после выполнения команд меню "Файл — Новый график" и "Окно — Новое окно", а также команды контекстного меню окна "Обзор рынка — Окно графика";

  • Управление профилями — меню управления профилями. Выбрав в этом меню требуемый профиль, можно активировать его. Также из этого меню можно удалить профиль или на базе текущей конфигурации окон графиков сохранить новый. Более детальная информация находится в разделе "Профили и шаблоны".

    Внимание: профиль DEFAULT удалить нельзя.

    Для работы с профилями можно также выполнить команду меню "Файл — Профили";

  • Окно "Обзор рынка" — открыть/закрыть окно "Обзор рынка". В этом окне публикуются текущие котировки по всем доступным иснтрументам. Из него можно открывать графики инструментов и выставлять ордера. Более детальная информация о работе с этим окном приводится в разделе "Обзор рынка".
    Команда меню "Вид — Обзор рынка" и клавиши-акселераторы Ctrl+M также позволяют открыть или закрыть данное окно;

  • Окно "Окно данных" — открыть/закрыть информационное "Окно данных". В этом окне публикуется информация о ценах и наложенных индикаторах. Более детальная информация о работе с этим окном приводится в разделе "Окно данных".
    Команда меню "Вид — Окно данных" и клавиши-акселераторы Ctrl+D также позволяют открыть или закрыть данное окно;

  • Окно "Навигатор" — открыть/закрыть окно "Навигатор". В этом окне располагаются все открытые счета, доступные советники, технические индикаторы и скрипты. Более детальная информация о работе с этим окном приводится в разделе "Навигатор".
    Команда меню "Вид — Навигатор" и клавиши-акселераторы Ctrl+N также позволяют открыть или закрыть данное окно;

  • Окно "Терминал" — открыть/закрыть окно "Терминал". Это окно позволяет выставлять торговые ордера, просматиривать историю счета, получать новости и многое другое. Более детальная информация о работе с этим окном приводится в разделе "Терминал".
    Команда меню "Вид — Терминал" и клавиши-акселераторы Ctrl+T также позволяют открыть или закрыть данное окно;

  • Окно "Тестер" — открыть/закрыть окно "Тестер". Это окно предназначено для тестирования и оптимизации советников. Более детальная информация по работе с этим окном приводится в разделе "Тестирование стратегий".
    Команда меню "Вид — Тестер стратегий" и клавиши-акселераторы Ctrl+R также позволяют открыть или закрыть данное окно;

  • Новый ордер — новый ордер. По команде открывается окно, при помощи которого можно выставить рыночный или отложенный ордер. Более детальная информация находится в разделе "Торговля".
    Это окно можно открыть также командой меню "Сервис — Новый ордер", командами контекстного меню окна "Обзор рынка — Новый ордер" либо окна "Терминал — Торговля — Новый ордер", а также клавишей F9;

  • Редактор MetaEditor — запустить редактор советников MetaEditor. Этот редактор позволяет создавать и редактировать советники, собственные индикаторы, скрипты и библиотеки MQL 4. Более детальная информация о работе с редактором советников приводится в разделе "MetaEditor" и в собственной справке программы-редактора.
    Данное действие можно выполнить также командой меню "Сервис — Редактор MetaQuotes Language" либо клавишей F4;

  • Разрешить/запретить использование советников — разрешить использование советников. Если эта опция отключена, ни один прикрепленный к графикам эксперт выполняться не будет. Детальное описание работы с экспертами находится в разделе "Автотрейдинг".
    Опция "Включить Советников" в настройках терминала выполняет то же действие;

  • Настройки терминала — вызвать окно настройки терминала. В этом окне производятся все базовые настройки терминала. Более детальная информация приведена в одноименном разделе.
    Окно настроек терминала можно также открыть командой меню "Сервис — Настройки" либо клавишами-акселераторами Ctrl+O;

  • Полноэкранный режим — включить/выключить полноэкранный режим. При включении этой опции происходят отключение панелей инструментов, статусной строки и закрытие всех служебных окон. На экране остаются строка заголовка клиентского терминала, главное меню, рабочая область (графики) и вкладки окон графиков. При повторном выполнении команды происходит возврат к исходному состоянию.
    Те же действия можно выполнить клавишей F11 либо командой меню "Вид — Полный экран";

  • Печать графика — печать графика. Если в настройках программы включена опция "Цветная печать", можно распечатать не черно-белый график, а цветной.
    То же действие можно выполнить командой меню "Файл — Печать" либо одноименной командой контекстного меню графика;

  • Предварительный просмотр — предварительный просмотр графика перед печатью. При этом используются настройки выбранного принтера. Таким образом, перед печатью можно проверить, все ли требуемые данные попадут на бумагу.
    То же действие можно выполнить командой меню "Файл — Предварительный просмотр" либо одноименной командой контекстного меню графика;

  • Вызов Справки — вызов справки. После нажатия этой кнопки необходимо кликнуть на интересующий элемент интерфейса, чтобы вызвать соответствующий раздел справки.
    Вызвать справку можно также командой меню "Справка — Вызов справки" либо клавишей F1.


Панели инструментов — Графики

Панель инструментов Графики

На этой панели сгруппированы команды управления графиком и наложенными на него техническими индикаторами. К ним относятся:

  • Баровый (столбиковый) график — представить график в виде последовательности баров (преобразовать в баровый).
    То же действие можно выполнить командой меню "Графики — Бары" или при помощи клавиш-акселераторов Alt+1;

  • График свечей — представить график в виде последовательности японских свечей (преобразовать в график японских свечей).
    То же действие можно выполнить командой меню "Графики — Японские свечи" или при помощи клавиш-акселераторов Alt+2;

  • Линейный график — представить график в виде линии (преобразовать в линейный график).
    То же действие можно выполнить командой меню "Графики — Линия" или при помощи клавиш-акселераторов Alt+3;

  • Увеличить масштаб графика — увеличить масштаб графика.
    То же действие можно выполнить командой меню "Графики — Увеличить", соответствующей командой контекстного меню графика либо клавишей "+";

  • Уменьшить масштаб графика — уменьшить масштаб графика.
    То же действие можно выполнить командой меню "Графики — Уменьшить", соответствующей командой контекстного меню графика либо клавишей "-";

  • Автопрокрутка графика — автоматическая прокрутка графика к последним барам. Если эта опция включена, на экране всегда будут отображаться последние бары.
    То же действие можно выполнить командой меню "Графики — Автопрокрутка";

  • Смещение графика — отодвинуть график от правого края окна до метки сдвига графика. Метку сдвига графика (серый треугольник в верхней части окна) можно перемещать мышкой по горизонтали в пределах 10-50% размера окна.
    То же действие можно выполнить командой меню "Графики — Сдвиг графика";

  • Индикаторы — вызвать подменю управления индикаторами. В нем сгруппированы все встроенные технические индикаторы. Выбрав наименование в списке, можно наложить индикатор на активный график. Более детальная информация находится в разделе "Технические индикаторы".
    То же действие можно выполнить командой меню "Вставка — Индикаторы";

  • Период графика — подменю управления периодом графика. При выборе периода в этом подменю соответствующие изменения происходят в активном графике.
    Переключить период графика можно командой меню "Графики — Период", соответствующей командой контекстного меню графика либо соответствующими кнопками панели инструментов "Период";

  • Профили — вызвать подменю управления шаблонами. Из этого подменю на активный график можно наложить любой шаблон. Кроме того, можно сохранить новый шаблон на основе активного графика или удалить уже имеющийся шаблон. Более детальная информация о работе с шаблонами находится в разделе "Шаблоны и профили".
    То же действие можно выполнить командой меню "Графики — Шаблон" либо соответствующей командой контекстного меню графика.

Внимание: большинство команд панели инструментов "График" продублировано в одноименном меню и в контекстном меню графика.


Панели инструментов — Графические инструменты

Панель Графические инструменты

На панели "Графические инструменты" собраны линейные инструменты и графические объекты (геометрические фигуры, значки и текст), накладываемые на график. Команды этой панели инструментов (за исключением "Перекрестья" и "Курсора") продублированы в меню "Вставка". Работа с линейными инструментами детально описана в соответствующем разделе. Оставшиеся значки панели инструментов предназначены для работы с графическими объектами и для изменения режима работы курсора:

  • Эллипс — нарисовать эллипс. При помощи этой фигуры можно выделять различные области на графике. Более детальная информация о работе с объектами приведена в одноименном разделе.
    Команда меню "Вставка — Фигуры — Эллипс" также позволяет нарисовать эту фигуру;

  • Треугольник — нарисовать треугольник. При помощи этой фигуры можно выделять различные области на графике. Более детальная информация о работе с объектами приведена в одноименном разделе.
    Команда меню "Вставка — Фигуры — Треугольник" также позволяет нарисовать эту фигуру;

  • Прямоугольник — нарисовать прямоугольник. При помощи этой фигуры можно выделять различные области на графике. Более детальная информация о работе с объектами приведена в одноименном разделе.
    Команда меню "Вставка — Фигуры — Прямоугольник" также позволяет нарисовать эту фигуру;

  • Текстовая метка — добавить текстовую метку. После нажатия этой кнопки следует выбрать место на графике, в которое необходимо поставить метку. В отличие от комментария (описано ниже), метка прикрепляется не к графику, а к окну графика. При прокрутке графика текстовая метка не перемещается.
    Командой меню "Вставка — Текстовая Метка" также можно добавить текстовую метку в окно графика;

  • Комментарий — добавить комментарий на график. Он привязывается непосредственно к графику. При прокрутке графика комментарий перемещается вместе с ним.
    Командой меню "Вставка — Текст" можно также добавить комментарий на график;

  • Символы — меню управления графическими символами. Из этого меню можно добавить графические символы на график или удалить все нанесенные значки.
    Командой меню "Вставка — Значки" можно также нанести эти объекты на график;

  • Перекрестье — перекрестье. Курсор в этом режиме позволяет высвечивать координаты выбранной точки в окне графика или индикатора. Этот режим курсора действует только в пределах активного окна графика. Если в режиме "Перекрестье" нажать левую кнопку мыши и, не отпуская, переместить курсор, будет проведена линия, соединяющаяя две эти точки. Справа от второй точки линии будет высвечено расстояние от одной точки до другой и текущее значение цены. Запись будет иметь формат [количество баров между двумя точками] / [количество пунктов между двумя точками] / [текущее значение цены во второй точке]. Этот инструмент называется электронной линейкой.
    Также переключить курсор в режим перекрестья можно нажатием клавиш-акселераторов Ctrl+F или третьей кнопки мыши;

  • Режим выбора — стандартный режим (режим выбора). Курсор в этом режиме позволяет выделять различные объекты на графике.


Панели инструментов — Период

Панель инструментов Период

В этой панели инструментов сгруппированы переключатели периодов графиков. При нажатии кнопок панели в активном окне меняется период графика. Сразу после этого начинается подкачка данных по выбранным инструменту и периоду, что может занять некоторое время.


Пользовательский интерфейс — Обзор рынка

Обзор Рынка

В окне "Обзор рынка" приводится список финансовых инструментов, по которым клиентский терминал получает котировки с сервера. Данные в окне представлены в виде таблицы с несколькими полями. В поле "Символ" приводится название финансового инструмента, в полях "Бид", "Аск" и "Время" — соответствующие цены и время их получения с сервера. Значения полей "Максимум" и "Минимум" вычисляются на основе динамики цен в течение дня. Окно "Обзор рынка" можно открыть/закрыть при помощи клавиш-акселераторов Ctrl+M, командой меню "Вид — Обзор рынка" либо кнопкой Открытие окна "Обзора рынка" из панели "Стандартная" панели инструментов "Стандартная".

При помощи этого окна можно выставлять рыночные и отложенные ордера, а также открывать новые графики. При нажатии правой кнопки мыши в области окна "Обзор рынка" появляется контекстное меню, в котором доступны следующие команды:

  • Новый ордер — открыть окно "Новый ордер", в котором можно подготовить и выставить рыночный или отложенный ордер по выбранному инструменту. Также при подготовке ордера можно указать уровни Stop Loss и Take Profit. Более детальная информация находится в разделе "Открытие позиций".
    Открыть окно "Новый ордер" можно также двойным щелчком на наименовании финансового инструмента в окне "Обзор рынка", командой меню "Сервис — Новый ордер", командой контекстного меню окна "Терминал — Торговля — Новый ордер", кнопкой Новый ордер панели инструментов "Стандартная" и клавишей F9;

  • Окно графика — открыть график выбранного финансового инструмента. Более детальная информация по работе с окнами графиков приводится в одноименном разделе.
    График финансового инструмента можно также открыть командами меню "Файл — Новый график" и "Окно — Новое окно" и кнопкой Открыть график финансового инструмента панели инструментов "Стандартная";

  • Тиковый график — открыть тиковый график выбранного финансового инструмента. В отличие от обычных графиков, тиковый располагается прямо в окне "Обзор рынка". Тиковый график выбранного инструмента можно также посмотреть, переключив в этом окне одноименную вкладку;

  • Удалить символ — удалить (скрыть) символ из списка. Для минимизации трафика рекомендуется исключить неиспользуемые инструменты из окна котировок при помощи этой команды или клавиши Delete.

    Внимание: если по финансовому инструменту имеются открытые позиции или отложеные ордера, а также если открыт график, символ удалить нельзя.

  • Скрыть все символы — удалить из списка все символы. Под действие этой команды не подпадают инструменты, по которым имеются открытые позиции, или графики которых были открыты в текущем сеансе работы;

  • Показать все символы — показать список всех доступных инструментов. После выполнения команды по всем этим инструментам начнут приходить котировки;

  • Символы — вызвать одноименное окно, в котором находится список всех доступных инструментов. Инструменты в окне сгруппированы в соответствии с их типами. Командой "Показать символ" можно добавить требуемые инструменты, а "Скрыть символ" — удалить инструмент из окна котировок. Команда окна "Свойства" позволяет просматривать параметры финансового инструмента;

  • Набор символов — открыть подменю управления набором символов. В этом подменю можно сохранить текущий набор символов, удалить или выбрать уже существующий. Это бывает очень удобно при работе с разными типами инструментов;

  • Максимум/Минимум — добавить к отображаемым котировкам максимальное и минимальное значения цены за день;

  • Время — показывать время прихода котировок;

  • Авторазмер столбцов — автоматическая установка размера столбцов при изменении размера окна.
    Авторазмер можно также включить клавишей A;

  • Сетка — показать/скрыть сетку для разделения колонок.
    Сетку можно также включить клавишей G;

  • Окно котировок — открыть дополнительное окно котировок. Список инструментов этого окна совпадает со списком в окне "Обзор рынка" на момент выполнения этой команды. То есть изменение списка инструментов окна "Обзор рынка" не влияет на список "Окна котировок". Это информационное окно, но из него также можно совершать торговые операции. Для этого необходимо дважды кликнуть левой кнопкой мыши на нужном инструменте. В контекстном меню этого окна находятся команды, позволяющие: настроить параметры отображения данных, включить полноэкранный режим или расположить окно поверх всех остальных.


Пользовательский интерфейс — Окно данных

Окно данных

Это окно предназначено для отображения информации о ценах (OHLC), дате и времени бара, а также об используемых индикаторах (включая пользовательские). "Окно данных" является информационным окном и не позволяет выполнять каких-либо действий. Здесь можно быстро получить требуемую информацию об отдельном баре и наложенных индикаторах. Для этого достаточно навести на него курсор.

Команды контекстного меню этого окна позволяют:

  • Копировать — копировать данные окна в буфер обмена для дальнейшего использования в других приложениях.
    То же действие можно выполнить нажатим клавиш-акселераторов Ctrl+C;

  • Последние данные — показать/скрыть колонку последних данных. При этом в окне появится дополнительный столбец с данными последнего бара;

  • Авторазмер столбцов — автоматически устанавливать размер столбцов при изменении размера окна;

  • Сетка — показать/скрыть сетку для разделения колонок;

  • Показать — показать/скрыть информационные поля. В появившемся подменю можно выбрать любую из цен бара (OHLC), дату или объем. Если элемент не отмечен галочкой, он отображаться не будет.

Внимание: любой индикатор можно настроить (вкладка "Отображение" в окне свойств индикатора) таким образом, что его данные не будут показываться в этом окне.


Пользовательский интерфейс — Навигатор

Окно Навигатор

Это окно позволяет быстро получить доступ к различным возможностям терминала. Это окно можно открыть/закрыть при помощи клавиш-акселераторов Ctrl+N, командой меню "Вид — Навигатор" либо кнопкой Окно "Навигатор" панели инструментов "Стандартная".

Список возможностей представлен в виде дерева и содержит пять групп: "Счета", "Индикаторы", "Советники", "Пользовательские Индикаторы" и "Скрипты". В группе "Счета" содержится список открытых счетов. При помощи контекстного меню можно открыть новый демонстрационный счет или удалить старый. Из терминала можно открыть неограниченное количество демонстрационных счетов. Для этого необходимо выполнить команду контекстного меню "Открыть счет" или нажать клавишу Insert. Более детальная информация об открытии счетов находится в соответствующем разделе. Чтобы авторизовать уже открытый счет (демонстрационный или реальный), необходимо выполнить команду "Логин" либо дважды щелкнуть левой кнопкой мыши на строке требуемого счета.

Внимание: реальные счета из терминала открыть нельзя, они открыватся только брокерской компанией.

В группе "Индикаторы" содержится список встроенных технических индикаторов. Они являются основным инструментом для анализа динамики цен. Двойным нажатием левой кнопки мыши или командой контекстного меню "Присоединить к графику" можно наложить выбранный индикатор на активный график. Кроме того, используя технологию "Drag'n'Drop", можно наложить аналитический инструмент на любой график или подокно уже наложенного индикатора. Более детальная информация приводится в разделе "Технические индикаторы".

В группе "Советники" содержится список всех доступных советников (экспертов). Советниками в терминале называются программы, позволяющие автоматизировать аналитическую и торговую деятельность. Для их создания и изменения используется встроенный редактор советников — MetaEditor. Более детальная информация о создании и работе с экспертами находится в разделе "Автотрейдинг".

Команда контекстного меню "Создать" позволяет создать новый советник, "Изменить" — редактировать существующий, а "Удалить" — удалить эксперт из терминала. Команда "Присоединить к графику" либо двойное нажатие левой кнопки мыши позволяют наложить советник на активный график. После этого, с приходом нового тика, он начинает исполняться. Используя технологию "Drag'n'Drop", можно накладывать советники на любой график. Окрашенные в серый цвет пиктограммы экспертов означают, что их использовать нельзя. Такой советник надо сначала скомпилировать.

В группе "Пользовательские Индикаторы" приведен список всех доступных пользовательских индикаторов (аналогов встроенных технических индикаторов), в группе "Скрипты" — список доступных скриптов (программ, выполняемых один раз). Управление пользовательскими индикаторами и скриптами при помощи контекстного меню аналогично управлению советниками. Более детальная информация находится в разделах "Пользовательские индикаторы" и "Скрипты".

Существует возможность назначать сочетания клавиш для вызова любых элементов окна "Навигатор", за исключением элементов группы "Счета". Чтобы назначить горячие клавиши элементу, необходимо выполнить команду "Назначить горячую клавишу" его контекстного меню. Назначенные горячие клавиши имеют больший приоритет по сравнению с предопределенными. Например, изначально сочетанию Ctrl+O соответствует вызов окна настройки терминала. Если этому же сочетанию назначить вызов индикатора On Balance Volume, то при нажатии Ctrl+O нельзя будет вызвать окно настройки терминала.

Вкладка Избранное

Вкладка "Избранное" предназначена для быстрого доступа к наиболее часто используемым объектам. В этой вкладке, например, можно разместить только необходимые счета, индикаторы, скрипты и советники. Это позволяет ускорить работу трейдера, особенно когда необходимо принимать оперативные меры. Чтобы переместить требуемый объект во вкладку "Избранное", необходимо выполнить соответствующую команду контекстного меню. Если объект больше не нужен, его можно удалить из вкладки при помощи команды контекстного меню "Удалить из избранного".

Внимание: все включенные в "Избранное" объекты могут выполнять свои функции без каких-либо ограничений. Все команды управления, располагаемые в контекстном меню, также могут быть вызваны прямо из этой вкладки.


Пользовательский интерфейс — Терминал

Окно Терминал

"Терминал" — многофункциональное окно, открывающее доступ к различным возможностям терминала. Это окно позволяет контролировать торговую деятельность, просматривать новости и историю счета, настраивать сигналы, а также работать с внутренней почтой и системным журналом. Окно может быть открыто командой меню "Вид — Терминалы", нажатием клавиш-акселераторов Ctrl+T либо кнопки Окно "Терминал" панели инструментов "Стандартная". В окне имеются несколько вкладок:

  • Торговля — в этой вкладке можно просматривать состояние открытых позиций и отложенных ордеров, а также управлять всей торговой деятельностью. Кроме того, в этой вкладке публикуется общий финансовый результат по всем открытым позициям;

  • История счета — здесь публикуются история по всем проведенным торговый операциям и состояние баланса без учета открытых позиций. По результатам, приведенным в этой вкладке, можно оценить эффективность всей торговой деятельности;

  • Новости — из этой вкладки можно просмотреть все приходящие в терминал финансовые новости. Эта оперативная информация бывает незаменимой для фундаментального анализа;

  • Сигналы — здесь можно просматривать и выставлять различные сигналы. В качестве сигналов могут использоваться любые исполняемые в операционной системе файлы (включая звуковые) и отправляемые по электронной почте сообщения;

  • Почтовый ящик — в этом разделе содержатся все письма, пришедшие на терминал по внутреней электронной почте. Отсюда же электронные письма и отправляются;

  • Эксперты — во вкладке публикуется информация о работе прикрепленного эксперта, включая открытие/закрытие позиций, модификацию ордеров, собственные сообщения советника и так далее;

  • Журнал — в журнале фиксируется информация о запуске терминала и о событиях во время его работы, включая совершение всех торговых операций.

Внимание: часть вкладок окна "Терминал" может отсутствовать. Это означает, что в них нет никакой информации. Например, вкладка "Эксперты" будет скрыта до тех пор, пока не появится какое-либо сообщение от MQL4-программы.


Терминал — Торговля

Торговля

Вкладка "Торговля" содержит информацию о текущем состоянии торгового счета, открытых позициях и выставленных отложенных ордерах. Все открытые позиции располагаются в порядке сортировки, их можно сортировать по любому полю. Далее — строка баланса счета и финансового результата открытых позиций, а за ней — список отложенных ордеров. При срабатывании отложенного ордера открывается новая позиция, и строка отложенного ордера удаляется. Вместо нее в окне появляется строка открытой позиции.

Все торговые операции отображаются в виде таблицы с полями (слева направо):

  • Ордер — номер тикета операции. Это уникальный номер торговой операции;

  • Время — время открытия позиции. Запись представляется в виде YYYY.MM.DD HH:MM (год.месяц.день час:минута). Именно в это время была открыта позиция;

  • Тип — тип торговой операции. Здесь могут встретиться несколько типов торговых операций: "Buy" — длинная позиция, "Sell" — короткая позиция, а также названия отложенных ордеров Sell Stop, Sell Limit, Buy Stop и Buy Limit;

  • Лоты — количество лотов, участвующих в операции. Минимально допустимое в операциях количество лотов ограничивается брокерской компанией, а максимальное — депозитом;

  • Символ — это поле показывает название финансового инструмента, участвующего в торговой операции;

  • Цена — цена открытия позиции (не путать с текущей ценой, которая описана ниже). Именно по этой цене была открыта позиция;

  • S/L — уровень выставленного ордера Стоп Лосс. Если ордер не был установлен, в поле записывается нулевое значение.
    Более детальная информация о работе с ордерами приводится в соответствующем разделе;

  • T/P — уровень выставленного ордера Тейк Профит. Если ордер не был установлен, в поле записывается нулевое значение.
    Более детальная информация о работе с ордерами приводится в соответствующем разделе;

  • Цена — текущая цена инструмента (не путать с ценой открытия позиции, которая описана выше);

  • Комиссия — комиссии, взимаемые брокерской компанией при совершении торговых операций, записываются в этом поле;

  • Своп — в этой графе фиксируется начисление свопов;

  • Прибыль — в этом поле записывается финансовый результат совершения сделки с учетом текущей цены. Положительный результат свидетельствует о прибыльности совершенной сделки, а отрицательный — об убыточности;

  • Комментарии — в этой колонке записываются комментарии к торговым операциям. Комментарий можно записать только при открытии позиции или выставлении ордера. При модификации ордера или позиции комментарий изменить нельзя. Кроме того, комментарий к торговой операции может записать брокерская компания.

Эта вкладка позволяет не только просматривать открытые позиции и выставленные ордера, но и управлять торговой деятельностью. Здесь можно: открыть новую позицию, выставить отложенный ордер, изменить или удалить его, а также закрыть позицию. Для этого необходимо воспользоваться командами контекстного меню:

  • Новый ордер — новый ордер. По команде появляется окно управления ордерами. В нем можно открыть новую позицию или выставить отложенный ордер. При этом указываются: финансовый инструмент, количество лотов, тип ордера (рыночный или отложенный), а также уровни Стоп Лосс и Тэйк Профит ордеров. Более детальная информация по выставлению ордеров приводится в разделе "Управление торговыми позициями";

  • Закрыть ордер — закрыть торговую позицию. Эта команда становится активной только в том случае, если контекстное меню было вызвано на открытой позиции. По команде также появляется окно управления ордерами. На этот раз, кроме кнопок "Sell" и "Buy", появится кнопка "Закрыть#XXXXXXX ..." (где ХХХХХХХ — номер тикета позиции). Кроме того, выполнив эту команду, можно закрыть выбранную позицию вместе со встречной. Более детальная информация по закрытию позиций находится в соответствующем разделе;

  • Модифицировать или удалить ордер — изменить значения "Стоп Лосс" и "Тэйк Профит" открытых позиций или цену отложенного ордера. Если уровни Стоп Лосс и Тэйк Профит окажутся слишком близко к текущей цене, появится сообщение об ошибке, и уровни выставлены не будут. Необходимо отодвинуть уровни от текущей цены и повторить попытку снова. Более детальная информация об изменении ордеров находится в одноименном разделе;

  • Трейлинг стоп — установить, изменить или удалить уровень "Трейлинг стоп". Выбрав в меню соответствующий уровень, можно активировать трейлинг стоп с указанным параметром. Значение "Нет" служит для отключения ордера. "Удалить все уровни" — отключить все трейлинг стопы. Более детальная информация по трейлинг стопам приводится в разделе "Трейлинг Стоп";

  • Прибыль — показывать прибыль/убыток в пипсах, в валюте ордера или в валюте депозита. Изменения этого параметра отражаются в поле "Прибыль". Если выбран параметр "показывать прибыль в валюте ордера" (валюта котировки) и, к примеру, имеются открытые позиции по USDJPY, то прибыль по ним будет показываться в японских йенах;

  • Комиссии — показать/скрыть колонку "Комиссия", в которой будет отражаться комиссия за совершение каждой из торговых операций;

  • Комментарии — показать/скрыть колонку "Комментарий". В этой колонке записываются комментарии к торговым операциям. Комментарий можно записать только при открытии позиции или выставлении ордера. При модификации ордера или позиции комментарий изменить нельзя. Кроме того, комментарий к торговой операции может записать брокерская компания;

  • Авторазмер столбцов — автоматическая установка размера столбцов при изменении размера окна;

  • Сетка — показать/скрыть сетку для разделения колонок.

Клавиши-акселераторы Ctrl+F9 переключают фокус управления в окне "Терминал — Торговля". После этого можно управлять торговым процессом при помощи клавиатуры.


Терминал — История счета

История счета

Во вкладке "История счета" содержится информация о совершенных торговых операциях. Вся история отображается в виде таблицы с полями (слева направо):

  • Ордер — номер тикета операции. Это уникальный номер торговой операции;

  • Время — время открытия позиции. Запись представлена в виде YYYY.MM.DD HH:MM (год.месяц.день час:минута). Именно в это время была открыта позиция;

  • Тип — тип торговой операции. Здесь могут встретиться только 3 типа торговых операций: "Balance" — зачисление денежных средств на счет, "Buy" — длинная позиция и "Sell" — короткая позиция;

  • Лоты — количество лотов, участвовавших в совершении операции;

  • Символ — это поле показывает название финансового инструмента, участвовавшего в торговой операции;

  • Цена — цена открытия позиции. Именно по этой цене была открыта позиция;

  • S/L — уровень выставленного ордера Stop Loss. Если торговая позиция была закрыта по этому ордеру, данная ячейка будет закрашена красным цветом, а в поле комментария появится запись "[s/l]". Если ордер не был установлен, в поле записывается нулевое значение. С другой стороны, если ордер был установлен, но не сработал, его значение все равно указывается в этом поле. При этом ячейка не закрашивается, и в поле комментария запись "[s/l]" не выводится. Более детальная информация о работе с ордерами приводится в соответствующем разделе;

  • T/P — уровень выставленного ордера Take Profit. Если торговая позиция была закрыта по этому ордеру, данная ячейка будет закрашена зеленым цветом, а в поле комментария появится запись "[t/p]". Если ордер не был установлен, в поле записывается нулевое значение. С другой стороны, если ордер был установлен, но не сработал, его значение все равно указывается в этом поле. При этом ячейка не закрашивается и в поле комментария запись "[t/p]" не выводится. Более детальная информация о работе с ордерами приводится в соответствующем разделе;

  • Время — время закрытия позиции. Запись представлена в виде YYYY.MM.DD HH:MM (год.месяц.день час:минута). Именно в это время была закрыта позиция;

  • Цена — цена закрытия позиции. Именно по этой цене была закрыта позиция;

  • Комиссия — комиссии, взымаемые брокерской компанией при совершении торговых операций, записываются в этом поле;

  • Своп — в этой графе фиксируется начиление свопов;

  • Прибыль — в этом поле записывается финансовый результат совершения сделки. Положительный результат свидетельствует о прибыльности совершенной сделки, а отрицательный — об убыточности. Прибыль здесь, в отличие от одноименного поля во вкладке "Торговля", показывается только в валюте депозита.

  • Комментарии — в этой колонке записываются комментарии к торговым операциям. Комментарий можно записать только при открытии позиции или выставлении ордера. При модификации ордера или позиции комментарий изменить нельзя. Кроме того, комментарий к торговой операции может записать брокерская компания.

Контекстное меню

В контекстном меню окна сгруппированы команды управления диапазоном истории и внешним видом отображения данных, а также команды экспорта исторических данных:

  • Вся история — показать всю историю счета. При выполнении этой команды на экране появится вся финансовая история данного счета без ограничений по времени;

  • Последние 3 месяца — показать историю только за последние три месяца;

  • Последний месяц — показать историю только за последний месяц;

  • Выбрать период — показать историю за выбранный период. По выполнении этой команды появится окно управления диапазоном истории, в котором можно выбрать предустановленные диапазоны (поле "Период") или указать их собственноручно в полях "От" и "До";

  • Сохранить как отчет — сохранить историю счета в формате HTML-файла. При этом появится окно, позволяющее выбрать путь для сохранения файла;

  • Сохранить детальный отчет — сохранить историю счета в формате HTML-файла. Детальный отчет отличается от обычного дополнительным набором показателей. После выполнения этой команды появится окно, позволяющее выбрать путь для сохранения файла;

  • Комиссии — показать/скрыть колонку "Комиссия";

  • Комментарии — показать/скрыть колонку "Комментарий". В этой колонке записываются комментарии к торговым операциям. Комментарий можно записать только при открытии позиции или выставлении ордера. Кроме того, комментарий к торговой операции может записать брокерская компания;

  • Авторазмер столбцов — автоматическая установка размера столбцов при изменении размера окна;

  • Сетка — показать/скрыть сетку для разделения колонок.


Терминал — Новости

Новости

Во вкладке "Новости" содержится список пришедших новостей. Заголовки новостей располагаются в виде таблицы в соответствии со временем поступления. В таблице публикуются время поступления новости, ее тема и категория. Этот список автоматически обновляется с приходом последних новостей.

В контекстном меню доступны следующие команды:

  • Показать — просмотреть выбранную новость. Новости можно также прочитать, дважды щелкнув на заголовке левой кнопкой мыши;

  • Копировать — скопировать новость в буфер обмена;

  • Категория — показать/скрыть колонку "Категория";

  • Авторазмер столбцов — автоматическая установка размера столбцов при изменении размера окна;

  • Сетка — показать/скрыть сетку для разделения колонок.

Внимание:
  • если в окне "Терминал" отсутствует вкладка "Новости", это означает, что ни одна новость не приходила;
  • если в настройках терминала отключена опция "Разрешить новости", новости поступать не будут;
  • одной из причин, по которой новости не приходят или невозможно просмотреть их содержание, может быть отсутствие соответствующих прав у данного счета.


Терминал — Сигналы

Сигналы

В этой вкладке содержится информация о созданных сигналах. Эти сигналы предназначены для оповещения о событиях на рынке. Создав сигналы, можно отойти от монитора — клиентский терминал автоматически оповестит о совершении заданного события.

Все сигналы в этой вкладке представлены в виде таблицы со следующими полями:

  • Символ — финансовый инструмент, данные которого используются для проверки условия. Если в качестве условия выбран параметр "Time=" (срабатывание сигнала при наступлении заданного времени), символ значения не имеет;

  • Условие — условие срабатывания сигнала. В качестве этого условия могут быть:

    1. Bid> — Бид-цена больше заданного значения. Если текущая Бид-цена поднимется выше указанного значения, произойдет срабатывание сигнала;

    2. Bid< — Бид-цена меньше заданного значения. Если текущая Бид-цена опустится ниже указанного значения, произойдет срабатывание сигнала;

    3. Ask> — Аск-цена больше заданного значения. Если текущая Аск-цена поднимется выше указанного значения, произойдет срабатывание сигнала;

    4. Ask< — Аск-цена меньше заданного значения. Если текущая Аск-цена опустится ниже указанного значения, произойдет срабатывание сигнала;

    5. Time= — время равно заданному значению. При наступлении заданного времени произойдет срабатывание сигнала.

  • Счетчик — количество срабатываний сигнала;

  • Предел — максимально допустимое количество срабатываний сигналов. Отработав заданное количество раз, сигнал перестанет выполняться;

  • Таймаут — период времени между срабатываниями сигналов;

  • Событие — исполняемое действие. Это могут быть звуковой сигнал, исполняемый в операционной системе файл или отсылка сообщения по почте.

Управление сигналами

Для управления сигналами предназначены команды контекстного меню:

  • Создать — создать новый сигнал о событии. То же действие можно выполнить, нажав клавишу Insert;

  • Изменить — редактировать сигнал. То же действие можно выполнить, дважды кликнув на наименовании сигнала в таблице или нажав клавишу Enter;

  • Удалить — удалить сигнал. Нажав клавишу Delete, также можно выполнить это действие;

  • Включить/Выключить — включить/выключить сигнал. При выключении сигнал не удаляется, но перестает работать. В дальнейшем его можно будет снова включить. Нажав клавишу Space или выставив флажок в окне настройки сигнала (описано ниже), можно выполнить то же действие.

Внимание: чтобы управлять сигналами при помощи клавиатуры, необходимо сначала переместить в это окно фокус. Для этого следует кликнуть левой кнопкой мыши на окне.

Двойным щелчком левой кнопки мыши на строке информации о сигнале можно приступить к редактированию сигнала. В данном случае, а также при выполнении команд контекстного меню "Изменить" и "Создать", появится окно редактора сигналов:

  • Разрешить — включить/выключить сигнал. При выключении сигнал не удаляется, но его выполнение приостанавливается. Эта опция аналогична выполнению команды "Включить/Выключить" контекстного меню и нажатию клавиши Space;

  • Действие — назначить действие, совершаемое при наступлении события: проиграть звук, голосовое сообщение, запустить файл или выслать электронное письмо.
    При проигрывании звука и запуске файла необходимо указать соответствующие файлы. В случае использования голосовых сообщений требуется указать язык и текст сообщения в поле "Источник". При отсылке письма необходимо указать заголовок и текст сообщения;

  • Символ — финансовый инструмент, значения которого будут использоваться для проверки условия;

  • Условие — условие ("Time=", "Bid<", "Bid>", "Ask<", "Ask>") выполнения сигнала;

  • Значение — проверочное значение условия. Если цена инструмента будет удовлетворять этому значению, произойдет срабатывание сигнала;

  • Источник — сигнал. При проигрывании звука и запуске файла необходимо указать путь к соответствующему файлу. В случае использования голосовых оповещений — текст, который будет воспроизводится голосом, и язык в одноименном поле. При отсылке электронной почты — сообщение. Важно помнить, что при отсылке почтовых сообщений необходимо предварительно настроить параметры почтового ящика;

  • Таймаут — период времени, через который выдается сигнал;

  • Максимум повторений — максимальное количество сигналов о событии.

Кнопкой "Тест" можно проверить работоспособность выбранного сигнала. Чтобы изменения вступили в силу, необходимо нажать кнопку "OK".

Внимание:
  • для отсылки писем при совершении событий необходимо задать параметры почтового ящика в настройках программы.


Терминал — Почтовый ящик

Почтовый ящик

Раздел "Почтовый ящик" предназначен для работы с внутренней почтой. Все пришедшие на терминал электронные письма содержатся именно в этом разделе окна "Терминал". Они представлены в виде таблицы с полями:

  • Время — время поступления новости;

  • От — имя отправителя сообщения;

  • Тема — заголовок сообщения.

При помощи двойного щелчка левой кнопки мыши на нужном заголовке или команды контекстного меню "Показать" можно просмотреть содержимое выбранного письма, а командой "Удалить" — удалить сообщение. Кроме того, если это разрешено брокерской компанией, из данной вкладки можно отсылать письма администратору системы и в отдел технической поддержки. Для этого необходимо выполнить команду контекстного меню "Создать", затем в появившемся окне выбрать получателя, озаглавить новость, написать сообщение и нажать кнопку "Отослать".

Внимание: все сообщения отсылаются по внутренней почтовой системе и не требуют никаких дополнительных настроек. В случае возникновения проблем при работе с почтовым ящиком следует обратиться в службу технической поддержки.


Терминал — Эксперты

Эксперты

Во вкладке "Эксперты" содержится вся информация о работе прикрепленного эксперта, включая открытие/закрытие позиций, модификацию ордеров, собственные сообщения советника и другие. В окне располагаются только последние сообщения. Для просмотра предыдущих сообщений нужно выполнить команду контекстного меню "Открыть" и выбрать нужный файл. Файлы журнала экспертов хранятся в каталоге /EXPERTS/LOGS, имена файлов соответствуют дате формирования журнала — YYYYMMDD.LOG. Чтобы скопировать сообщение в буфер обмена, необходимо выполнить одноименную команду контекстного меню.


Терминал — Журнал

Журнал

Во вкладке "Журнал" содержатся сведения о зафиксированных действиях трейдера и клиентского терминала за текущий сеанс. В журнале фиксируется информация о запуске терминала и о событиях во время его работы, включая все торговые операции. В окне располагаются только последние сообщения. Для просмотра предыдущих сообщений необходимо выполнить команду контекстного меню "Открыть" и выбрать требуемый файл. Файлы журнала клиентского терминала хранятся в каталоге /LOGS, имя файлов соответствует дате формирования журнала — YYYYMMDD.LOG. Чтобы скопировать сообщение в буфер обмена, следует выполнить одноименную команду контекстного меню.


Пользовательский интерфейс — Тестер

Окно Тестер

"Тестер" — многофункциональное окно, позволяющее тестировать стратегии и оптимизировать параметры советников. При тестировании происходит однократная прогонка эксперта на смоделированных данных, что позволяет определить его прибыльность и эффективность. При оптимизации производятся многократные прогоны механической торговой системы. Это делается с целью определения параметров советника, при которых его прибыльность максимальна.

Окно можно вызвать командой меню "Вид — Тестер стратегий", комбинацией клавиш-акселераторов Ctrl+R или кнопкой Окно "Тестирование Стратегий" панели инструментов "Стандартная". В этом окне имеется несколько вкладок:

  • Настройки — настройки параметров тестирования и оптимизации. Отсюда можно настроить параметры советника, указать период тестирования, выбрать способ моделирования баров и так далее;

  • Результаты — результаты совершения торговых операций советником, а также динамика изменения баланса;

  • График — отображение результатов тестирования на графике;

  • Отчет — детальный отчет о тестировании. Здесь можно найти множество показателей тестирования и эффективности работы советника: количество смоделированных баров, общую прибыль, наиболее прибыльные и убыточные позиции, количество прибыльных и убыточных позиций, а также многое другое;

  • Журнал — лог, в который записываются все действия и собственные сообщения советника;

  • Результаты оптимизации — информация по каждому прогону, включая входные параметры, прибыльность, просадки и другие показатели;

  • График оптимизации — результаты оптимизации советника в виде графика. Кроме прибыльности каждого прогона, на графике также отображается количество прибыльных и убыточных сделок.

Как и в случае с окном "Терминал", часть вкладок в окне "Тестер" скрывается, если в них нет информации. Так, изначально в этом окне можно видеть только вкладки "Настройки" и "Журнал". Вкладки "Результаты", "График" и "Отчет" появятся только после тестирования советника. После оптимизации эксперта также появятся вкладки "Результат оптимизации" и "График оптимизации". Более детальная информация по тестированию советников приводится в одноименном разделе.


Тестер — Настройки

Настройки

В этой вкладке можно настроить параметры тестирования и оптимизации советников. При тестировании происходит однократный прогон эксперта на смоделированных данных, что позволяет определить их прибыльность и эффективность. При оптимизации производятся многократные прогоны механической торговой системы. Это делается с целью определения параметров советника, при которых его прибыльность максимальна.
В этой вкладке доступны следующие команды и опции:

  • Советник — выбрать тестируемый советник из списка. Для этого советник должен быть скомпилирован и находиться в директории /EXPERTS. Все вновь создаваемые эксперты автоматически помещаются в эту директорию;

  • Символ — выбрать один из доступных финансовых инструментов;

  • Период — выбрать период инструмента (таймфрейм);

  • Модель — выбрать метод моделирования баров:

    1. Все тики (на основе всех наименьших доступных периодов с фрактальной интерполяцией каждого тика);

    2. Контрольные точки (используется ближайший таймфрейм + фрактальная интерполяция);

    3. По ценам открытия (быстрый метод на сформировавшихся барах);

  • Использовать дату — использовать диапазон дат при тестировании. Если эта опция включена, при тестировании будут использоваться данные из указанного диапазона. В противном случае используются все доступные данные по указанному инструменту и периоду;

  • Оптимизация — включить режим оптимизации параметров советника. Более детальная информация по оптимизации параметров советника приведена в одноименном разделе;

  • Свойства эксперта — открыть окно "Свойства советника", позволяющее управлять параметрами советника при тестировании и оптимизации;

  • Свойства символа — посмотреть параметры финансового инструмента. Эти данные записаны в заголовке файла *.FXT и используются для эмуляции работы сервера;

  • Открыть график — создать новое окно графика выбранного для тестирования финансового инструмента. В процессе тестирования советник работает с виртуальным графиком. На этот график наносятся значки открытия и закрытия позиций, а также используемые советником объекты и индикаторы. Этот график может быть открыт только после завершения тестирования. При открытии виртуального графика используется шаблон TESTER.TPL, а при его отсутствии используются настройки по умолчанию;

  • Изменить эксперт — открыть редактор "MetaEditor" и приступить к редактированию выбранного эксперта. Это бывает удобным, если необходимо внести небольшие изменения и быстро перекомпилировать эксперт;

  • Старт — начать тестирование или оптимизацию. После нажатия этой кнопки в нижней части окна в прогресс-баре можно оценить скорость протекания процесса тестирования или оптимизации. Также после начала тестирования вместо кнопки "Старт" появится кнопка "Стоп". Нажав эту кнопку во время тестирования/оптимизации, можно остановить процесс.

Более детальная информация о тестировании советников приводится в одноименном разделе.


Тестер — Свойства советника

Окно свойств советника

В этом окне можно настроить параметры виртуального счета и тестируемого советника. В дальнейшем эти данные будут использоваться для тестирования или оптимизации параметров эксперта. В окне имеются три вкладки:

  • Тестирование — в этой вкладке указываются общие для тестирования и оптимизации параметры. К ним относятся объем и валюта начального депозита, которые указываются в одноименных полях. Также выбираются типы открываемых при тестировании позиций: "Only Long" — открывать только длинные позиции; "Only Short" — только короткие; "Long and Short" — открывать позиции в обе стороны. Каким бы ни был алгоритм советника, он будет открывать позиции только в заданных направлениях;

  • Входные параметры — здесь в виде таблицы приводится список всех входных параметров. Входными параметрами называются переменные, которые влияют на работу эксперта и могут быть изменены прямо из клиентского терминала. Их количество может варьироваться от эксперта к эксперту. В поле "Значение" записываются текущие показатели, которые используются при тестировании советника. Данные, записываемые в полях "Старт", "Шаг" и "Стоп", не влияют на тестирование советника и необходимы лишь для его оптимизации. В этих полях записываются начальное значение переменной, шаг изменения и конечное значение. При оптимизации будут происходить последовательные прогоны эксперта с параметрами от начального до конечного значений. Слева от названия переменных имеются галочки, включающие параметр в оптимизацию. Если переменная не отмечена галочкой, она не участвует в оптимизации. Ее значение в процессе оптимизации не изменяется, и используется параметр, записанный в поле "Значение".

    Существует возможность загрузить уже сохраненный набор входных параметров (включая значения "Старт", "Шаг" и "Стоп"). Это можно сделать, нажав кнопку "Загрузить" и выбрав предварительно сохраненный набор параметров. Сохранить текущий набор внешних переменных можно при помощи одноименной кнопки.

    Внимание: в оптимизацию рекомендуется включать только необходимые переменные. При включении в оптимизацию слишком многих переменных резко увеличиваются количество прогонов и общее время оптимизации советника.

  • Оптимизация — эта вкладка позволяет управлять ограничениями процесса оптимизации. Достижение этих условий во время оптимизации приведет к прекращению текущего прогона и переходу к следующему. К параметрам, ограничивающим тестирование при оптимизации советника, относятся:

    1. Минимальный баланс — минимальное значение баланса в валюте депозита;

    2. Максимальная прибыль — максимальная прибыль в валюте депозита;

    3. Минимальный уровень маржи, % — минимальный уровень маржи в процентах;

    4. Максимальная просадка, % — максимальная просадка в процентах;

    5. Непрерывный убыток — максимальный суммарный убыток в одной серии сделок. Убыточной серией называется определенное количество совершенных подряд убыточных сделок;

    6. Непрерывное количество убыточных сделок — максимальное количество убыточных сделок в одной серии;

    7. Непрерывный выигрыш — максимальная суммарная прибыль в одной серии сделок. Прибыльной серией называется определенное количество совершенных подряд прибыльных сделок;

    8. Непрерывное количество прибыльных сделок — максимальное количество прибыльных сделок в одной серии.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Тестер — Результаты

Результаты

В этой вкладке в виде таблицы представлены результаты тестирования. Здесь можно найти информацию обо всех проведенных в процессе тестирования торговых операциях:

  • Номер — порядковый номер торговой операции;

  • Время — время совершения операции;

  • Тип — тип совершенной операции (sell, buy, s/l, t/p, modify, close at stop и так далее);

  • Ордер — номер тикета торговой позиции или отложенного ордера (не путать с номером торговой операции, который описан выше);

  • Лоты — количество лотов, участвовавших в операции;

  • Цена — цена инструмента при совершении операции;

  • S/L — значение ордера Стоп Лосс. Отсутствие записей в этом поле свидетельствует о том, что ордер не выставлялся;

  • T/P — значение ордера Тейк Профит. Отсутствие записей в этом поле свидетельствует о том, что ордер не выставлялся;

  • Прибыль — прибыль/убыток. Значение прибыли/убытка проставляется только при закрытии позиций;

  • Баланс — значение баланса. Значение баланса записывается только при закрытии позиций.

Кликнув левой кнопкой мыши на любом заголовке столбца, можно отсортировать все записи в таблице по убыванию или по возрастанию. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать выбранные строки результатов в буфер обмена для дальнейшего использования в других приложениях. Если не выбрано ни одной строки, то в буфер обмена скопируется вся таблица. Также, чтобы скопировать всю таблицу в буфер обмена, можно выполнить команду "Копировать все". Отчет о результатах тестирования можно сохранить в HTML-файле на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как отчет". Команды "Установить начальную дату" и "Установить конечную дату" позволяют задать временной диапазон тестирования. При этом даты выбранных операций записываются в поля "Использовать дату от:" и "Использовать дату до:" в настройках тестирования. Это бывает полезным, если необходимо тщательно протестировать советник или провести оптимизацию его параметров на данном диапазоне.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Тестер — График

График

Во вкладке "График" автоматически рисуется график состояния баланса счета (синяя линия — "Баланс") и общее состояние счета с учетом открытых позиций (зеленая линия — "Средства"). Если на графике отображается лишь одна линия баланса, значит линии "Баланс" и "Средства" совпадают на всем протяжении тестирования. График позволяет более наглядно отследить динамику результатов торговли при тестировании. Если в процессе тестирования происходило изменение размера лотов, в нижней части графика также появляется гистограмма изменения лотов.

Двойной клик левой кнопкой мыши на любой точке графика производит переключение во вкладку "Результаты" и выбирает соответствующую строку. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать изображение графика в буфер обмена для дальнейшего использования в других приложениях. График можно также сохранить в виде GIF-файла на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как рисунок" или нажать клавиши-акселераторы Ctrl+S. Команды "Установить начальную дату" и "Установить конечную дату" позволяют задать временной диапазон тестирования. При этом даты выбранных операций записываются в поля "Использовать дату от:" и "Использовать дату до:" во вкладке настроек тестирования. Это бывает полезным, если необходимо тщательно протестировать советник или провести оптимизацию его параметров на данном временном диапазоне.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Тестер — Отчет

Отчет

Во вкладке "Отчет" представлены обобщенные результаты тестирования советников и некоторые ключевые показатели. Такие отчеты позволяют быстро сравнивать между собой различные эксперты. В отчетах публикуются следующие данные:

  • Баров в истории — количество смоделированных исторических данных в барах;

  • Смоделировано тиков — количество смоделированных тиков;

  • Качество моделирования — качество смоделированных в процессе тестирования тиков в процентах. Моделирование схематично отображается в виде полосы в следующей строке отчета. Эта полоса может быть трех цветов:

    1. Серый — эта часть имеющихся данных не участвовала в тестировании. Серый цвет может появиться, если был указан диапазон дат в настройках тестирования;

    2. Красный — на этом отрезке моделирование не проводилось за неимением данных более мелкого периода. При этом использовались только данные выбранного в настройках тестирования периода;

    3. Зеленый — моделирование на данном участке проводилось. Причем чем ярче цвет, тем более качественным было моделирование. Например, при тестировании на периоде H1 темно-зеленая полоса может свидетельствовать о том, что для тестирования использовались данные тридцатиминутного периода M30, а самая яркая — об использовании минутных данных M1;

    Внимание: если в качестве метода моделирования в настройках тестирования был выбран самый быстрый способ ("по ценам открытия"), вся полоса будет красной. При этом в графе "Качество моделирования" будет записано "n/a" — моделирование не проводилось вовсе;

  • Начальный депозит — объем начального депозита;

  • Чистая прибыль — финансовый результат всех сделок. Этот показатель представляет собой разность "Общей прибыли" и "Общего убытка";

  • Общая прибыль — сумма всех прибыльных сделок в денежных единицах;

  • Общий убыток — сумма всех убыточных сделок в денежных единицах;

  • Прибыльность — отношение общей прибыли к общему убытку в процентах. Единица означает, что сумма прибыли равна сумме убытков;

  • Матожидание выигрыша — математическое ожидание выигрыша. Этот статистически расчитываемый показатель отражает среднюю прибыльность/убыточность одной сделки. Также можно считать, что он отражает предполагаемую прибыльность/убыточность следующей сделки;

  • Абсолютная просадка — наибольший убыток ниже значения начального депозита;

  • Максимальная просадка — наибольший убыток от локального максимума в валюте депозита и в проценте от депозита;

  • Всего сделок — общее количество торговых позиций;

  • Короткие позиции (% выигравших) — количество коротких позиций и процент прибыльных коротких позиций;

  • Длинные позиции (% выигравших) — количество длинных позиций и процент прибыльных длинных позиций;

  • Прибыльные сделки (% от всех) — количество прибыльных торговых позиций и их доля в общем количестве сделок, в процентах;

  • Убыточные сделки (% от всех) — количество убыточных торговых позиций и их доля в общем количестве сделок, в процентах;

  • Самая большая прибыльная сделка — наибольшая прибыль среди всех прибыльных позиций;

  • Самая большая убыточная сделка — наибольший убыток среди всех убыточных позиций;

  • Средняя прибыльная сделка — усредненное значение прибыли за сделку (сумма прибылей, деленная на количество прибыльных сделок);

  • Средняя убыточная сделка — усредненное значение убытков за сделку (сумма убытков, деленная на количество убыточных сделок);

  • Максимальное количество непрерывных выигрышей (прибыль) — наиболее длинная серия прибыльных торговых позиций и сумма их выигрышей;

  • Максимальное количество непрерывных проигрышей (убыток) — наиболее длинная серия убыточных торговых позиций и сумма их проигрышей;

  • Максимальная непрерывная прибыль (число выигрышей) — максимальная прибыль за одну серию прибыльных сделок и соответствующее ей количество прибыльных сделок;

  • Максимальный непрерывный убыток (число проигрышей) — максимальный убыток за одну серию убыточных сделок и соответствующее ей количество убыточных сделок;

  • Средний непрерывный выигрыш — среднее количество прибыльных позиций в непрерывных прибыльных сериях;

  • Средний непрерывный проигрыш — среднее количество убыточных позиций в непрерывных убыточных сериях.

Этот отчет можно скопировать в буфер обмена или сохранить на жестком диске в виде HTML-файла. Для этого необходимо выполнить команды контекстного меню "Скопировать" и "Сохранить как отчет" соответственно. Скопировать отчет в буфер обмена можно также при помощи клавиш-акселераторов Ctrl+C.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Тестер — Журнал

Журнал

Во вкладке "Журнал" автоматически публикуются сообщения о ходе тестирования советника, включая все торговые операции. Этот журнал идентичен журналу окна "Терминал — Эксперты", за исключением того, что в окне тестера публикуются сообщения, связанные с тестированием советника, а не c его работой на рынке. После окончания тестирования эти данные выводятся в отдельный каталог /TESTER/LOGS. Файлы журнала тестирования хранятся в каталоге /EXPERTS/LOGS, имена файлов соответствуют дате формирования журнала — YYYYMMDD.LOG. Для просмотра сохраненных журналов следует выполнить команду контекстного меню "Открыть" и выбрать нужный файл. Чтобы скопировать сообщение в буфер обмена, необходимо выполнить одноименную команду контекстного меню. Команда "Стереть все журналы" позволяет удалить все журналы из директории и очищает эту вкладку. Это бывает полезным для очистки жесткого диска от разросшихся файлов.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Тестер — Результаты оптимизации

Результаты оптимизации

В отличие от тестирования, оптимизация предполагает многократные прогоны механической торговой системы (МТС) с разными входными параметрами. Это делается с целью определения параметров советника, при которых его прибыльность будет максимальна. Чтобы провести оптимизацию, необходимо выставить одноименный флажок во вкладке настроек тестирования и нажать кнопку "Старт". После этого в окне появятся две новых вкладки: "Результаты оптимизации" и "График оптимизации".

Во вкладке "Результаты оптимизации", в отличие от результатов тестирования, публикуется не список всех операций, а окончательные отчеты каждого из прогонов. Вся информация представлена в виде таблицы с полями:

  • Проход — номер прогона;

  • Прибыль — чистая прибыль (валовая прибыль за вычетом валовых убытков);

  • Всего сделок — общее количество открытых торговых позиций;

  • Прибыльность — отношение общей прибыли к общему убытку в процентах. Единица означает, что сумма прибыли равна сумме убытков;

  • Матожидание выигрыша — математическое ожидание выигрыша. Этот статистически расчитываемый показатель отражает среднюю прибыльность/убыточность одной сделки. Также можно считать, что он отражает предполагаемую прибыльность/убыточность следующей сделки;

  • Просадка $ — максимальная просадка относительно начального депозита в валюте депозита;

  • Просадка % — максимальная просадка относительно начального депозита в процентах;

  • Входные параметы — изменяемые значения входных переменных при каждом прогоне.

Кликнув левой кнопкой мыши на заголовке любого столбца, можно отсортировать все записи в таблице по убыванию или по возрастанию. При выполнении команды контекстного меню "Установить входные параметры" в качестве базовых входных переменных эксперта (окно свойств эксперта, вкладка "Входные параметры") записываются данные выбранного прогона. При этом происходит переключение во вкладку "Настройка" и отключение режима оптимизации. Нажав кнопку "Старт", можно приступить к тестированию советника с выбранными входными переменными. Двойным кликом левой кнопки мыши на строке прогона во вкладке результатов оптимизации можно выполнить то же действие. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать выделенные строки результатов в буфер обмена для дальнейшего использования в других приложениях. Если не выбрано ни одной строки, то в буфер обмена скопируется вся таблица. Также, чтобы скопировать всю таблицу в буфер обмена, можно выполнить команду "Копировать все". Отчет о результатах оптимизации можно также сохранить в HTML-формате на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как отчет". Другие команды контекстного меню позволяют настраивать отображение результатов:

  • Пропустить бесполезные результаты — показать/скрыть результаты убыточных прогонов;

  • Показать входные параметры — показать/скрыть колонку "Входные параметры";

  • Авторазмер столбцов — автоматическая установка размера столбцов при изменении размера окна.
    То же действие можно выполнить нажав клавишу A;

  • Сетка — показать/скрыть сетку для разделения колонок.
    То же действие можно выполнить, нажав клавишу G.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Тестер — График оптимизации

График оптимизации

В отличие от тестирования, оптимизация предполагает многократные прогоны механической торговой системы (МТС) с разными входными параметрами. Это делается с целью определения параметров советника, при которых его прибыльность была бы максимальной. Чтобы провести оптимизацию, необходимо выставить одноименный флажок во вкладке настроек тестирования и нажать кнопку "Старт". После этого в окне появятся две новых вкладки: "Результаты оптимизации" и "График оптимизации".

Во вкладке "График Оптимизации" автоматически рисуется график прибыли всех прогонов. График позволяет наглядно оценить прибыльность использования различных комбинаций входных параметров. В нижней части графика также приводится график, отражающий количество прибыльных (зеленый цвет) и убыточных (красный цвет) сделок при каждом прогоне.

Двойной клик левой кнопкой мыши на любой точке графика производит переключение во вкладку "Результаты" и выбирает соответствующий прогон. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать изображение графика в буфер обмена для дальнейшего использования в других приложениях. График можно также сохранить в виде GIF-файла на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как рисунок" или нажать клавиши-акселераторы Ctrl+S.

Более детальная информация приводится в разделах "Тестирование советников" и "Оптимизация".


Пользовательский интерфейс — Средства быстрой навигации

Средства быстрой навигации

В клиентском терминале имеются различные приемы ускорения работы. Для этих целей можно использовать:

  • строку быстрой навигации — небольшую строку, появляющуюся в нижнем левом углу графика и позволяющую управлять им;

  • горячие клавиши (клавиши-акселераторы) — сочетания клавиш, предназначенные для ускорения работы с различными функциями программы.

Строка быстрой навигации

Строка быстрой навигации используется для быстрой замены графика и/или его периода, а также для быстрой прокрутки графика до выбранной даты. Открыть строку быстрой навигации на активном графике можно клавишей Enter, после чего в левой нижней части окна графика появится строка быстрой навигации. Также можно подвести курсор мыши в левую нижнюю часть окна графика и после появления значка Значок cтроки быстрой навигации дважды нажать левую кнопку мыши.

Строка быстрой навигации

Формат команд строки быстрой навигации:

   1. [время (часы:минуты)]                                               пример: 08:30; 8:30;
   2. [дата]                                                              пример: 2004.10.16; 16.10.2004; 16.10.04;
   3. [дата и время]                                                      пример: 2004.10.16 8:30; 16.10.2004 8:30; 16.10.04 8:30;
   4. [обозначение финансового инструмента]                               пример: GBPUSD; EURUSD;
   5. [период графика]                                                    пример: M1; M5; M15; M30; H1; H4; D1; W1; MN;
   6. [обозначение финансового инструмента], [период графика]             пример: GBPUSD, M30; EURUSD, D1;
Внимание: следует помнить, что в строке быстрой навигации может выполняться только одна из перечисленных команд.

Чтобы выполнить команду строки необходимо нажать клавишу Enter, закрыть строку — клавишу Esc. Для перемещения графика к конкретной дате и времени необходимо ввести эти дату и время. Например, команда, позволяющая переместиться к бару, полученному в 8:30 16 октября 2004 года, будет иметь вид "2004.10.16 08:30". Наряду с форматами даты ГГГГ.ММ.ДД и ДД.ММ.ГГГГ, можно также использовать формат ДД.ММ.ГГ, но не ГГ.ММ.ДД. Первый ноль при вводе времени можно также опустить. Например, вместо "08:30" можно написать просто "8:30". При смене инструмента необходимо указывать его полное обозначение. При указании периода графика букву "М" можно опустить. По команде "GBPUSD 30", равно как и "GBPUSD М30", произойдет смена финансового инструмента и периода на тридцатиминутный график Фунт-Доллар.

Горячие клавиши

Горячими клавишами (клавишами-акселераторами) называются клавиши и комбинации клавиш, позволяющие быстро выполнять различные команды без обращения к меню или панелям управления.

  • "ï" — прокрутка графика влево;

  • "ð" — прокрутка графика вправо;

  • "ñ" — быстрая прокрутка графика влево, а в случае фиксированного масштаба — прокрутка графика вверх;

  • "ò" быстрая прокрутка графика вправо, а в случае фиксированного масштаба — прокрутка графика вниз;

  • Numpad 5 — восстановление автоматического масштаба графика по вертикали после его изменения. А при фиксированном масштабе — возвращение графика в пределы видимости;

  • Page Up — быстрая прокрутка графика влево;

  • Page Down — быстрая прокрутка графика вправо;

  • Home — переместить график в начало;

  • End — переместить график в конец;

  • "-" — уменьшить масштаб графика;

  • "+" — увеличить масштаб графика;

  • Delete — удалить все выделенные графические объекты;

  • Backspace — удалить в окне графика объекты, нанесенные последними;

  • Enter — открыть/закрыть окно быстрой навигации;

  • Esc — закрыть диалоговые окна;

  • F1 — открыть данное "Руководство пользователя";

  • F2 — открыть окно "Архив котировок";

  • F3 — открыть окно "Глобальные переменные";

  • F4 — загрузить редактор советников MetaEditor;

  • F6 — вызвать окно "Тестер" для тестирования советника, прикрепленного к окну графика;

  • F7 — вызвать окно со свойствами советника, прикрепленного к окну графика, для изменения настроек;

  • F8 — вызвать окно настройки графика;

  • F9 — вызвать окно "Новый ордер";

  • F10 — открыть "Окно котировок";

  • F11 — включить/выключить полноэкранный режим;

  • F12 — сдвинуть график на один бар влево;

  • Shift+F12 — сдвинуть график на один бар вправо;

  • Shift+F5 — переключить на предыдущий профиль;

  • Alt+1 — представить график в виде последовательности баров (преобразовать в столбиковый);

  • Alt+2 — представить график в виде последовательности японских свечей (преобразовать в свечной);

  • Alt+3 — представить график в виде ломаной линии (преобразовать в линейный);

  • Alt+A — скопировать в буфер обмена все результаты тестирования или оптимизации советника;

  • Alt+W — вызвать окно управления графиками;

  • Alt+F4 — закрыть клиентский терминал;

  • Alt+Backspace или Ctrl+Z — отменить удаление объекта;

  • Ctrl+A — установить высоту всех окон индикаторов по умолчанию;

  • Ctrl+B — вызвать окно "Список объектов";

  • Ctrl+C или Ctrl+Insert — копировать в буфер;

  • Ctrl+E — разрешить/запретить использование советника;

  • Ctrl+F — включить "Перекрестие";

  • Ctrl+G — показать/скрыть сетку;

  • Ctrl+H — показать/скрыть строку OHLC;

  • Ctrl+I — вызвать окно "Список индикаторов";

  • Ctrl+L — показать/скрыть объемы;

  • Ctrl+P — печать графика;

  • Ctrl+S — сохранить график в файле с расширениями "CSV", "PRN", "HTM";

  • Ctrl+W или Ctrl+F4 — закрыть окно графика;

  • Ctrl+Y— показать/скрыть разделители периодов;

  • Ctrl+Z или Alt+Backspace — отменить удаление объекта;

  • Ctrl+D — открыть/закрыть "Окно данных";

  • Ctrl+M — открыть/закрыть окно "Обзор рынка";

  • Ctrl+N — открыть/закрыть окно "Навигатор";

  • Ctrl+O — открыть окно "Настройки";

  • Ctrl+R — открыть/закрыть окно "Тестер";

  • Ctrl+T — открыть/закрыть окно "Терминал";

  • Ctrl+F5 — переключить на следующий профиль;

  • Ctrl+F6 — активизировать следующее окно графика;

  • Ctrl+F9 — открыть окно "Терминал — Торговля" и переключить в него фокус управления. После этого можно управлять торговой деятельностью при помощи клавиатуры.

Существует возможность назначать горячие клавиши для вызова любого элемента окна "Навигатор", за исключением элементов группы "Счета". Чтобы назначить сочетание клавиш элементу, необходимо выполнить команду "Назначить горячуюю клавишу" его контекстного меню. Назначенные горячие клавиши имеют больший приоритет по сравнению с предопределенными. Например, изначально сочетанию Ctrl+O соответствует вызов окна настройки терминала. Если этому же сочетанию назначить вызов индикатора On Balance Volume, то нажатием Ctrl+O нельзя будет вызвать окно настройки терминала.


Работа с графиками — Открытие графиков

Открытие графиков

График отображает динамику цен финансового инструмента во времени. Графики необходимы для проведения технического анализа, работы советников и их тестирования. В терминале одновременно может быть открыто до девяноста девяти графиков.

Новый график можно открыть, выполнив команду меню "Файл — Новый график", меню "Окно — Новое окно" либо нажав кнопку New Chart панели инструментов "Стандартная". При выполнении любого из этих действий появится список доступных финансовых инструментов. Выбрав нужный символ из списка, можно открыть его график. Также новые графики можно открывать из окна "Обзор рынка", удерживая клавишу Ctrl и перетащив элемент списка (финансовый инструмент) из окна в любое место рабочей области терминала или выполнив команду "Окно графика" контекстного меню. Все новые графики открываются с использованием шаблона DEFAULT.TPL, который создается в процессе установки клиентского терминала. Этот шаблон нельзя удалить, но можно изменить.

Исторические данные, на основе которых строятся графики, хранятся на жестком диске. При открытии графика данные загружаются с диска и производится докачка последних недостающих данных с торгового сервера. Если исторические данные по финансовому инструменту отсутствуют на жестком диске, происходит загрузка последних 512 баров истории. Чтобы докачать более ранние данные, необходимо переместить график в требуемую область. После открытия графика в терминал начнет поступать информация о текущих котировках. Таким образом, в режиме реального времени формируется дальнейшая динамика цен. Эта информация автоматически сохраняется в файл истории и используется при повторном открытии этого графика в будущем.

Внимание: в настройках терминала задаются параметры "Макс. баров истории" и "Макс. баров на графике". Эти параметры позволяют контролировать количество отображаемых и сохраняемых на жесткий диск исторических данных.

Оффлайновые графики

Клиентский терминал также позволяет работать с оффлайновыми графиками. Эти графики открываются на основе сохраненных на жёсткий диск данных в формате HST. Они не обновляются с сервера. Такие графики оказываются очень полезными для работы с нестандартными инструментам и периодами.

Для открытия нового графика в режиме оффлайн необходимо выполнить команду меню "Файл — Открыть автономно". Затем в появившемся окне следует выбрать финансовый инструмент и нажать кнопку "Открыть". К графику автоматически применяется шаблон OFFLINE.TPL. При этом в заголовке оффлайнового графика добавляется надпись "(offline)".

При тестировании советника создается и используется файл данных формата FXT. Он отличается от обычного графика, но его можно открывать в оффлайне.


Работа с графиками — Настройка

Настройка графика

Внешний вид и свойства каждого графика в терминале могут быть настроены индивидуально. Для этого следует выполнить команду меню "Графики — Свойства", одноименную команду контекстного меню графика или нажать клавишу F8. В результате этих действий появится окно "Свойства", с помощью которого можно настроить цвет различных элементов графика (вкладка "Цвета"):

  • Фон — фон;

  • Текст — оси, шкалы и строка OHLC;

  • Сетка — сетка;

  • Бар вверх — бар вверх, тени и окантовка тела бычьей свечи;

  • Бар вниз — бар вниз, тени и окантовка тела медвежьей свечи;

  • Бычья свеча — тело бычьей свечи;

  • Медвежья свеча — тело медвежьей свеча;

  • Линия — линейный график и доджи;

  • Объемы — объемы и уровни открытых позиций;

  • Линия Ask — цвет линии Ask-цены;

  • Уровни стопа — уровни стоп-ордеров (Stop Loss и Take Profit).

В левой части окна, на графике преварительного просмотра, автоматически отображаются внесенные изменения. Кроме ручной настройки цветов различных элементов графика, можно выбрать предопределенные цветовые схемы в одноименном поле. В терминале доступны три цветовые схемы: "Yellow on Black" (желтое на черном фоне), "Green on Black" (зеленое на черном фоне) или "Black on White" (черное на белом фоне). При выборе каждой из схем вышеописанные элементы графика будут также изменяться на графике в левой части окна. Собственные цветовые схемы можно сохранять в шаблонах.

В этом окне можно также задать другие настройки графика. Для этого необходимо переключиться на вкладку "Общие" и выбрать требуемые опции:

  • Автономный график — сделать график оффлайновым. Эта опция прекращает получение и отрисовку ценовых данных для данного графика. В дальнейшем, после отключения этой опции, ценовые данные снова начинают рисоваться на графике. После открытия графика в оффлайне (команда меню "Файл — Открыть автономно") эта опция включается автоматически.

  • График сверху — расположить график на "переднем плане". Если эта функция включена, то все аналитические объекты располагаются "под" графиком цены.
    Выполнение данной команды аналогично команде меню "Графики — График сверху".

  • Смещение графика — отодвинуть график от правого края окна до метки сдвига. Метку сдвига графика (серый треугольник в верхней части окна) можно перемещать мышкой по горизонтали в пределах 10%-50% размера окна.
    Эту опцию можно также включить кнопкой Функция "Chart Shift" панели "Графики" и командой меню "Графики — Сдвиг графика".

  • Автопрокрутка графика — разрешить/запретить смещать график влево автоматически после начала формирования нового бара. Если эта опция включена, на графике всегда отображается последний бар.
    Эту опцию можно также включить кнопкой Функция "Auto Scroll" панели "Графики" и командой меню "Графики — Автопрокрутка".

  • Фиксировать масштаб — зафиксировать текущий масштаб графика. Если масштаб не зафиксирован, при прокрутке графики отображаются с автоматическим масштабированием по вертикали. Эта опция отключает автомасштабирование и фиксирует масштаб. При выборе данной опции активизируются поля дополнительных параметров масштабирования "максимум" и "минимум".

  • Фиксировать масштаб 1:1 — зафиксировать масштаб графика "один к одному" (размер одного пипса вертикальной оси в пикселах равен расстоянию между осями баров в пикселах). При этом автоматически включается опция "Фиксировать масштаб" и у правой стороны окна графика появляется бегунок полосы прокрутки, позволяющий перемещать график по вертикали. Этот режим необходим для точных геометрических построений.

  • Бары — представить график в виде последовательности баров.
    Данное действие можно также выполнить кнопкой Bar Chart панели "Графики", командой меню "Графики — Бары" либо клавишами-акселераторами Alt+1.

  • Японские свечи — представить график в виде последовательности японских свечей.
    Данное действие можно также выполнить кнопкой Candlesticks панели "Графики", командой меню "Графики — Японские свечи" либо клавишами-акселераторами Alt+2.

  • Линия — представить график в виде ломаной линии, соединяющей цены закрытия баров.
    Данное действие можно также выполнить кнопкой Line Chart панели "Графики", командой меню "Графики — Линия" либо клавишами-акселераторами Alt+3.

  • Показывать OHLC — показать/скрыть строку OHLC. При выполнении этого действия в левой верхней части окна появляется дополнительная информационная строка. В ней, кроме названия инструмента и периода графика, перечислены также цены последнего бара. Запись цен имеет формат: OPEN, HIGH, LOW и CLOSE (OHLC) — цена открытия бара, максимальная цена бара, минимальная цена и цена закрытия соответственно. Таким образом, перед глазами всегда оказывается точное значение последнего бара. Эта опция также влияет на информационную строку подокон индикаторов.

  • Показывать линию Ask — показать/скрыть уровень Ask-цены последней котировки. В терминале бары строятся и отображаются только по Bid-ценам. Однако при открытии длинных позиций и закрытии коротких всегда используется Ask-цена. Она никак не отражается на графике, ее нельзя увидеть. Чтобы более точно контролировать свою торговую деятельность, можно включить параметр "Показывать линию Ask". По выполнении этой команды на графике появится дополнительная горизонтальная линия, соответствующая Ask-цене последнего бара.

  • Показывать разделители периодов — показать/скрыть разделители периодов. На горизонтальной оси графика отображаются дата и время каждого бара. А ценой деления этой горизонтальной шкалы является выбранный период (таймфрейм). Опция "Показывать разделители периодов" наносит на график дополнительные вертикальные линии, соответствующие границам более крупного таймфрейма. Так, для графиков с периодом от M1 до H1 строятся дневные разделители, H4 — недельные, D1 — месячные, а W1 и MN1 — годовые.

  • Показывать сетку — показать/скрыть сетку в окне графика.
    Те же действия можно выполнить одноименной командой контекстного меню графика и меню "Графики", а также нажатием клавиш-акселераторов Ctrl+G.

  • Показывать объемы — показать/скрыть график объема в нижней части окна. При фиксированном масштабе эта опция не работает.
    Те же действия можно выполнить одноименной командой контекстного меню графика и меню "Графики", а также и нажатием клавиш-акселераторов Ctrl+L.

  • Показывать описания объектов — показать/скрыть описания объектов на графике. Если эта опция включена и у нанесенных на график объектов есть описания, они буду показываться прямо на графике.


Управление графиком — Руководство пользователя.

Управление — Работа с графиками

Управление графиком

Графики позволяют анализировать динамику цен на рынке и используются для графического анализа, построения различных индикаторов и линейных инструментов. Графики являются исключительно ценным инструментом для анализа финансовых рынков, поэтому им уделяется большое внимание. Управление графиком — это:

  • Смена вида
    График финансового инструмента может быть трех видов:

    1. Бары — последовательность баров.
      Чтобы получить такой график, необходимо нажать кнопку Баровый график панели "Графики", комбинацию клавиш-акселераторов Alt + 1, соответствующую опцию окна свойств графика или выполнить команду меню "Графики — Бары".

    2. Японские свечи — последовательность японских свечей.
      Для построения такого графика следует нажать кнопку График "японских свечей" панели "Графики", комбинацию клавиш-акселераторов Alt + 2, соответствующую опцию окна свойств графика или выполнить команду меню "Графики — Японские свечи".

    3. Линия — ломаная линия, соединяющая цены закрытия баров.
      Для получения этого графика необходимо нажать кнопку Линейный график панели "Графики", комбинацию клавиш-акселераторов Alt + 3, соответствующую опцию окна свойства графика или выполнить команду меню "Графики — Линия".

  • Сохранение
    Клиентский терминал позволяет сохранять исторические данные активного графика в виде текстового файла в форматах "CSV", "PRN" и "HTM".
    Чтобы сохранить их таким образом, нужно выполнить команду меню "Файл— Сохранить как" либо нажать на клавиши-акселераторы Ctrl + S. Кроме того, можно сохранять график в виде рисунка формата BMP или GIF. Для этого надо выполнить команду меню "Файл—Сохранить как рисунок". Те же действия выполняются одноименной командой контекстного меню графика.

  • Печать
    Для цветной печати изображения активного графика нужно в настройках графика установить флажок "Цветная печать", затем выполнить команду меню "Файл — Печать...", одноименную команду контекстного меню графика, нажать на кнопку Печать графика панели инструментов "Стандартная" или на клавиши-акселераторов Ctrl+P. Если флажок "Цветная печать" снят или отсутствует цветной принтер, то график печатается в черно-белом виде.

  • Полный экран
    Выполнение команды меню "Вид — Полный экран" или нажатие на клавишу F11 приводит к переходу в полноэкранный режим. На экране, кроме окон графиков, остается главное меню и панель переключения графиков. Вернуться к исходному режиму можно, выполнив ту же команду.

  • Присоединение программ MQL4
    Перед началом выполнения программы MQL4 ее нужно присоединить к графику. Для этого нужно в окне "Навигатор" выбрать требуемую MQL4-программу и дважды щелкнуть на ней или выполнить команду контекстного меню "Присоединить к графику". Также можно использовать технологию "Drag'n'Drop".

  • Работа с индикаторами
    Индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. На основе сигналов технических индикаторов принимаются решения относительно того, как и когда открывать или закрывать позицию. Индикаторы можно наложить на график при помощи команд меню "Вставка —Индикаторы" либо команд подменю управления индикаторами, которое открывается кнопкой Индикаторы панели инструментов "Графики". Технология "Drag'n'Drop" также позволяет накладывать индикаторы из окна "Навигатор" на любое открытое окно. Список наложенных на график индикаторов можно просмотреть в "Окне Данных", выполнив команду меню "Графики — Список индикаторов", одноименную команду контекстного меню графика, либо нажав клавиши-акселераторы Ctrl+I.

    Более детальная информация о работе с техническими индикаторами приводится в одноименном разделе.

  • Работа с объектами
    Для проведения анализа на график можно также накладывать различные графические объекты. Для этого нужно воспользоваться командами меню "Вставка" либо кнопками панели инструментов "Графически инструменты". В меню сгруппированы линейные инструменты, геометрические фигуры, значки и текст.

    Более детальная информация находится в разделе "Графические объекты".

  • Смена периода
    Клиентский терминал поддерживает девять различных периодов данных, от минутных до месячных. Большое количество периодов графиков необходимо для проведения анализа рынков посредством технических индикаторов и линейных инструментов.
    Выбрать требуемый период графика можно при помощи панели "Период", кнопки Период графика панели "Графики", меню "Графики — Период" либо выполнением одноименной команды контекстного меню графика.

  • Масштабирование
    Графики можно масштабировать по горизонтальной оси и тем самым увеличивать или уменьшать количество одновременно отображаемых на экране баров.
    Для этого предназначены кнопки Увеличить масштаб / Уменьшить масштаб панели "Графики", клавиши "+" / "-", команды "Увеличение"/"Уменьшение" контекстного меню графика и меню "Графики".
    Для уменьшения масштаба по вертикальной оси также можно захватить левой кнопкой мыши произвольную точку оси и сдвинуть ее вниз. Двойной щелчок мыши на вертикальной оси или нажатие клавиши "5" на дополнительной цифровой клавиатуре восстанавливает масштаб.
    Кроме того, в окне свойств графика при помощи опции "Фиксировать масштаб" можно задать точный масштаб, определив верхнюю и нижнюю границы. Опция "Фиксировать масштаб 1:1" того же окна позволяет установить масштаб "один к одному", то есть, один пипс вертикальной оси будет соответствовать одному бару на горизонтальной.

  • Прокрутка, автопрокрутка и сдвиг графика
    Прокрутка — это смещение ценовых данных на графике вправо/влево, выполняемое курсорными клавишами клавиатуры. Кроме того, прокручивать график можно при помощи клавиш F12 (режим "Шаг за шагом" — смещение графика на один бар влево) и Shift+F12 (смещение графика на один бар вправо), а также при помощи мыши: удерживая левую кнопку мыши на любой точке графика, необходимо перемещать курсор вправо/влево. Также при помощи строки быстрой навигации можно отобразить необходимую область графика, указав конкретные дату и время. В случае сдвига графика в область, где отсутствуют ценовые данные, произойдет автоматическая загрузка недостающих баров.

    Если зафиксирован масштаб графика, его можно также прокручивать по вертикали. Для этого необходимо удерживая бегунок на вертикальной шкале перемещать мышь вверх/вниз. Чтобы вернуть график в пределы видимости, необходимо нажать клавишу "5" на дополнительной цифровой клавиатуре либо дважды кликнуть мышью в области ценовой шкалы графика.

    Автопрокрутка предназначена для того, чтобы всегда перед глазами иметь последние бары. Если эта опция включена, с приходом новой котировки график автоматически перемещается в конец. Включить данную функцию можно кнопкой Автопрокрутка панели "Графики" и командой меню "Графики — Автопрокрутка".

    Опция "Сдвиг графика" отодвигает последний бар от правого края экрана до метки сдвига графика. Метку сдвига графика (серый треугольник в верхней части окна) можно перемещать мышкой по горизонтали в пределах 10-50% размера окна. Сдвиг графика включается кнопкой Сдвиг графика панели "Графики" и командой меню "Графики — Сдвиг графика".

  • Позиционирование графика
    Обычно точка привязки графика располагается в левой части окна. К ней привязывается бар с конкретным временем, который можно переместить при помощи прокрутки или строки быстрой навигации. При смене таймфрейма производится попытка рассчитать новый бар привязки, соответствующий бару на предыдущем периоде. То есть, с левого края окна графика будет отображаться ближайший к заданой точке временной промежуток. Точку привязки (серый треугольник на нижней границе графика) можно перемещать в пределах окна графика при помощи мыши. Он появляется только в случае, если отключена "Автопрокрутка". Этот механизм удобен при анализе определенного временного промежутка на разных таймфреймах.

    Внимание: позиционирование не работает, если включена опция "Автопрокрутка".

  • Работа с шаблонами
    Шаблоны представляют собой запись характеристик окна графика. В шаблоне сохраняются: вид графика, период, масштаб, все настройки линейных инструментов, технических и пользовательских индикаторов, а также экспертов. Шаблоны позволяют легко и быстро приводить множество различных графиков к единому виду.
    Меню управления шаблонами можно вызвать командой меню "Графики — Шаблон", одноименной командой контекстного меню графика и кнопкой Шаблоны графиков панели "Графики". Команда меню "Сохранить шаблон…" позволяет сохранить новый шаблон, а "Удалить шаблон" — удалить ранее созданный.
    Более детальная информация находится в разделе "Шаблоны и профили".

  • Работа с профилями
    Концепция профилей предлагает удобный способ работы с группами графиков. Когда открывается профиль, каждый график со всеми настройками располагается точно в том же месте, где он был при сохранении профиля.
    Меню управления профилями можно открыть командой меню "Файл — Профили", нажав кнопку Профили панели инструментов "Стандартная" либо щелкнув мышью в окошке статусной строки с именем текущего профиля.
    Более детальная информация находится в разделе "Шаблоны и профили".

  • Обновление данных
    К обновлению данных прибегают в случае возникновения ошибок или "дыр" на ценовом графике. Чтобы обновить ценовые данные, необходимо выполнить команду меню "Графики — Обновление" или одноименную команду контекстного меню графика. При выполнении всех этих действий происходит автоматическая загрузка с сервера недостающих баров и их прорисовка на графике.

Работа мышью

Управление графиком непосредственно мышью производится следующим образом:

  • нажатие левой кнопки мыши в любой точке окна графика и удержание с последующим горизонтальным перемещением курсора приводят к прокрутке графика;

  • нажатие левой кнопки мыши на вертикальной шкале графика и удержание с последующим вертикальным перемещением курсора приводят к изменению масштаба графика по вертикали, двойной щелчок мыши на вертикальной шкале восстанавливает масштаб;

  • нажатие левой кнопки мыши на горизонтальной шкале графика (кроме области строки быстрой навигации) и удержание с последующим горизонтальным перемещением курсора приводят к изменению масштаба графика;

  • нажатие правой кнопки мыши в любой точке окна графика вызывает контекстное меню графика (описано ниже);

  • двойной щелчок левой кнопки мыши на элементах технических индикаторов (линии, символы, столбцы гистограмм и так далее) вызывает окно настройки соответствующего индикатора;

  • щелчок правой кнопкой мыши на элементах технического индикатора вызывает контекстное меню индикатора;

  • одинарный либо двойной, в зависимости от настройки терминала, щелчок левой кнопкой мыши на объекте (линейный инструмент, текст или значок) выделяет объект;

  • нажатие левой кнопки мыши на выделенном объекте и удержание с последующим перемещением позволяет перемещать выделенный объект;

  • Ctrl + нажатие левой кнопки мыши на выделенной трендовой линии с последующим перемещением позволяет нарисовать параллельную трендовую линию (создать канал);

  • щелчок средней кнопки мыши в окне графика переводит курсор в режим "перекрестье";

  • нажатие правой кнопки мыши на выделенном объекте открывает его контекстное меню;

  • установка курсора на цене закрытия бара либо на элементе объекта или индикатора вызывает подсказку.

Управление графиком при помощи команд контекстного меню

Часть команд контекстного меню предназначена для управления графиком:

  • Советники — подменю управления советниками. Советником (экспертом) называется MQL4-программа, выполняющаяся с каждым новым тиком и позволяющая автоматизировать аналитическую и торговую деятельности. В подменю управления советниками сгруппированы команды управления наложенным на график экспертом. При помощи этого подменю можно изменить свойства советника, удалить его или приступить к тестированию.
    Более детальная информация находится в разделе "Советники".

  • Удалить скрипт — удалить исполняемый скрипт. Скриптом называется программа, написанная на языке MetaQuotes Language 4 (MQL 4) и предназначенная для одноразового выполнения каких-либо действий.

  • Список индикаторов — окно управления техническими индикаторами, присоединенными к окну графика. Техническим индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. На основе сигналов технических индикаторов принимаются решения относительно того, как и когда открывать или закрывать позицию.

  • Список объектов — окно управления графическими объектами. Графическими в терминале называются объекты, накладываемые на график вручную. Они предназначены для аналитических целей.

  • Период — подменю управления периодом графика.
    Периодом графика можно также управлять при помощи одноименных команд меню "Графики" и панели инструментов.

  • Шаблон — подменю управления шаблонами. Шаблоном называется набор настроек окна графика, который можно применить для других графиков.
    Подменю управления шаблонами можно также вызвать при помощи одноименной команды меню "Графики".

  • Обновление — обновить исторические данные. При этом произойдет загрузка всех недостающих в пределах имеющейся истории и новых данных.
    Это же действие можно выполнить одноименной командой меню "Графики".

  • Авторазмер — установить высоту всех окон индикаторов по умолчанию.
    Это же действие можно выполнить нажатием клавиш-акселераторов Ctrl+A.

  • Сетка — показать/скрыть сетку.
    Это же действие можно выполнить одноименной командой меню "Графики" и нажатием клавиш-акселераторов Ctrl+G.

  • Объемы — показать/скрыть график объемов.
    Те же действия можно выполнить одноименной командой меню "Графики" и нажатием клавиш-акселераторов Ctrl+L.

  • Увеличение — увеличить масштаб графика по горизонтали на один шаг.
    Масштаб можно также увеличить при помощи одноименной команды меню "Графики", клавиши "+" или кнопки Zoom In панели инструментов "Графики".

  • Уменьшение — уменьшить масштаб графика на один шаг.
    Масштаб можно также уменьшить при помощи одноименной команды меню "Графики", клавиши "-" или кнопки Zoom Out панели инструментов "Графики".

  • Удалить окно индикатора — удалить окно индикатора. Некоторые индикаторы строятся в специальных подокнах с собственной шкалой. Эта команда позволяет удалить такое подокно.
    Более детальная информация по работе с техническими индикаторами приводится в соответствующем разделе.

  • Сохранить как рисунок — сохранить график в виде рисунка (формат GIF или BMP).
    Это же действие можно выполнить командой меню "Файл — Сохранить как рисунок".

  • Предварительный просмотр — предварительный просмотр образа графика перед печатью.
    Это же действие можно выполнить командой меню "Файл — Предварительный просмотр" или копкой предварительный просмотр панели инструментов "Стандартная".

  • Печать — печать графика. Если в настройках программы включена опция "Цветная печать", можно распечатать не черно-белый, а цветной график.
    Это же действие можно выполнить командой меню "Файл — Печать", клавишами-акселераторами Ctrl+P или кнопкой Печать графика панели инструментов "Стандартная".

  • Свойства — вызвать окно настройки параметров графика.
    Это же действие можно выполнить горячей клавишей F8.

Внимание: подменю "Советники", команды "Удалить скрипт", "Список индикаторов" и "Список объектов" активизируются только в случае если на график наложены соответствующие объекты.


Печать графиков — Работа с графиками

Печать графиков

В клиентском терминале имеются средства для печати графиков. Распечатать график можно в цветном или черно-белом виде. Для цветной печати необходимо в окне настроек клиентского терминала включить опцию "Цветная печать". После чего на цветной принтер график будет выводиться в цвете. В противном случае график будет печататься в черно-белом виде.

Перед печатью иногда требуется настроить имеющийся принтер. Для этого необходимо выполнить команду меню Файл — Настройка печати". Чтобы убедиться в том, что все требуемые элементы попадают в область печати, можно выполнить команду "Предварительный просмотр" того же меню, одноименную команду контекстного меню графика или нажать кнопку Предварительный просмотр панели инструментов "Стандартная". Непосредственно печать выполняется командой меню "Файл — Печать...", одноименной командой контекстного меню графика, кнопкой Печать графика панели инструментов "Стандартная" либо с помощью клавиш-акселераторов Ctrl+P.


Работа с графиками — Удаленные графики

Удаленные графики

В процессе работы некоторые графики становятся ненужными, и возникает необходимость их удалить. Это можно сделать командой меню "Файл — Закрыть" либо нажатием клавиш-акселераторов Ctrl+F4. При этом шаблоны удаленных окон будут сохраняться, если в окне настройки клиентского терминала выставлен флажок "Сохранять удаленные окна для переоткрытия". В дальнейшем эти шаблоны можно использовать. Так, если график был удален случайно, его можно восстановить. Для этого нужно выполнить команду меню "Файл — Открыть удаленный" и выбрать финансовый инструмент из списка. После этого окно графика выбранного финансового инструмента полностью восстановится со всеми настройками и наложенными на график элементами.


Шаблоны и профили — Руководство пользователя

Шаблоны и профили — Работа с графиками

Шаблоны

Шаблоном называется набор настроек окна графика, который можно применить для других графиков. В шаблонах запоминаются:

  • тип и цвет графика;

  • цветовая схема;

  • масштаб графика;

  • наличие строки OHLC;

  • прикрепленный советник и его параметры;

  • наложенные пользовательские и технические индикаторы с их настройками;

  • линейные инструменты;

  • разделители дней.

При наложении шаблона на график записанные настройки как бы прилагаются к инструменту и периоду. Например, можно создать шаблон, который включает индикаторы MACD, RSI и Moving Average, а затем использовать его для других графиков. В этом случае у окон графиков будет один и тот же вид для разных финансовых инструментов и периодов.

Шаблоны сохраняются в директории /TEMPLATES в TPL-файлах. Однажды созданный шаблон может использоваться неограниченное количество раз. В процессе установки терминала создается базовый шаблон (DEFAULT.TPL), который будет автоматически применяться при создании нового окна графика. В дальнейшем его можно будет изменить, воспользовавшись характеристиками активного окна графика.

Чтобы создать новый шаблон, необходимо выполнить команду меню "Графики — Шаблон — Сохранить шаблон...", одноименную команду контекстного меню графика или нажать кнопку Шаблоны панели "Графики". В результате на базе информации активного окна графика будет создан новый шаблон. Для изменения шаблона необходимо выполнить те же действия, но вместо нового имени файла следует выбрать уже существующий шаблон. Наложить шаблон на окно графика можно, выбрав требуемый файл в меню управления шаблонами либо из любой доступной папки в окне "Открыть", которое вызывается командой меню "Графики — Шаблон — Загрузить шаблон...". Команда меню "Графики — Шаблон — Удалить шаблон" и одноименная команда контекстного меню графика позволяют удалять шаблоны.

Внимание: шаблон "DEFAULT.TPL" удалить нельзя.

Профили

Концепция профилей предлагает удобный способ работы с группами графиков. Когда открывается профиль, каждый график со всеми настройками располагается точно в том же месте, где он был при сохранении профиля. Все изменения во всех окнах графиков данного списка автоматически сохраняются в текущем профиле. Список всех окон графиков текущего профиля находится в меню "Окно". Имя текущего профиля высвечивается в одном из окошек статусной строки и помечено галочкой в меню управления профилями. В процессе установки терминала создается профиль по умолчанию (DEFAULT). Изначально в нем хранятся четыре окна графика основных валютных пар "EUR/USD", "USD/CHF", "GBP/USD" и "USD/JPY".

Все управление профилями объединено в меню, которое можно вызвать командой меню "Файл — Профили", нажав кнопку Профили панели инструментов "Стандартная" либо щелкнув мышью в окошке статусной строки с именем текущего профиля. Чтобы использовать другой профиль, необходимо выбрать требуемое название из списка этого меню. При этом новый профиль открывается и становится текущим. Команда "Сохранить профиль" сохраняет текущий профиль в состоянии на момент начала выполнения команды под новым именем. Новый профиль является копией предыдущего и становится текущим. С помощью команды "Удалить профиль" можно удалять профили.

Команда "Следующий профиль" и клавиши Ctrl + F5 по порядку открывают все имеющиеся профили, а команда "Предыдущий профиль" и клавиши Shift + F5 позволяют перебирать профили в обратном направлении.

Внимание: текущий профиль и профиль по умолчанию (DEFAULT) удалить нельзя.

В клиентском терминале торговому счету можно назначать предопределенный профиль. Такой профиль должен иметь имя, совпадающее с номером торгового счета. Если при переключении на данный торговый счёт имеется соответствующий профиль, то происходит его автоматическое открытие. Если предопределенного профиля не существует, то активным профилем остается текущий.


Линейные инструменты — Руководство пользователя

Линейные инструменты — Работа с графиками

Аналитика

Для аналитических целей в терминал встроены технические индикаторы и линейные инструменты. Эти объекты накладываются прямо на график и позволяют прогнозировать дальнейшую динамику цен. При этом индикаторы накладываются автоматически, а линейные инструменты — вручную. Поэтому при работе с линейными инструментами важно их правильное построение. С другой стороны, параметры индикаторов также могут быть настроены вручную. На разных финансовых инструментах и периодах технические индикаторы могут иметь разные настройки.

Использование технических индикаторов и линейных инструментов позволяет обоснованно открывать и закрывать торговые позиции, выставлять и модифицировать отложенные ордера. Кроме того, использование аналитических средств позволяет вести систематизированную торговую деятельность и тем самым снижает влияние эмоционального фактора. Наряду со встроенными техническимим индикаторами для аналитических целей можно использовать собственные индикаторы, написанные на языке MetaQuotes Language 4 (MQL 4). Аналогов линейным инструментам на языке MQL 4 создать нельзя.


Аналитика — Графические объекты

Графические объекты

Графическими объектами в терминале называются объекты, накладываемые на график вручную. Эти объекты предназначены для аналитических целей. К ним относятся:

  • Линейные инструменты — линии и различные геометрические фигуры, наносящиеся на графики цен или индикаторов. В их число входят линии поддержки/сопротивления, линии тренда, а также инструменты Фибоначчи, Ганна, Эндрюса и др. Более детальная информация по линейным инструментам приводится в одноименном разделе;

  • Фигуры — геометрические фигуры (прямоугольник, треугольник и эллипс), позволяющие выделять различные области на ценовом графике;

  • Значки — символы (стрелочки, значки проверки и остановки), позволяющие выделять на графике наиболее значимые точки;

  • Текст — текст, предназначенный для добавления комментариев на график;

  • Текстовая Метка — текст, предназначенный для добавления комментариев и привязанный к координатам окна графика. При прокрутке графика текстовая метка не перемещается.

Все объекты сгруппированы в меню "Вставка" и на панели "Графические инструменты". Выбрав объект из списка и указав точку на графике (или в окне идикатора), можно наложить инструмент.

Внимание: для наложения некоторых объектов необходимо задать не одну, а несколько точек. До тех пор пока не будут указаны все точки, объект на графике не появится.

После того как объект создан, его можно изменить или переместить. Для этого необходимо сначала выделить объект. При этом, если в настройках терминала выставлен параметр "Выделять объекты по одиночному клику мыши", необходимо одиночное нажатие левой кнопки мыши на любом элементе объекта. В противном случае — двойное. Свидетельством выделения объекта можно считать появление квадратных маркеров или рамок. Эти маркеры предназначены для перемещения объектов и изменения параметров их построения. Так, например, чтобы изменить положение Веера Фибоначчи, следует захватить левой кнопкой мыши его центральный маркер и переместить курсор. В то же время перемещение любого из крайних маркеров приведет к изменению параметров построения объекта. Терминал позволяет быстро создавать копии различных объектов. Для этого необходимо выделить объект и, нажав клавишу Ctrl, переместить его при помощи центрального маркера.

Все нанесенные на график объекты рано или поздно становятся ненужными, и их можно удалять при помощи команд контекстного меню. Кроме того, клавиша Backspace позволяет последовательно удалять объекты. В дальнейшем все удаленные объекты можно восстановить. Для этого небходимо выполнить команду "Отменить удаление" контекстного меню объекта, команду меню "Графики — Объекты — Отменить удаление" либо использовать клавиши-акселераторы Ctrl+Z.

Свойства объекта

Каждый объект обладает определенными свойствами. От объекта к объекту эти свойства могут меняться. Для управления свойствами объектов необходимо выделить объект и выполнить команду его контекстного меню "Свойства", команду меню "Графики — Объекты — Список объектов". При этом появится одноименное окно, в котором располагаются несколько вкладок. Во вкладке "Общие" размещены обобщенные настройки объектов. Здесь доступны:

  • Имя — уникальное название объекта в пределах одного графика, которое ему присваивается автоматически. Записав в поле другое название, можно изменить его. Такие имена позволяют легко выделять объект среди множества однотипных;

  • Описание/Текст — описание/текст объекта, также позволяющие выделять его из множества однотипных. Кроме того, эти описания могут выводиться на график, если включена опция "Показывать описания объектов" в настройках графика;

  • Стиль — стиль линий объекта. Здесь можно выбрать цвет, вид и толщину линий;

  • Рисовать объект как фон — рисовать объект в фоновом слое, под графиком. Для фигур и каналов (кроме канала Фибоначчи) включение опции "Рисовать объект как фон" дает заливку объекта.

Во вкладке "Параметры" можно изменить координаты точек привязки объекта на графике. В полях "Время" задаются временные координаты точки привязки объекта. А в полях "Значение" — координаты привязки по вертикальной оси графика или индикатора. У объекта может быть от одной до трех координат. Для некоторых объектов во вкладке "Параметры " используются дополнительные опции:

  • Угол в градусах — угол наклона объекта в градусах против часовой стрелки;

  • Масштаб — соотношение единиц вертикальной (пипсы) и горизонтальной (бары) осей объекта. Обычно при построении графиков количество пикселов в единице горизонтальной оси (шкала времени) отличается от их количества в единице на вертикальной оси (шкала цен). Масштаб 1:1 приводит их к одинаковому значению. Изменение этого параметра для отдельных объектов меняет данное соотношение;

  • Код значка — код объекта;

  • Луч — отображать в виде лучей трендовые линии объекта;

  • Угол привязки — один из углов окна графика, к которому привязана текстовая метка;

  • По оси X: — расстояние в пикселах от угла привязки до текстовой метки по горизонтали;

  • По оси Y: — расстояние в пикселах от угла привязки до текстовой метки по вертикали.

Во вкладке "Отображение" можно изменять режим отображения объекта на различных таймфреймах (периодах). Данный объект будет показываться только на выбранных периодах. Эта возможность оказывается полезной, когда инструмент на разных таймфреймах имеет различные настройки. Вкладка "Уровни Фибоначчи" является специфичной и используется только для Фибо-инструментов. Здесь в виде таблицы приводится список уровней инструмента. Значения этих уровней можно изменить или удалить вовсе (кнопка "Удалить"). Также, воспользовавшись кнопкой "Добавить", можно создать дополнительный уровень. При этом если в поле "Описание" уровня записать "(%$)", то на графике также будет отображаться значение цены, соответствующее этому уровню. Кнопка "По умолчанию" устанавливает первоначальные значения. В нижней части вкладки приводится поле "Стиль", позволяющее настраивать цвет, вид и толщину уровней объекта.


Аналитика — Линейные инструменты

Линейные инструменты

Линейными инструментами называют линии и различные геометрические фигуры, наносящиеся на графики цен или индикаторов. В их число входят линии поддержки/сопротивления, линии тренда, а также инструменты Фибоначчи, Ганна, Эндрюса и др.

Линейные инструменты в терминале объединены в меню "Вставка" и на панели инструментов "Графические инструменты". Чтобы наложить объект, необходимо нажать соответствующую кнопку панели инструментов (в крайнем левом столбце таблицы приведены соответствующие кнопки) или выполнить команду меню.

 | Команда меню | Описание
Горизонтальная линия | Горизонтальная линия | Горизонтальная линия подходит для обозначения различных уровней, в частности, уровней поддержки и сопротивления. Для нанесения объекта необходимо задать одну точку.
Вертикальная линия | Вертикальная линия | Вертикальная линия подходит для обозначения различных границ на временной оси и сопоставления сигналов индикаторов с динамикой цен. Чтобы нанести объект, необходимо задать одну точку.
Трендовая линия | Трендовая линия | Трендовая линия помогает выявлять тенденции развития цен. Для выставления тренда следует определить две точки, через которые пройдёт линия.
Тренд по углу | Трендовая линия по углу | Трендовая линия по углу помогает выявлять тенденции развития цен. В отличие от простой трендовой линии, для построения этого инструмента необходимо указать угол. Для выставления тренда необходимо определить две точки, через которые пройдёт линия.
Канал линейной регрессии | Канал линейной регрессии | Линейная регрессия — это инструмент статистического анализа, используемый для предсказания будущих значений по имеющимся данным. В условиях восходящей тенденции логично предположить, что следующий бар будет немного выше текущего. Метод линейной регрессии позволяет получить статистическое подтверждение подобных логических выводов. Чтобы построить инструмент, необходимо задать две точки.
Трендовый канал | Трендовый канал | Линии трендового канала всегда параллельны. Для построения инструмента требуется определить две точки.
Канал стандартных отклонений | Канал стандартных отклонений | Стандартное отклонение — это измерение волатильности при помощи статистических методов. Стандартное отклонение влияет на ширину данного канала. Для построения инструмента требуется задать две точки.
Линия Ганна | Линия Ганна | Линия Ганна представляет собой линию тренда, построенную под углом в 45 градусов. Чтобы построить инструмент, необходимо задать две точки.
Веер Ганна | Веер Ганна | Веер Ганна представляет собой набор линий тренда, проведенных из одной точки под разными углами. Линию тренда 1х1 (45 градусов) Ганн считал наиболее важной. Положение ценовой кривой выше этой линии служит признаком бычьего рынка, а ниже нее — медвежьего. Ганн полагал, что луч 1х1 является мощной линией поддержки при восходящей тенденции, а прорыв этой линии рассматривал как важный сигнал разворота. Для построения Веера Ганна необходимо задать одну точку.
Сетка Ганна | Сетка Ганна | Линии сетки Ганна располагаются под углом в 45 градусов. Чтобы построить инструмент, необходимо задать две точки.
Уровни Фибоначчи | Уровни Фибоначчи | Считается, что Леонардо Фибоначчи открыл числовую последовательность, в которой каждый последующий член представляет собой сумму двух предыдущих: 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144 и т.д. Каждое число приблизительно в 1,618 раз больше предыдущего, а каждое предыдущее составляет приблизительно 0,618 от следующего. Инструмент строится по двум точкам, определяющим линию тренда, при этом автоматически проводятся горизонтальные линии, пересекающие тренд на уровнях Фибоначчи 0.0%, 23.6%, 38.2%, 50%, 61.8%, 100%, 161.8%, 261.8% и 423.6%.
Канал Фибоначчи | Канал Фибоначчи | Для построения инструмента используются канал, ширина которого принимается за единицу. Затем на расстоянии значений ряда Фибоначчи наносятся параллельные линии, начиная с 0.618-кратного размера канала, затем 1.000-кратного, 1.618-кратного, 2.618-кратного, 4.236-кратного и так далее. Для построения инструмента требуется задать две точки и ширину базового канала.
Временные зоны Фибоначчи | Временные зоны Фибоначчи | Временные зоны Фибоначчи — это ряд вертикальных линий с интервалами Фибоначчи 1, 2, 3, 5, 8, 13, 21, 34 и т.д. Считается, что вблизи этих линий следует ожидать значительных ценовых изменений. Инструмент строится по двум точкам, определяющим длину единичного интервала.
Веер Фибоначчи | Веер Фибоначчи | Веер Фибоначчи строится по двум точкам, определяющим линию тренда. Затем через вторую точку проводится «невидимая» вертикальная линия. Потом из первой точки проводятся три тренда, пересекающие невидимую вертикальную линию на уровнях Фибоначчи 38.2%, 50% и 61.8%. Считается, что вблизи этих линий следует ожидать значительных ценовых изменений.
Дуги Фибоначчи | Дуги Фибоначчи | Инструмент Дуги Фибоначчи строится по двум точкам, определяющим линию тренда. Затем строятся три дуги с центром во второй точке, пересекающие линию тренда на уровнях Фибоначчи 38.2%, 50% и 61.8%. Считается, что вблизи этих дуг следует ожидать значительных ценовых изменений.
Расширение Фибоначчи | Расширение Фибоначчи | Расширение Фибоначчи строится по трем точкам, описывающим две волны. Затем строятся три линии, пересекающие третью "предполагаемую" волну на уровнях Фибоначчи 61.8%, 100% и 161.8%. Считается, что вблизи этих линий следует ожидать значительных ценовых изменений.
Вилы Эндрюса | Вилы Эндрюса | Этот инструмент строится по трем точкам и представляет собой три параллельные линии тренда. Первая линия тренда начинается в выбранной крайней левой точке (это важный пик или впадина) и проводится точно между двумя крайними правыми точками. Эта линия — «рукоятка» вил. Затем параллельно первой линии проводятся вторая и третья линии тренда, исходящие из двух вышеупомянутых крайних правых точек (важные пик и впадина). Эти линии - «зубья» вил. Интерпретация Вил Эндрюса основывается на стандартных правилах интерпретации линий поддержки и сопротивления.
Линии Циклов | Циклические линии | Этот инструмент представляет собой ряд вертикальных линий с равными интервалами. Обычно единичный интервал соответствует одному циклу. При этом считается, что достроенные линии описывают будущие циклы. Инструмент строится по двум точкам, определяющим длину единичного интервала.


Аналитика — Технические индикаторы

Технические индикаторы

Техническим индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. На основании сигналов технических индикаторов принимаются решения относительно того, как и когда открывать или закрывать позицию. В соответствии с функциональными свойствами индикаторы можно разделить на две группы: индикаторы тенденций и осцилляторы. Индикаторы тенденций помогают выделять движение цены в одном направлении и определять моменты разворота тенденций синхронно или с опозданием. Осцилляторы позволяют определять поворотные моменты с опережением или синхронно.

Индикаторы накладываются на график из окна "Навигатор" при помощи технологии Drag`n`Drop, командой меню "Вставка — Индикаторы" или кнопкой [image] панели инструментов "Графики". Технический индикатор может строиться в создаваемом отдельном окне индикатора с собственной вертикальной шкалой (например, MACD) или накладываться прямо на график цен (например, Moving Average). При этом можно строить индикаторы не только от ценовых данных и их производных (Median Price, Typical Price, Weighted Close), но и от других индикаторов. Например, можно построить индикатор Moving Average от Awesome Oscillator и тем самым получить в дополнение к AO сигнальную линию. Для этого необходимо сначала построить индикатор AO, а затем при помощи технологии Drag`n`Drop наложить MA на AO и в его настройках в поле "Применить к" выбрать "Previous Indicator Data" (наложить индикатор на данные предыдущего индикатора). Если выбрать "First Indicator Data", MA будет строиться на основании данных самого первого индикатора, которым не обязательно является AO.

При настройке индикаторов, помимо аналитических характеристик, можно задавать цвета элементов, толщину линий и размеры используемых символов. Кроме того, во вкладке "Отображение" можно изменять режим отображения объекта на различных таймфреймах (периодах). При этом индикатор будет показываться только на выбранных периодах. Этот инструмент бывает полезным, если инструмент на разных таймфреймах имеет различные настройки. Также при помощи опции "Показывать в Окне данных" в той же вкладке можно контролировать отображение информации об индикаторах в "Окне данных".

Все настройки можно изменять. Для этого необходимо в окне "Список индикаторов" выделить нужный индикатор и нажать на кнопку "Правка" или выполнить команду "Свойства..." контекстного меню индикатора. Контекстное меню индикатора вызывается нажатием правой кнопки мыши на линии, символе или гистограмме требуемого индикатора. Чтобы удалить индикатор, следует выполнить команду контекстного меню индикатора "Удалить индикатор" либо команду "Удалить окно индикатора" из контекстных меню графика или индикатора. По команде "Удалить окно индикатора" окно индикатора закрывается.

Внимание: подведя курсор к линии, символу или краю столбца гистограммы индикатора, можно определить точное значение данного индикатора в этой точке.


Технические индикаторы — Acceleration/Deceleration

Acceleration/Deceleration — АС

Цена - это элемент, который изменяется в последнюю очередь. Прежде чем изменится цена, изменяется движущая сила рынка, а перед тем, как движущая сила изменит свое направление, ускорение движущей силы должно замедлиться и дойти до нуля. Затем она начинает ускоряться в противоположном направлении, до тех пор пока цена не начнет менять свое направление.

Технический индикатор Ускорения/Замедления (Acceleration/Deceleration, AC) измеряет ускорение и замедление текущей движущей cилы. Этот индикатор будет менять направление перед изменением движущей силы, которая, в свою очередь, будет менять свое направление перед изменением цены. Понимание того, что АС является более ранним предупреждающим сигналом, дает очевидные преимущества во время торговли.

Нулевая линия - это, по существу, место, где движущая сила сбалансирована с ускорением. Если Осциллятор Ускорения/Замедления (Acceleration Deceleration, AC) выше нуля, то обычно для ускорения бывает легче продолжить движение наверх (и наоборот - когда ниже нуля). В отличие от Аwesome Оscillator, пересечение нулевой линии не представляет собой сигнала. Единственное, что необходимо делать, чтобы контролировать рынок и принимать решения, - это следить за изменением цвета. Чтобы избежать длительных размышлений, необходимо помнить: при помощи АС нежелательно покупать, когда текущий столбец окрашен в красный цвет, и нежелательно продавать, когда текущий столбец окрашен в зеленый цвет.

Если входить в рынок в направлении движущей силы (индикатор Acceleration/Deceleration выше нуля при покупке, ниже нуля — при продаже), то необходимы только два зеленых столбца (для покупки) или два красных столбца (для продажи). Если движущая сила против открываемой позиции (индикатор ниже нуля при покупке и выше нуля при продаже), необходимо подтверждение, поэтому требуется дополнительный столбец. В этом случае для короткой позиции нужно, чтобы индикатор показывал три красных столбца выше нулевой линии, а для длинной — три зеленых столбца ниже нулевой линии.

Расчет

Гистограмма АС — это разность между значением 5/34 гистограммы движущей силы и 5-периодным простым скользящим средним, взятым от этой гистограммы.

MEDIAN PRICE = (HIGH + LOW) / 2
AO = SMA (MEDIAN PRICE, 5) — SMA (MEDIAN PRICE, 34)
AC = AO — SMA (AO, 5)

где:
MEDIAN PRICE — медианная цена;
HIGH — максимальная цена бара;
LOW — минимальная цена бара;
SMA — простое скользящее среднее;
AO — индикатор Awesome Oscillator.


Технические индикаторы — Accumulation/Distribution

Accumulation/Distribution (A/D)

Технический индикатор Накопления/Распределения (Accumulation/Distribution, A/D) определяется изменением цены и объема. Объем выступает в роли весового коэффициента при изменении цены: чем больше коэффициент (объем), тем значительнее вклад изменения цены (за данный промежуток времени) в значение индикатора.

Фактически, этот индикатор - вариант более распространенного индикатора Балансового Объема (On Balance Volume). Оба они используются для подтверждения ценовых изменений путем измерения соответствующего объема торгов.

Рост индикатора Accumulation/Distribution (A/D) означает накопление (покупку) ценной бумаги, поскольку подавляющая доля объема торгов связана с восходящим движением цен. Когда индикатор падает, это означает распределение (продажу) ценной бумаги, поскольку подавляющая доля объема торгов связана с нисходящим движением цен.

Расхождения между индикатором Accumulation/Distribution и ценой бумаги свидетельствуют о предстоящем изменении цен. Обычно в случае расхождения ценовая тенденция изменяется в направлении движения индикатора. Так, если индикатор растет, а цена бумаги падает, то следует ожидать разворота цен.

Расчет:

К текущему накопленному значению индикатора прибавляется или вычитается из него определенная доля дневного объема. Чем ближе цена закрытия к максимуму дня, тем больше прибавляемая доля. Чем ближе цена закрытия к минимуму дня, тем больше вычитаемая доля. Если цена закрытия находится строго между максимумом и минимумом, значение индикатора не изменяется.

A/D = SUM (((CLOSE - LOW) - (HIGH - CLOSE)) * VOLUME / (HIGH - LOW), N)

Где:
CLOSE — цена закрытия;
LOW — минимальная цена бара;
HIGH — максимальная цена бара;
N — количество периодов, используемых для расчета;
SUM (..., N) — сумма за N периодов.


Технические индикаторы — Alligator

Alligator

"Большую часть времени рынок никуда не движется. Только 15–30% от всего времени рынок образует какие-то тенденции, и трейдеры, которые не находятся в биржевом зале, почти все свои прибыли извлекают из трендовых движений. Мой дед часто повторял: «Даже слепая курица найдет зерна, если ее кормить в одно и то же время». Мы называем торговлю по тренду «рынок слепой курицы». Хотя нам понадобились годы, мы все-таки разработали индикатор, который всегда позволяет нам «держать порох сухим» до тех пор, пока мы не окажемся в «рынке слепой курицы»."

Bill Williams

Технический индикатор Alligator — это комбинация Линий Баланса (Скользящих Средних, Moving Averages), использующих фрактальную геометрию и нелинейную динамику.

  • Синяя линия (Челюсть Аллигатора) — это Линия Баланса для временного периода, который использовался для построения графика (13-периодное сглаженное скользящее среднее, сдвинутое на 8 баров в будущее).

  • Красная линия (Зубы Аллигатора) — это Линия Баланса для значимого временного периода на порядок ниже (8-периодное сглаженное скользящее среднее, сдвинутое на 5 баров в будущее).

  • Зеленая линия (Губы Аллигатора) — это Линия Баланса для значимого временного периода, который ниже еще на один порядок (5-периодное сглаженное скользящее среднее, сдвинутое на 3 бара в будущее).

Губы, Зубы и Челюсть Аллигатора показывают взаимодействие разных временных периодов. Поскольку тренды на рынке можно выделить лишь в течение 15–30 процентов времени, то необходимо следовать трендам и не работать на рынках, изменяющихся только в пределах определенных ценовых периодов.

Когда Челюсть, Зубы и Губы закрыты или переплетены, Аллигатор собирается спать или уже спит. Когда он спит, его голод увеличивается — чем дольше он спит, тем более голодным он будет, когда проснется. Когда он просыпается, первое, что он делает, — это открывает свою Пасть и начинает зевать. Затем он начинает чуять запах пищи: мясо быка или мясо медведя, и начинает за ним охотиться. Когда Аллигатор основательно наестся, он начинает терять интерес к пище-цене (Линии Баланса сходятся) — это время для фиксирования прибыли.

Расчет

MEDIAN PRICE = (HIGH + LOW) / 2
ALLIGATORS JAW = SMMA (MEDEAN PRICE, 13, 8)
ALLIGATORS TEETH = SMMA (MEDEAN PRICE, 8, 5)
ALLIGATORS LIPS = SMMA (MEDEAN PRICE, 5, 3)

где:
MEDIAN PRICE — медианная цена;
HIGH — максимальная цена бара;
LOW — минимальная цена бара;
SMMA (A, B, C) — сглаженное скользящее среднее. Параметр А — сглаживаемые данные, В — период сглаживания, С — сдвиг в будущее. Например, SMMA (MEDIAN PRICE, 5, 3) означает, что сглаженная скользящая берется от медианной цены, при этом период сглаживания равен 5 барам, а сдвиг — 3;
ALLIGATORS JAW — Челюсти Аллигатора (синяя линия);
ALLIGATORS TEETH — Зубы Аллигатора (красная линия);
ALLIGATORS LIPS — Губы Аллигатора (зеленая линия).


Технические индикаторы — Average Directional Movement Index

Average Directional Movement Index

Технический индикатор Индекс Среднего Направления Движения (Average Directional Movement Index, ADX) помогает определить наличие ценовой тенденции. Его разработал и подробно описал в книге «Новые концепции технических торговых систем» Уэллс Уайлдер.

Простейший метод торговли на основе системы направленного движения предполагает сравнение двух индикаторов направленности 14-периодного +DI и 14-периодного -DI. Для этого либо графики индикаторов наносятся один на другой, либо +DI вычитается из -DI. У. Уайлдер предлагает покупать, если +DI поднимается выше -DI, и продавать, когда +DI опускается ниже -DI.

Эти простые торговые правила У.Уайлдер дополняет также «правилом экстремальных точек». Оно служит для устранения ложных сигналов и уменьшения числа заключаемых сделок. Согласно принципу экстремальных точек, в момент пересечения +DI и -DI необходимо отметить «экстремальную точку». Если +DI поднимается выше -DI, этой точкой является максимальная цена дня пересечения. Если +DI опускается ниже -DI, эта точка - минимальная цена дня пересечения.

Экстремальная точка затем используется как уровень вхождения в рынок. Так, после сигнала к покупке (+DI поднялся выше -DI) необходимо дождаться, когда цена поднимется выше экстремальной точки, и лишь после этого покупать. Если же цене не удается преодолеть уровень экстремальной точки, следует сохранять короткую позицию.

Расчет

ADX = SUM ((+DI - (-DI)) / (+DI + (-DI)), N) / N

где:
N — количество периодов, используемых для расчета;
SUM (..., N) — сумма за N периодов;
+DI — значение индикатора позитивного направления движения цен (positive directional index);
-DI — значение индикатора негативного направления движения цен (negative directional index).


Технические индикаторы — Average True Range

Average True Range

Технический индикатор Средний Истинный Диапазон (Average True Range, ATR) — это показатель волатильности рынка. Его ввел Уэллс Уайлдер в книге «Новые концепции технических торговых систем», и с тех пор индикатор применяется как составляющая многих других индикаторов и торговых систем.

Индикатор Average True Range часто достигает высоких значений в основаниях рынка после стремительного падения цен, вызванного паническими продажами. Низкие значения индикатора часто соответствуют продолжительным периодам горизонтального движения, которые наблюдаются на вершинах рынка и во время консолидации. Его можно интерпретировать по тем же правилам, что и другие индикаторы волатильности. Принцип прогнозирования с помощью Average True Range формулируется так: чем выше значение индикатора, тем выше вероятность смены тренда; чем ниже его значение, тем слабее направленность тренда.

Расчет

Истинный диапазон (True Range) есть наибольшая из следующих трех величин:

  • разность между текущими максимумом и минимумом;

  • разность между предыдущей ценой закрытия и текущим максимумом;

  • разность между предыдущей ценой закрытия и текущим минимумом.

Индикатор Среднего Истинного Диапазона (Average True Range, ATR) представляет собой скользящее среднее значений истинного диапазона.


Технические индикаторы — Awesome Oscillator

Awesome Oscillator

Технический индикатор Чудесный Осциллятор Билла Вилльямса (Awesome Oscillator, AO) — это 34-периодное простое скользящее среднее, построенное по средним точкам баров (H+L)/2, которое вычтено из 5-периодного простого скользящего среднего, также построенного по средним точкам (H+L)/2. Он точно говорит нам, что происходит в текущий момент времени с движущей силой рынка.

Сигналы на покупку

«Блюдце»

Это единственный сигнал на покупку, который возникает, когда гистограмма находится выше нулевой линии. Необходимо помнить следующее:

  • сигнал «Блюдце» образуется, когда гистограмма меняет направление с нисходящего на восходящее. Второй столбец ниже первого и окрашен в красный цвет. Третий столбец выше второго, и он зеленый;

  • для образования сигнала «Блюдце» необходимы, по крайней мере, три столбца гистограммы.

Помните, что при использовании сигнала на покупку «Блюдце» все столбцы Awesome Oscillator должны находиться выше нулевой линии.

«Пересечение нулевой линии»

Сигнал на покупку образуется, когда гистограмма переходит от отрицательных значений к положительным. При этом:

  • чтобы образовался этот сигнал, необходимы только два столбца;

  • первый столбец должен быть ниже нулевой линии, второй столбец должен пересекать нулевую линию (переход от отрицательного значения к положительному);

  • невозможно одновременное наличие сигнала на покупку и на продажу.

«Два пика»

Это единственный сигнал на покупку, который может образоваться, когда значения гистограммы лежат ниже нулевой линии. Здесь необходимо помнить следующее:

  • сигнал образуется, когда на графике ниже нулевой линии имеется направленный вниз пик (самый низкий минимум), за которым следует другой направленный вниз пик, находящийся выше (отрицательное число, меньшее по абсолютному значению, поэтому оно находится ближе к нулевой линии), чем предыдущий смотрящий вниз пик;

  • гистограмма должна находиться ниже нулевой линии между двумя пиками. Если гистограмма пересекает нулевую линию между пиками, сигнал на покупку не действует. Однако создается сигнал на покупку «Пересечение нулевой линии»;

  • каждый новый пик гистограммы должен быть выше (меньшее по модулю отрицательное число, которое находится ближе к нулевой линии), чем предыдущий пик;

  • если формируется дополнительный, более высокий пик (ближе к нулевой линии) и гистограмма не пересекла нулевую линию, то образуется дополнительный сигнал на покупку.

Сигналы на продажу

Сигналы на продажу Awesome Oscillator идентичны сигналам на покупку. Сигнал «Блюдце» перевернут и находится ниже нуля. «Пересечение нулевой линии» идет по убыванию: первый столбец выше нуля, второй - ниже. А сигнал "два пика" находится выше нулевой линии и также перевернут.

Расчет

Гистограмма Awesome Oscillator — это 34-периодное простое скользящее среднее, построенное по центральным значениям баров (H+L)/2, вычтенное из 5-периодного простого скользящего среднего по центральным точкам (Н+L)/2.

MEDIAN PRICE = (HIGH + LOW) / 2
AO = SMA (MEDIAN PRICE, 5) — SMA (MEDIAN PRICE, 34)

где:
MEDIAN PRICE — медианная цена;
HIGH — максимальная цена бара;
LOW — минимальная цена бара;
SMA — простая скользящая средняя.


Технические индикаторы — Bears Power

Bears Power

Каждый день торгов представляет собой борьбу покупателей ("быков"), стремящимся поднять цену вверх, и продавцов ("медведей"), толкающих цену вниз. В зависимости от того, какая из сторон одерживает верх, день завершается более высокой или более низкой ценой по сравнению с днем предыдущим, а промежуточные результаты, и в первую очередь максимальная и минимальная цены, позволяют судить о том, как разворачивалась борьба на протяжении дня.

Задача оценки баланса сил "медведей" имеет большое значение, так как изменение этого баланса является одним из первых сигналов, позволяющим предугадать вероятную смену тенденции. Эта задача решается осцилятором Bears Power, который был разработан Александром Элдером и описан в его книге "Как играть и выигрывать на бирже". При его выводе Элдер использовал следующие посылки:

  • скользящее среднее является соглашением о цене между продавцами и покупателями в течение определенного промежутка времени,

  • минимальная цена отражает максимальную силу продавцов в течение дня.

Базируясь на этих посылках, Элдер разработал Bear Power как разницу между минимальной ценой и 13-периодной экспоненциальной скользящей средней (LOW - ЕМА).

Применение

Данный индикатор лучше всего использовать в совокупности с одним из трендовых индикаторов (чаще всего это скользящая средняя):

  • если трендовый индикатор направлен вверх, а индекс силы медведей ниже нуля, но возрастает, это сигнал купли;

  • желательно, чтобы при этом на графике индикатора формировалось расхождение донышек.

Расчет

Первой ступенью расчета данного индикатора является расчет экспоненциальной скользящей средней (как правило, рекомендуют использовать 13-периодную).

BEARS = LOW - EMA

где:

BEARS — сила медведей;

LOW — минимальная цена текущего бара;

EMA — экспоненциальное скользящее среднее..

При убывающем тренде LOW ниже EMA, поэтому сила медведей меньше нуля, а гистограмма располагается ниже нулевой линии. Если при подъеме цен LOW поднимается над EMA, сила медведей становится больше нуля, а ее гистограмма поднимается выше нулевой линии.


Технические индикаторы — Bollinger Bands

Bollinger Bands

Полосы Боллинджера (Bollinger Bands, BB) схожи с Envelopes. Различие между ними состоит в том, что границы Торговых Полос (Envelopes) расположены выше и ниже кривой скользящего среднего на фиксированном, выраженном в процентах расстоянии, тогда как границы Bollinger Bands строятся на расстояниях, равных определенному числу стандартных отклонений. Поскольку величина стандартного отклонения зависит от волатильности, полосы сами регулируют свою ширину: она увеличивается, когда рынок неустойчив, и уменьшается в более стабильные периоды.

Bollinger Bands обычно наносятся на ценовой график, но могут наноситься и на график индикатора. Как и в случае с Envelopes, интерпретация Bollinger Bands основана на том, что ценам свойственно оставаться в пределах верхней и нижней границ полосы. Отличительной особенностью Полос Боллинджера является их переменная ширина, обусловленная волатильностью цен. В периоды значительных ценовых изменений (т.е., высокой волатильности) полосы расширяются, давая простор ценам. В периоды застоя (т.е., низкой волатильности) полосы сужаются, удерживая цены в пределах своих границ.

К особенностям этого индикатора можно отнести:

  1. резкие изменения цен, обычно происходящие после сужения полосы, соответствующего снижению волатильности.

  2. если цены выходят за пределы полосы, следует ожидать продолжения текущей тенденции;

  3. если за пиками и впадинами за пределами полосы следуют пики и впадины внутри полосы, возможен разворот тенденции;

  4. движение цен, начавшееся от одной из границ полосы, обычно достигает противоположной границы.

Последнее наблюдение полезно при прогнозировании ценовых ориентиров.

Расчет

Полосы Боллинджера формируются из трех линий. Средняя линия (MIDDLE LINE, ML) — это обычное скользящее среднее.
ML = SUM (CLOSE, N) / N = SMA (CLOSE, N)

Верхняя линия (TOP LINE, TL) — это та же средняя линия, смещенная вверх на определенное число стандартных отклонений (D).
TL = ML + (D * StdDev)

Нижняя линия (BOTTOM LINE, BL) — это средняя линия, смещенная вниз на то же число стандартных отклонений.
BL = ML — (D * StdDev)

Где:
SUM (..., N) — сумма за N периодов;
CLOSE — цена закрытия;
N — количество периодов, используемых для расчета;
SMA —
простая скользящая средняя;
SQRT — квадратный корень;
StdDev — стандартное отклонение:

StdDev = SQRT (SUM ((CLOSE - SMA (CLOSE, N))^2, N)/N)

Рекомендуется использовать 20-периодное простое скользящее среднее в качестве средней линии и 2 стандартных отклонения — для расчета границ полосы. Кроме того, скользящие средние длиной менее 10 периодов малоэффективны.


Технические индикаторы — Bulls Power

Bulls Power

Каждый день торгов представляет собой борьбу покупателей ("быков"), стремящимся поднять цену вверх, и продавцов ("медведей"), толкающих цену вниз. В зависимости от того, какая из сторон одерживает верх, день завершается более высокой или более низкой ценой по сравнению с днем предыдущим, а промежуточные результаты, и в первую очередь максимальная и минимальная цены, позволяют судить о том, как разворачивалась борьба на протяжении дня.

Задача оценки баланса сил "быков" имеет большое значение, так как изменение этого баланса является одним из первых сигналов, позволяющим предугадать вероятную смену тенденции. Эта задача решается осцилятором Bulls Power, который был разработан Александром Элдером и описан в его книге "Как играть и выигрывать на бирже". При его выводе Элдер использовал следующие посылки:

  • скользящее среднее является соглашением о цене между продавцами и покупателями в течение определенного промежутка времени,

  • максимальная цена отражает максимальную силу покупателей в течение дня.

Базируясь на этих посылках, Элдер разработал Bulls Power как разницу между максимальной ценой и 13-периодной экспоненциальной скользящей средней (HIGH - ЕМА).

Применение

Данный индикатор лучше всего использовать в совокупности с одним из трендовых индикаторов (чаще всего это скользящая средняя):

  • если трендовый индикатор направлен вниз, а индекс силы быков выше нуля, но убывает, это сигнал продажи;

  • желательно, чтобы при этом на графике индикатора формировалось расхождение вершин.

Расчет

Первой ступенью расчета данного индикатора является расчет экспоненциальной скользящей средней (как правило, рекомендуют использовать 13-периодную).

BULLS = HIGH - EMA

где:

BULLS — сила быков;

HIGH — максимальная цена текущего бара;

EMA — экспоненциальное скользящее среднее..

При возрастающем тренде HIGH выше EMA, поэтому сила быков больше нуля, а гистограмма располагается выше нулевой линии. Если при снижении цен HIGH опускается под EMA, сила быков становится меньше нуля, а ее гистограмма опускается ниже нулевой линии.


Технические индикаторы — Commodity Channel Index

Commodity Channel Index

Технический индикатор Индекс Товарного Канала (Commodity Channel Index, CCI) измеряет отклонение цены инструмента от его среднестатистической цены. Высокие значения индекса указывают на то, что цена необычно высока по сравнению со средней, а низкие - что она слишком занижена. Несмотря на название, Commodity Channel Index применим к любому финансовому инструменту, а не только к товарам.

Существует два основных способа использования Commodity Channel Index:

  1. Для поиска расхождений
    Расхождение образуется, когда цена достигает нового максимума, а Commodity Channel Index не удается подняться выше предыдущих максимумов. За этим классическим расхождением обычно следует ценовая коррекция.

  2. В качестве индикатора перекупленности/перепроданности
    Индекс Товарного Канала обычно колеблется в диапазоне ±100. Значения выше +100 говорят о состоянии перекупленности (и вероятности корректирующего спада), а значения ниже -100 - о состоянии перепроданности (и вероятности корректирующего подъема).

Расчет

  1. Найти типичную цену. Для этого необходимо сложить максимум, минимум и цену закрытия каждого бара и разделить сумму на 3.
    TP = (HIGH + LOW + CLOSE) / 3

  2. Вычислить n-периодное простое скользящее среднее типичных цен.
    SMA (TP, N) = SUM (TP, N) / N

  3. Вычесть полученное SMA(TP, N) из типичных цен TP каждого из предшествующих n периодов.
    D = TP - SMA (TP, N)

  4. Вычислить n-периодное простое скользящее среднее абсолютных значений D
    SMA (D, N) = SUM (D, N) / N

  5. Умножить полученное SMA (D, N) на 0,015
    M = SMA (D, N) * 0,015

  6. Разделить M на D
    CCI = M / D

где:
HIGH — максимальная цена бара;
LOW — минимальная цена бара;
CLOSE — цена закрытия;
SMA — простое скользящее среднее;
SUM — сумма;
N — количество периодов, используемых для расчета.


Технические индикаторы — DeMarker

DeMarker

Технический индикатор Демарка (DeMarker, DeM) строится на основе сопоставлений максимума текущего бара с максимумом предыдущего. Если максимум текущего бара выше, то регистрируется соответствующая разность. Если текущий максимум меньше или равен максимуму предыдущего бара, то регистрируется нулевое значение. Затем полученные таким образом разности за n периодов суммируются. Полученное значение становится числителем индикатора DeMarker и делится на ту же самую величину плюс сумма разностей между ценовыми минимумами предшествующего и текущего баров. Если текущий ценовой минимум больше того, который был на предыдущем баре, то фиксируется нулевое значение.

Когда показания индикатора DeMarker опускаются ниже отметки 30, то ожидается разворот цен вверх. Когда показания индикатора поднимаются выше отметки 70, то ожидается разворот цен вниз.

Использование более длительных периодов расчета позволяет "зацепиться" за долгосрочную тенденцию в развитии рынка. Индикаторы с короткими периодами позволяют выходить на рынок в точке с наименьшим риском и планировать момент заключения сделки так, чтобы она была в русле основной тенденции.

Расчет

Значение индикатора DeMarker в интервале i вычисляется следующим образом:

  • Вычисляется DeMax (i)
    Если HIGH (i) > HIGH (i - 1) , то DeMax (i) = HIGH (i) - HIGH (i - 1),
    иначе DeMax (i) = 0

  • Вычисляется DeMin (i)
    Если LOW (i) < LOW (i - 1), то DeMin (i) = LOW (i - 1) - LOW (i),
    иначе DeMin (i) = 0

  • Рассчитывается значение Индикатора Демарка:
    DMark (i) = SMA (DeMax, N) / (SMA (DeMax, N) + SMA (DeMin, N))

где:
HIGH (i) — максимальная цена текущего бара;
LOW (i) — минимальная цена текущего бара;
HIGH (i - 1) — максимальная цена предыдущего бара;
LOW (i - 1) — минимальная цена предыдущего бара;
SMA — простое скользящее среднее;
N — количество периодов, используемых для расчета.


Технические индикаторы — Elder-Rays

Elder-Rays

Технический индикатор Лучи Элдера (Elder-Rays) - это объединение свойств отслеживающих тренд индикаторов и осцилляторов. Они используют в качестве отслеживающего индикатора экспоненциальную скользящую среднюю (ЕМА, наилучший период 13). Осцилляторы отражают мощность быков и медведей. Чтобы построить Лучи Элдера, используют три диаграммы: на одной строят график цен и ЕМА, на двух других - Осциллятор Силы Быков (Bulls Power) и Осциллятор Силы Медведей (Bears Power).

Elder-Rays используются как самостоятельно, так и совместно с другими методами. Если использовать их самостоятельно, то следует учитывать, что наклон ЕМА определяет направление тренда, и открывать позиции в его направлении. Осцилляторы силы быков и медведей применяются для определения момента открытия/закрытия позиций.

Рекомендовано покупать, если:

  • присутствует растущий тренд (определяется направлением ЕМА);

  • Осциллятор Силы Медведей отрицательный, но при этом возрастает;

  • последний пик Осциллятора Силы Быков расположен выше предыдущего;

  • Осциллятор Силы Медведей растет после бычьей дивергенции.

При положительных значениях осциллятора силы медведей от покупки надо воздержаться.

Рекомендовано продавать, если:

  • присутствует нисходящий тренд (определяется направлением ЕМА);

  • Осциллятор Силы Быков положителен, но постепенно убывает;

  • последняя впадина Осциллятора Силы Быков расположена ниже предыдущей;

  • Осциллятор Силы Быков убывает, выходя из медвежьей дивергенции.

Рекомендуется не открывать коротких позиций, если осциллятор Bulls Power отрицательный.

Дивергенция между осцилляторами Bulls Power и Bears Power и ценами - лучшее время для проведения операций.

Расчет

BULLS = HIGH - EMA
BEARS = LOW - EMA

где:
BULLS — сила быков;
BEARS — сила медведей;
HIGH — максимальная цена текущего бара;
LOW — минимальная цена текущего бара;
EMA — экспоненциальное скользящее среднее.


Технические индикаторы — Envelopes

Envelopes

Технический индикатор Огибающие Линии (Конверты, Envelopes) образуется двумя скользящими средними, одна из которых смещена вверх, а другая — вниз. Выбор оптимальной относительной величины смещения границ полосы определяется волатильностью рынка: чем она выше, тем больше смещение.

Envelopes определяют верхние и нижние границы нормального диапазона колебаний цен бумаги. Сигнал к продаже возникает тогда, когда цена достигает верхней границы полосы, а сигнал к покупке — при достижении ею нижней границы.

Применение технического индикатора Envelopes основано на естественной логике поведения рынка: когда под давлением особо рьяных покупателей или продавцов цены достигают экстремальных значений (т.е., верхней или нижней границы полосы), они часто стабилизируются, возвращаясь к более реалистичным уровням. Такой же принцип используется при интерпретации Полос Боллинджера (Bollinger Bands, BB).

Расчет:

UPPER BAND = SMA (CLOSE, N) * [1 + K / 1000]
LOWER BAND = SMA (CLOSE, N) * [1 - K / 1000]

где:
UPPER BAND — верхняя линия индикатора;
LOWER BAND — нижняя линия индикатора;
SMA — простое скользящее среднее;
CLOSE — цена закрытия;
N — период усреднения;
K / 1000 — величина отклонения от среднего (в десятых долях процента).


Технические индикаторы — Force Index

Force Index

Технический индикатор Индекс Силы (Force Index, FRC) был разработан Александром Элдером и измеряет силу быков при каждом подъеме и силу медведей при каждом спаде. Он связывает основные элементы рыночной информации: направление цены, ее перепады и объем сделок. Данный индекс можно использовать в чистом виде, однако лучше его сгладить с помощью скользящей средней. Сглаживание с помощью короткой скользящей средней (автор предлагает использовать 2 периода) помогает найти благоприятные моменты для открытия и закрытия позиций. Если же сглаживание производится с помощью длинной скользящей средней (например, 13-периодной), то индекс выявляет перемены тенденций.

  • Покупать желательно тогда, когда во время тенденции к повышению Force Index станет отрицательным (упадет ниже нулевой линии).

  • Поднимаясь до новой высоты, индикатор сигнализирует о продолжении тенденции к повышению.

  • Сигнал к продаже поступает, когда во время тенденции к понижению Force Index становится положительным.

  • Падая на новую глубину, Индикатор Силы сигнализирует о силе медведей и продолжении тенденции к понижению.

  • Если изменения цен не подкреплены аналогичным изменением объема, то Force Index остается на одном уровне, что предупреждает о близком развороте тенденции.

Расчет

Сила каждого движения рынка определяется его направлением, размахом и объемом. Если цена закрытия текущего бара выше, чем предыдущего, то сила положительна. Если текущая цена закрытия ниже, чем предыдущая, то сила отрицательна. Чем больше различие в ценах, тем больше сила. Чем больше объем сделок, тем больше сила.

FORCE INDEX (i) = VOLUME (i) * ((MA (ApPRICE, N, i) - MA (ApPRICE, N, i-1))

где:
FORCE INDEX (i) — Индекс Силы текущего бара;
VOLUME (i) — объем текущего бара;
MA (ApPRICE, N, i) — любая скользящая средняя текущего бара за N периодов:
простая, экспоненциальная, взвешенная или усредненная (сглаженная);
ApPRICE — примененная цена.
N — период сглаживания.
MA (ApPRICE, N, i-1) — любая скользящая средняя предыдущего бара.


Технические индикаторы — Fractals

Fractals

Все рынки характеризуются тем, что в течение большей части времени цены на них сильно не меняются, и лишь на протяжении небольшого периода (15–30 процентов) наблюдаются трендовые изменения. Наиболее благоприятны для извлечения прибыли периоды, когда цены на рынках изменяются в соответствии с определенным трендом.

Фракталы (Fractals) — это один из пяти индикаторов торговой системы Билла Вильямса, позволяющий обнаруживать впадину или вершину графика цены. Фрактал вверх технически описывается как серия из, как минимум, пяти последовательных баров, в которой непосредственно перед самым высоким максимумом и сразу же после него находятся по два бара с более низкими максимумами. Противоположная конфигурация (серия из пяти баров, в которой непосредственно перед самым низким минимумом и сразу же после него находятся по два бара с более высокими минимумами) соответствует фракталу вниз. На графике фракталы имеют значения High и Low и отмечены стрелками вверх или вниз соответственно.

Сигналы технического индикатора Fractals необходимо отфильтровывать с помощью технического индикатора Аллигатор. Другими словами, не следует заключать сделку на покупку, если фрактал находится ниже Зубов Аллигатора, и не следует заключать сделку на продажу, если фрактал находится выше Зубов Аллигатора. После того как сигнал фрактала сформирован и имеет силу, что определяется его позицией вне Пасти Аллигатора, он остается сигналом до тех пор, пока не будет поражен или пока не возникнет более свежий сигнал фрактала.


Технические индикаторы — Gator Oscillator

Gator Oscillator

Gator Oscillator строится на основе индикатора Alligator и показывает степень схождения/расхождения его линий баланса (сглаженное скользящее среднее). Верхняя гистограмма — абсолютная разница между значениями синей линии и красной линии. Нижняя гистограмма — абсолютная разница между значениями красной линии и зелёной линии, но со знаком минус, потому что гистограмма рисуется сверху вниз.


Технические индикаторы — Ichimoku Kinko Hyo

Ichimoku Kinko Hyo

Технический индикатор Ишимоку Кинко Хайо (Ichimoku Kinko Hyo) предназначен для определения рыночного тренда, уровней поддержки и сопротивления, а также для генерации сигналов покупки и продажи. Лучше всего индикатор работает на недельных и дневных графиках.

При определении размерности параметров используются четыре временных интервала различной протяженности. На этих интервалах основываются значения отдельных линий, составляющих этот индикатор:

  • Tenkan-sen показывает среднее значение цены за первый промежуток времени, определяемый как сумма максимума и минимума за это время, поделенная на два;

  • Kijun-sen показывает среднее значение цены за второй промежуток времени;

  • Senkou Span A показывает середину расстояния между предыдущими двумя линиями, сдвинутую вперед на величину второго временного интервала;

  • Senkou Span B показывает среднее значение цены за третий временной интервал, сдвинутое вперед на величину второго временного интервала.

Chinkou Span показывает цену закрытия текущей свечи, сдвинутую назад на величину второго временного интервала. Расстояние между линиями Senkou штрихуется на графике другим цветом и называется «облаком». Если цена находится между этими линиями, рынок считается нетрендовым, а края облака образуют уровни поддержки и сопротивления.

  • Если цена находится над облаком, то верхняя его линия образует первый уровень поддержки, а следующая — второй уровень поддержки.

  • Если цена находится под облаком, то нижняя линия образует первый уровень сопротивления, а верхняя — второй.

  • Если линия Chinkou Span пересекает график цены снизу вверх, это является сигналом к покупке. Если сверху вниз — сигналом к продаже.

Kijun-sen используется как показатель движения рынка. Если цена выше нее, вероятно, цены будут продолжать расти. Когда цена пересекает эту линию, вероятно дальнейшее изменения тренда. Другим вариантом использования Киджун-сен является подача сигналов. Сигнал к покупке генерируется, когда линия Tenkan-sen пересекает Kijun-sen снизу вверх. Пересечение сверху вниз — сигнал к продаже. Tenkan-sen используется как индикатор рыночного тренда. Если эта линия растет или падает, тренд существует. Когда она идет горизонтально, рынок вошел в канал.


Технические индикаторы — Market Facilitation Index

Market Facilitation Index

Технический индикатор Индекс Облегчения Рынка (Market Facilitation Index, BW MFI) показывает изменение цены, приходящееся на один тик. Абсолютные величины индикатора сами по себе ничего не значат, смысл имеют лишь изменения индикатора. Билл Вильямс придает большое значение изменениям индикатора и объема.

  • Если индикатор Market Facilitation Index вырос и одновременно вырос объем, это свидетельствует о том, что: а) все большее количество игроков входит в рынок (растет объем), б) вновь прибывающие игроки открывают позиции в направлении развития бара, т.е., движение началось и набирает скорость.

  • Если индикатор Market Facilitation Index упал и одновременно упал объем, это говорит о снижении интереса у участников рынка.

  • Если индикатор Market Facilitation Index вырос, но объем упал, значит, рынок не поддерживается объемом со стороны трейдеров, а цена изменяется благодаря спекуляциям трейдеров «на полу» (посредников — брокеров и дилеров).

  • Если индикатор Market Facilitation Index упал, но объем вырос, значит, происходит сражение быков и медведей, с большим объемом покупок и продаж, но с незначительным движением самой цены вследствие примерно равных сил. Одна из двух противоборствующих сторон (покупатели против продавцов) победит. Обычно прорыв такого бара дает знать, определяет ли этот бар продолжение тренда или тренд им аннулирован. Билл Вильямс называет такой бар «приседающим».

Расчет

Для расчета BW MFI необходимо из максимальной цены бара вычесть минимальную, а полученный результат разделить на объем.

BW MFI = (HIGH - LOW) / VOLUME

где:
HIGH — максимальная цена текущего бара;
LOW — минимальная цена текущего бара;
VOLUME — объем текущего бара.


Технические индикаторы — Momentum

Momentum

Технический индикатор Темпа (Momentum) измеряет величину изменения цены финансового инструмента за определенный период. Имеется несколько основных способов использования Индикатора Темпа.

  • Его можно использовать в качестве осциллятора, следующего за тенденцией, аналогично Техническому Индикатору Схождение/Расхождение Скользящих Средних (Moving Average Convergence/Divergence, MACD). В этом случае сигнал к покупке возникает, если индикатор Momentum образует впадину и начинает расти, а сигнал к продаже - когда он достигает пика и поворачивает вниз. Для более точного определения моментов разворота индикатора можно использовать его короткое скользящее среднее.
    Крайне высокие или низкие значения индикатора Momentum предполагают продолжение текущей тенденции. Так, если индикатор достигает крайне высоких значений и затем поворачивает вниз, следует ожидать дальнейшего роста цен. Но в любом случае с открытием (или закрытием) позиции не нужно спешить до тех пор, пока цены не подтвердят сигнал индикатора.

  • Использование в качестве опережающего индикатора. Этот способ основан на предположении о том, что заключительная фаза восходящей тенденции обычно сопровождается стремительным ростом цен (так как все верят в его продолжение), а окончание медвежьего рынка - их резким падением (так как все стремятся выйти из рынка). Именно так нередко и происходит, но все же это слишком широкое обобщение.

    Приближение рынка к вершине сопровождается резким скачком индикатора Momentum. Затем он начинает падать, тогда как цены продолжают расти или движутся горизонтально. По аналогии, в основании рынка Momentum резко падает, а затем поворачивает вверх задолго до начала роста цен. В обоих случаях образуются расхождения между индикатором и ценами.

Расчет

Momentum определяется как отношение сегодняшней цены к цене n периодов назад:

MOMENTUM = CLOSE (i) / CLOSE (i - n) * 100

где:
CLOSE (i) — цена закрытия текущего бара;
CLOSE (i - n) — цена закрытия n баров назад.


Технические индикаторы — Money Flow Index

Money Flow Index

Технический индикатор Индекс Денежных Потоков (Money Flow Index, MFI) показывает интенсивность, с которой деньги вкладываются в ценную бумагу или выводятся из нее. Построение и интерпретация индикатора аналогичны Relative Strength Index, с той только разницей, что в MFI учитывается и объем.

При анализе Money Flow Index следует учитывать:

  • расхождения между индикатором и движением цен - если цены растут, а значение Money Flow Index падает (или наоборот), то велика вероятность разворота цен;

  • значения Money Flow Index выше 80 и ниже 20, что сигнализирует соответственно о потенциальных вершине и впадине рынка.

Расчет

Расчет значения технического индикатора Money Flow Index состоит из нескольких этапов. Сначала определяют типичную цену (Typical Price, TP) данного периода:

TP = (HIGH + LOW + CLOSE) / 3

Затем рассчитывается величина денежного потока (Money Flow, MF):

MF = TP * VOLUME

Если сегодняшняя типичная цена больше вчерашней, то денежный поток считается положительным. Если сегодняшняя типичная цена меньше вчерашней — денежный поток считается отрицательным.

Положительный денежный поток (POSITIVE MONEY FLOW) — это сумма значений положительных денежных потоков за выбранный период. Отрицательный денежный поток (NEGATIVE MONEY FLOW) — сумма значений отрицательных денежных потоков за выбранный период.

Затем определяется денежное отношение (Money Ratio, MR) путем деления положительного денежного потока на отрицательный:

MR = POSITIVE MONEY FLOW / NEGATIVE MONEY FLOW

И, наконец, с помощью денежного отношения рассчитывается индекс денежных потоков:

MFI = 100 - (100 / (1 + MR))

где:
HIGH — максимальная цена текущего бара;
LOW — минимальная цена текущего бара;
CLOSE — цена закрытия текущего бара;
VOLUME — объем текущего бара.


Технические индикаторы — Moving Average

Moving Average

Технический индикатор Скользящее Среднее (Moving Average, MA) показывает среднее значение цены инструмента за некоторый период времени. При расчете Moving Average производится математическое усреднение цены инструмента за данный период. По мере изменения цены ее среднее значение либо растет, либо падает.

Существует несколько типов скользящих средних: простое (его также называют арифметическим), экспоненциальное, сглаженное и взвешенное. Moving Average можно рассчитывать для любого последовательного набора данных, включая цены открытия и закрытия, максимальную и минимальную цены, объем торгов или значения других индикаторов. Нередко используются и скользящие средние самих скользящих средних.

Единственное, чем Moving Average разных типов существенно отличаются друг от друга, — это разные весовые коэффициенты, которые присваиваются последним данным. В случае Простого Скользящего Среднего (Simple Moving Average) все цены рассматриваемого периода имеют равный вес. Экспоненциальная и взвешенная скользящие средние (Exponential Moving Average и Linear Weighted Moving Average) делают более весомыми последние цены.

Самый распространенный метод интерпретации скользящего среднего цены состоит в сопоставлении его динамики с динамикой самой цены. Когда цена инструмента поднимается выше значения Moving Average, возникает сигнал к покупке, при ее падении ниже линии индикатора — сигнал к продаже.

Данная система торговли с помощью Moving Average вовсе не предназначена обеспечивать вхождение в рынок строго в его низшей точке, а выход — строго на вершине. Она позволяет действовать в соответствии с текущей тенденцией: покупать вскоре после того, как цены достигли основания, и продавать вскоре после образования вершины.

Скользящие Средние могут применяться также и к индикаторам. При этом интерпретация скользящих средних индикаторов аналогична интерпретации ценовых скользящих средних: если индикатор поднимается выше своего Moving Average, значит, восходящее движение индикатора продолжится, а если индикатор опускается ниже Moving Average, это означает продолжение его нисходящего движения.

Варианты скользящих средних:

  • Simple Moving Average (SMA) — простое скользящее среднее

  • Exponential Moving Average (EMA) — экспоненциальное скользящее среднее

  • Smoothed Moving Average (SMMA) — сглаженное скользящее среднее

  • Linear Weighted Moving Average (LWMA) — линейно-взвешенное скользящее среднее

Расчет

Простое скользящее среднее (Simple Moving Average, SMA)

Простое, или арифметическое, скользящее среднее рассчитывается путем суммирования цен закрытия инструмента за определенное число единичных периодов (например, за 12 часов) с последующим делением суммы на число периодов.

SMA = SUM (CLOSE (i), N) / N

где:
SUM — сумма;
CLOSE (i) — цена закрытия текущего периода;
N — число периодов расчета.

Экспоненциальное скользящее среднее (Exponential Moving Average, EMA)

Экспоненциально сглаженное скользящее среднее определяется путем добавления к предыдущему значению скользящего среднего определенной доли текущей цены закрытия. При использовании экспоненциальных скользящих средних больший вес имеют последние цены закрытия. Р-процентное экспоненциальное скользящее среднее будет иметь вид:

EMA = (CLOSE (i) * P) + (EMA (i - 1) * (100 - P))

где:
CLOSE (i) — цена закрытия текущего периода;
EMA (i - 1) — значение скользящего среднего предыдущего периода;
P — доля использования значения цен.

Сглаженное скользящее среднее (Smoothed Moving Average, SMMA)

Первое значение сглаженного скользящего среднего рассчитывается, как простое скользящее среднее (SMA):

SUM1 = SUM (CLOSE (i), N)
SMMA1 = SUM1 / N

Второе значение рассчитывается по следующей формуле:

SMMA (i) = (SUM1 - SMMA (i - 1) + CLOSE (i)) / N

Последующие скользящие средние рассчитываются по следующей формуле:

PREVSUM = SMMA (i-1) * N
SMMA (i) = (PREVSUM - SMMA (i - 1) + CLOSE (i)) / N

где:
SUM — сумма;
SUM1 — сумма цен закрытия N периодов, отсчитываемая от предыдущего бара;
PREVSUM — сглаженная сумма предыдущего бара;
SMMA (i - 1) — сглаженное скользящее среднее предыдущего бара;
SMMA (i) — сглаженное скользящее среднее текущего бара (кроме первого);
CLOSE (i) — текущая цена закрытия;
N — период сглаживания.

В результате арифметических преобразований формула может быть упрощена:

SMMA (i) = (SMMA (i - 1) * (N - 1) + CLOSE (i)) / N

Линейно-взвешенное скользящее среднее (Linear Weighted Moving Average, LWMA)

Во взвешенном скользящем среднем последним данным присваивается больший вес, а более ранним — меньший. Взвешенное скользящее среднее рассчитывается путем умножения каждой из цен закрытия в рассматриваемом ряду на определенный весовой коэффициент.

LWMA = SUM (CLOSE (i) * i, N) / SUM (i, N)

где:
SUM — сумма;
CLOSE(i) — текущая цена закрытия;
SUM (i, N) — сумма весовых коэффициентов;
N — период сглаживания.


Технические индикаторы — Moving Average Convergence/Divergence

Moving Average Convergence/Divergence

Технический индикатор Схождение/Расхождение Скользящих Средних (Moving Average Convergence/Divergence, MACD) — это следующий за тенденцией динамический индикатор. Он показывает соотношение между двумя скользящими средними цены.

Технический индикатор MACD строится как разность между двумя экспоненциальными скользящими средними (EMA) с периодами 12 и 26. Чтобы четко обозначить благоприятные моменты для покупки или продажи, на график MACD наносится так называемая сигнальная линия — 9-периодное скользящее среднее индикатора.

MACD наиболее эффективно в условиях, когда рынок колеблется с большой амплитудой в торговом коридоре. Чаще всего используются следующие сигналы MACD: пересечения, состояния перекупленности/перепроданности и расхождения.

Пересечения

Основное правило торговли с помощью MACD построено на пересечениях индикатора со своей сигнальной линией: когда Moving Average Convergence/Divergence опускается ниже сигнальной линии, следует продавать, а когда поднимается выше сигнальной линии — покупать. В качестве сигналов к покупке/продаже также используются пересечения MACD нулевой линии вверх/вниз.

Состояния перекупленности/перепроданности

Moving Average Convergence/Divergence также весьма ценен как индикатор перекупленности/перепроданности. Когда короткое скользящее среднее поднимается существенно выше длинного (т.е., когда MACD растет), это означает, что цена рассматриваемого инструмента, скорее всего, сильно завышена и скоро вернется к более реалистичному уровню.

Расхождения

Когда между MACD и ценой образуется расхождение, это означает возможность скорого окончания текущей тенденции. Бычье расхождение возникает тогда, когда MACD достигает новых максимумов, а цене не удается их достичь. Медвежье расхождение образуется, когда индикатор достигает новых минимумов, а цена — нет. Оба вида расхождений наиболее значимы, если они формируются в областях перекупленности/перепроданности.

Расчет

Технический индикатор Moving Average Convergence/Divergence определяется путем вычитания 26-периодного экспоненциального скользящего среднего из 12-периодного. Затем на график MACD пунктиром наносится его 9-периодное простое скользящее среднее, которое выполняет роль сигнальной линии.

MACD = EMA(CLOSE, 12)-EMA(CLOSE, 26)
SIGNAL = SMA(MACD, 9)

где:
EMA - экспоненциальное скользящее среднее
SMA - простое скользящее среднее
SIGNAL - сигнальная линия индикатора


Технические индикаторы — Moving Average of Oscillator

Moving Average of Oscillator

Технический индикатор Скользящая Средняя Осциллятора (Moving Average of Oscillator, OsMA) в общем случае представляет собой разность между осциллятором и сглаживанием осциллятора. В данном случае в качестве осциллятора используется основная линия MACD, а в качестве сглаживания - сигнальная.

OSMA = MACD-SIGNAL

где:
MACD — значение индикатора MACD (гистограмма);
SIGNAL — сигнальная линия MACD.


Технические индикаторы — On Balance Volume

On Balance Volume

Технический индикатор Балансового Объема (On Balance Volume, OBV) связывает объем и изменение цены, сопровождавшее данный объем. Смысл этого индикатора, придуманного Джозефом Гранвиллем, прост. Если цена закрытия текущего бара выше цены закрытия предыдущего, значение объема текущего бара прибавляется к предыдущему значению OBV, а если закрытие текущего бара ниже предыдущего, текущий объем вычитается из предыдущего значения Балансового Объема.

Интерпретация индикатора On Balance Volume основана на принципе, утверждающем, что изменения OBV опережают ценовые. Согласно этому принципу, повышение балансового объема свидетельствует о том, что в инструмент вкладывают средства профессионалы. Когда позднее начинает вкладывать широкая публика, и цена, и показания индикатора OBV начинают стремительно расти.

Если цена опережает в своем движении индикатор On Balance Volume, возникает так называемое «отсутствие подтверждения». Это может наблюдаться на вершине бычьего рынка (когда цена растет без соответствующего роста Балансового Объема или опережая его) или в основании медвежьего рынка (когда цена падает без соответствующего уменьшения Балансового Объема или опережая его).

О восходящей тенденции On Balance Volume можно говорить, если каждый новый пик выше предыдущего, и каждая новая впадина выше предыдущей. По аналогии, нисходящая тенденция OBV предполагает последовательное понижение пиков и впадин. Когда OBV движется в горизонтальном коридоре, не образуя последовательно повышающихся или понижающихся пиков и впадин, — это неопределенная тенденция.

Если тенденция установилась, она остается в силе до момента перелома. Перелом в тенденции индикатора On Balance Volume может произойти двумя способами. В первом случае тенденция изменяется с восходящей на нисходящую или с нисходящей на восходящую.

Во втором случае перелома тенденция OBV переходит в неопределенную и остается таковой на протяжении более трех периодов. Таким образом, если восходящая тенденция меняется на неопределенную и остается таковой в течение только двух периодов, а затем опять переходит в восходящую, следует считать, что тенденция OBV все это время была восходящей.

Когда тенденция индикатора On Balance Volume меняется на восходящую или нисходящую, происходит так называемый «прорыв». Поскольку прорывы индикатора обычно предшествуют ценовым прорывам, инвесторам следует занимать длинные позиции при прорывах OBV вверх и, соответственно, продавать в случае прорыва OBV вниз. Открытые позиции нужно сохранять до тех пор, пока направление тенденции не изменится.

Расчет

если текущая цена закрытия выше предыдущей, то: OBV (i) = OBV (i - 1) + VOLUME (i)

если текущая цена закрытия ниже предыдущей, то: OBV (i) = OBV (i - 1) - VOLUME (i)

если текущая цена закрытия равна предыдущей, то: OBV (i) = OBV (i - 1)

где:
OBV (i) — значение индикатора On Balance Volume в текущем периоде;
OBV (i - 1) — значение индикатора On Balance Volume в предыдущем периоде;
VOLUME (i) — объем текущего бара.


Технические индикаторы — Parabolic SAR

Parabolic SAR

Технический индикатор Параболическая Система SAR (Parabolic SAR) был разработан для анализа трендовых рынков. Индикатор строится на ценовом графике. По своему смыслу данный индикатор аналогичен скользящей средней, с той лишь разницей, что Parabolic SAR движется с большим ускорением и может менять положение относительно цены. На «бычьем тренде» (Up Trend) индикатор располагается ниже цен, на «медвежьем» (Down Trend) — выше.

Если цена пересекает линии Parabolic SAR, то происходит разворот индикатора, а следующие его значения располагаются по другую сторону от цены. При этом «перевороте» индикатора точкой отсчета будет служить максимальная или минимальная цена за предыдущий период. Переворот индикатора — это сигнал либо об окончании (переходе в коррекцию или флэт) тренда, либо о его развороте.

Parabolic SAR превосходно определяет точки выхода из рынка. Длинные позиции следует закрывать, когда цена опускается ниже линии технического индикатора, а короткие — когда цена поднимается выше линии Parabolic SAR. Часто данный индикатор используют в качестве линии скользящего стопа (trailing stop).

Если открыта длинная позиция (то есть цена выше линии Parabolic SAR), то линия индикатора будет перемещаться вверх независимо от того, в каком направлении движутся цены. Величина перемещения линии Parabolic SAR зависит от величины ценового движения.

Расчет

Для длинных позиций: SAR (i) = ACCELERATION * (HIGH (i - 1) - SAR (i - 1)) + SAR (i - 1)
Для коротких позиций: SAR (i) = ACCELERATION * (LOW (i - 1) - SAR (i - 1)) - SAR (i - 1)

где:
SAR (i - 1) — значение индикатора Parabolic SAR на предыдущем баре;
ACCELERATION — фактор ускорения;
HIGH (i - 1) — максимальная цена за предыдущий период;
LOW (i - 1) — минимальная цена за предыдущий период.

Значение индикатора увеличивается, если цена текущего бара больше предыдущей на бычьем рынке и наоборот. При этом будет удваиваться фактор ускорения (ACCELERATION), что вызовет сближение Parabolic SAR и цены. Иными словами, индикатор приближается к цене тем быстрее, чем быстрее растет или падает цена.


Технические индикаторы — Relative Strength Index

Relative Strength Index

Технический индикатор Индекс Относительной Силы (Relative Strength Index, RSI) — это следующий за ценой осциллятор, который колеблется в диапазоне от 0 до 100. Вводя Relative Strength Index, У. Уайлдер рекомендовал использовать его 14-периодный вариант. В дальнейшем распространение получили также 9- и 25-периодные индикаторы. Один из распространенных методов анализа индикатора Relative Strength Index состоит в поиске расхождений, при которых цена образует новый максимум, а RSI не удается преодолеть уровень своего предыдущего максимума. Подобное расхождение свидетельствует о вероятности разворота цен. Если затем индикатор поворачивает вниз и опускается ниже своей впадины, то он завершает так называемый «неудавшийся размах» (failure swing). Этот неудавшийся размах считается подтверждением скорого разворота цен.
При анализе графиков различают следующие сигналы Relative Strenght Index:

  • Вершины и основания
    Вершины индикатора Relative Strength Index обычно формируются выше 70, а основания — ниже 30, причем они обычно опережают образования вершин и оснований на ценовом графике.

  • Графические модели
    Relative Strength Index часто образует графические модели, такие как ’голова и плечи’ или треугольники, которые на ценовом графике могут и не обозначаться.

  • Неудавшийся размах (прорыв уровня поддержки или сопротивления)
    Имеет место, когда Relative Strength Index поднимается выше предыдущего максимума (пик) или опускается ниже предыдущего минимума (впадина).

  • Уровни поддержки и сопротивления
    На графике индикатора Relative Strength Index уровни поддержки и сопротивления проступают даже отчетливее, чем на ценовом графике.

  • Расхождения
    Как уже сказано выше, расхождения образуются, когда цена достигает нового максимума (минимума), который не подтверждается новым максимумом (минимумом) на графике RSI. При этом обычно происходит коррекция цен в направлении движения индикатора Relative Strength Index.

Расчет

Основная формула расчета технического индикатора Relative Strenght Index:

RSI = 100 - (100 / (1 + U / D))

где:
U — среднее значение положительных ценовых изменений;
D — среднее значение отрицательных ценовых изменений.


Технические индикаторы — Relative Vigor Index

Relative Vigor Index

Технический индикатор Индекс Относительной Бодрости (Relative Vigor Index, RVI) базируется на идее о том, что на бычьем рынке цена закрытия, как правило, выше цены открытия, а на медвежьем — наоборот. Таким образом, бодрость движения устанавливается положением, в котором цена находится в конце периода. Чтобы нормализовать индекс к ежедневному диапазону торговли, изменение цены делится на максимальный диапазон цен в течение дня. Для большей сглаженности расчётов используется простое скользящее среднее. Лучшим периодом считается 10. Для исключения возможных неоднозначностей строится сигнальная линия — 4-периодное симметрично взвешенное сглаженное среднее значений Relative Strength Index. Пересечение линий говорит о наличии сигнала на покупку или продажу.

Расчет

RVI = (CLOSE - OPEN) / (HIGH - LOW)

где:
OPEN — цена открытия;
HIGH — максимальная цена;
LOW — минимальная цена;
CLOSE — цена закрытия.


Технические индикаторы — Standard Deviation

Standard Deviation

Стандартное отклонение — величина измерения волатильности рынка. Этот индикатор характеризует размер колебаний цены относительно простого скользящего среднего. Так, если значение индикатора велико, рынок является волатильным, и цены баров достаточно разбросаны относительно скользящего среднего. Если значение индикатора невелико, рынок характеризуется низкой волатильностью, и цены баров достаточно близки к скользящему среднему.

Обычно этот индикатор используется как составная часть других индикаторов. Так, при расчете Bollinger Bands значение стандартного отклонения инструмента прибавляется к его скользящему среднему.

Расчет

StdDev = SQRT (SUM (CLOSE - SMA (CLOSE, N), N)^2)/N

где:
SQRT — квадратный корень;
SUM (..., N) — сумма за N периодов;
SMA (..., N) — простая скользящая средняя с периодом N;
N — период расчета.


Технические индикаторы — Stochastic Oscillator

Stochastic Oscillator

Технический индикатор Стохастический Осциллятор (Stochastic Oscillator) сопоставляет текущую цену закрытия с диапазоном цен за выбранный период времени. Индикатор представлен двумя линиями. Главная линия называется %K. Вторая линия %D - это скользящее среднее линии %K. Обычно %K изображается сплошной линией, а %D - пунктирной. Существует три наиболее распространенных способа интерпретации Стохастического Осциллятора:

  • покупайте, когда осциллятор (%K или %D) сначала опустится ниже определенного уровня (обычно 20), а затем поднимется выше него, и продавайте, когда осциллятор сначала поднимется выше определенного уровня (обычно 80), а потом опустится ниже него;

  • покупайте, если линия %K поднимается выше линии %D, и продавайте, если линия %K опускается ниже линии %D.

  • следите за расхождениями, например, когда цены образуют ряд новых максимумов, а Стохастическому Осциллятору не удается подняться выше своих предыдущих максимумов.

Расчет

Для расчета стохастического осциллятора используются четыре переменные:

  • периоды %K — число единичных периодов, используемых для расчета стохастического осциллятора;

  • периоды замедления %K — величина, определяющая степень внутренней сглаженности линии %K, причем значение 1 дает быстрый стохастический осциллятор, а значение 3 - медленный;

  • периоды %D — число единичных периодов, используемых для расчета скользящего среднего линии %K;

  • метод %D — метод сглаживания (экспоненциальный, простой, сглаженный или взвешенный), используемый при расчете %D.

Формула для расчета %K:

%K = (CLOSE - MIN (LOW (%K))) / (MAX (HIGH (%K)) - MIN (LOW (%K))) * 100

где:
CLOSE - сегодняшняя цена закрытия;
MIN (LOW (%K)) - наименьший минимум за число периодов %K;
MAX (HIGH (%K)) - наибольший максимум за число периодов %K.

Скользящее среднее %D рассчитывается по формуле:

%D = SMA (%K, N)

где:
N - период сглаживания;
SMA - простая скользящая средняя.


Технические индикаторы — Williams’ Percent Range

Williams’ Percent Range

Процентный Диапазон Вильямса (Williams’ Percent Range, %R) - это динамический индикатор, определяющий состояние перекупленности/перепроданности. Williams’ Percent Range очень похож на технический индикатор Stochastic Oscillator. Различие между ними состоит лишь в том, что первый имеет перевернутую шкалу, а второй строится с использованием внутреннего сглаживания.

Значения индикатора в диапазоне от -80% до -100% указывают на состояние перепроданности. Значения в диапазоне от 0% до -20% свидетельствуют о том, что рынок перекуплен. Для построения индикатора Williams' Percent Range в перевернутой шкале его значениям обычно присваивается знак отрицания (например, -30%). При анализе знак отрицания можно не учитывать.

По общему для всех индикаторов перекупленности/перепроданности правилу, действовать по их сигналам лучше всего, дождавшись поворота цен в соответствующем направлении. Так, если индикатор перекупленности/перепроданности указывает на состояние перекупленности, прежде чем продавать бумагу, разумно дождаться поворота цен вниз.

У индикатора Williams' Percent Range есть любопытная способность загадочным образом предвосхищать ценовые развороты. Он почти всегда образует пик и поворачивает вниз за определенный промежуток времени до того, как цена достигает пика и поворачивает вниз. Точно так же Williams Percent Range обычно образует впадину и заблаговременно поворачивает вверх.

Расчет

Формула расчета индикатора Williams’ Percent Range схожа с формулой для расчета Stochastic Oscillator:

%R = (MAX (HIGH (i - n)) - CLOSE (i)) / (MAX (HIGH (i - n)) - MIN (LOW (i - n))) * 100

где:
CLOSE (i) — сегодняшняя цена закрытия;
MAX (HIGH (i - n)) — наибольший максимум за n предыдущих периодов;
MIN (LOW (i - n)) — наименьший минимум за n предыдущих периодов.


Торговля

Торговля

Основой получения прибыли при работе на финансовых рынках является простое правило: покупать дешевле, а продавать дороже. Таким образом, вся работа на финансовых рынках сводится к последовательному совершению торговых операций по купле-продаже финансовых инструментов. Для этого потребуется открывать, изменять и закрывать торговые позиции. Торговой позицией назвается рыночное обязательство, количество купленных или проданных контрактов, по которым не было произведено зачетных сделок. Вся торговая деятельность в терминале происходит с использованием торговых позиций.

Чтобы открыть торговую позицию, необходимо совершить торговую операцию, а чтобы закрыть ее — совершить обратную операцию. Открытие торговой позиции осуществляется брокерской компанией по рыночному ордеру или по исполнении отложенного ордера. Открытую позицию можно модифицировать, изменив значения прикрепленных к позиции уровней ордеров Stop Loss и Take Profit. Закрытие позиции происходит по требованию трейдера или по исполнении ордеров Stop Loss и Take Profit. Кроме того, позиции могут открываться, изменяться и закрываться советником — этот механизм работы рассматривается в другом разделе.


Торговля — Типы ордеров

Типы ордеров

Клиентский терминал позволяет подготавливать и выдавать приказы брокеру на исполнение торговых операций. Кроме того, терминал позволяет контролировать и управлять состоянием открытых позиций. Для этих целей используются несколько видов торговых ордеров. Ордером называется распоряжение или приказание клиента брокерской компании провести какую-либо торговую операцию. В терминале используются следующие ордера: Рыночный ордер, Отложенный ордер, Стоп Лосс и Тейк Профит.

  • Рыночный ордер
    Рыночный ордер — это распоряжение брокерской компании купить или продать финансовый инструмент по текущей цене. Исполнение данного ордера приводит к открытию торговой позиции. Покупка происходит по цене Ask (цена спроса), а продажа — по Bid (цена предложения). К рыночному ордеру можно прикрепить ордера Стоп Лосс и Тейк Профит (эти ордера описаны ниже). Режим исполнения рыночных ордеров зависит от финансового инструмента.

  • Отложенный ордер
    Отложенный ордер — это распоряжение брокерской компании купить или продать финансовый инструмент в будущем по заданной цене. Данный ордер используется для открытия торговой позиции при условии равенства будущих котировок установленному уровню. Существует четыре типа отложенных ордеров:

    1. Buy Limit — купить при равенстве будущей цены "Ask" установленному значению. При этом текущий уровень цен больше значения установленного ордера. Обычно ордера этого типа выставляются в расчете на то, что цена инструмента, опустившись до определенного уровня, начнет расти;

    2. Buy Stop — купить при равенстве будущей цены "Ask" установленному значению. При этом текущий уровень цен меньше значения установленного ордера. Обычно ордера этого типа выставляются в расчете на то, что цена инструмента преодолеет некий уровень и продолжит свой рост;

    3. Sell Limit — продать при равенстве будущей цены "Bid" установленному значению. При этом текущий уровень цен меньше значения установленного ордера. Обычно ордера этого типа выставляются в расчете на то, что цена инструмента, поднявшись до определенного уровня, начнет снижаться;

    4. Sell Stop — продать при равенстве будущей цены "Bid" установленному значению. При этом текущий уровень цен больше значения установленного ордера. Обычно ордера этого типа выставляются в расчете на то, что цена инструмента достигнет определенного уровня и продолжит снижаться.

    Условия установки отложенных ордеров

    К отложенному ордеру можно прикрепить ордера Стоп Лосс и Тейк Профит. После срабатывания отложенного ордера его Стоп Лосс и Тейк Профит автоматически прикрепляются к открытой позиции.

  • Стоп Лосс
    Этот ордер предназначен для минимизации потерь в том случае, если цена финансового инструмента начала двигаться в убыточном направлении. Если цена инструмента достигнет этого уровня, позиция закроется автоматически. Такой ордер всегда связан с открытой позицией либо с отложенным ордером. Он выдается на установку брокерской компании только вместе с рыночным или отложенным ордерами. При проверке условия этого ордера для длинных позиций используется Bid-цена, а при проверке коротких позиций — Ask-цена.

    Для автоматизации перемещения ордера Стоп Лосс вслед за ценой можно использовать Трейлинг Стоп.

  • Тейк Профит
    Тейк Профит предназначен для получения прибыли при достижении ценой финансового инструмента прогнозируемого уровня. Исполнение данного ордера приводит к закрытию позиции. Он всегда связан с открытой позицией либо с отложенным ордером. Ордер можно выдать только вместе с рыночным ордером или отложенным ордером. При проверке условия этого ордера для длинных позиций используется Bid-цена, а при проверке коротких позиций — Ask-цена.

Внимание:
  • цена исполнения для всех торговых операций определяется брокером;
  • Стоп Лосс и Тейк Профит исполняются только для открытой позиции и не исполняется для отложенных ордеров;
  • исторические графики в терминале строятся только по Bid-ценам. При этом часть отображаемых на графиках ордеров строятся по Ask-ценам. Чтобы включить отображение Ask-цены последнего бара, необходимо выставить флажок "Показывать линию Ask" в настройках терминала.


Торговля — Трейлинг Стоп

Трейлинг Стоп

Стоп Лосс предназначен для минимизации потерь в том случае, если цена финансового инструмента начала двигаться в убыточном направлении. Когда же открытая позиция становится прибыльной, Стоп Лосс можно перемещать вручную на безубыточный уровень. Для автоматизации этого процесса используется Трейлинг Стоп (Trailing Stop). Данный инструмент особенно полезен при сильном однонаправленном движении цены, а также в тех случаях, когда нет возможности внимательно следить за изменением состояния рынков.

Трейлинг Стоп всегда связан с открытой позицией и выполняется в клиентском терминале, а не на сервере, как Стоп Лосс. Для установки трейлинг стопа необходимо в окне "Терминал" выполнить одноименную команду контекстного меню открытой позиции. Затем в открывшемся списке выбрать желаемую величину расстояния между уровнем ордера Стоп Лосс и текущей ценой. Для каждой открытой позиции можно установить только один трейлинг стоп.

После выполнения указанных действий с приходом новых котировок терминал проверяет, прибыльна ли открытая позиция. Как только прибыль в пунктах становится равной либо большей указанного уровня, автоматически выдается команда на установку ордера Стоп Лосс. Уровень ордера устанавливается на указанном расстоянии от текущей цены. Далее, если цена движется с увеличением прибыльности позиции, трейлинг стоп автоматически передвигает Стоп Лосс за ценой. Если прибыльность позиции уменьшается, модификации ордера не происходит. Таким образом, автоматически фиксируется прибыль торговой позиции. При каждой автоматической модификации ордера Стоп Лосс создается запись в системном журнале.

Отключить трейлинг стоп можно, выставив параметр "Нет" в меню управления. А при выполнении команды "Удалить все уровни" отключаются трейлинг стопы всех открытых позиций и отложенных ордеров.

Внимание: Трейлинг Стоп работает на клиентском терминале, а не на сервере (как Стоп Лосс или Тейк Профит). Следовательно, при выключенном терминале, в отличие от указанных ордеров, Трейлинг Стоп не будет работать. При выключенном терминале может сработать только Стоп Лосс, выставленный трейлинг стопом.


Торговля — Типы исполнения

Типы исполнения

В клиентском терминале реализованы три режима исполнения ордеров:

  • Немедленное исполнение
    В этом режиме исполнение рыночного ордера осуществляется по цене, предложенной брокеру. При отправке запроса на исполнение, терминал автоматически подставляет в ордер текущие цены. В случае, если брокер принимает цены, ордер будет исполнен. Если брокер не принимает запрошенную цену, то происходит так называемое "Перекотирование" (Requote) — брокер возвращает цены, по которым может быть исполнен данный ордер.

  • Исполнение по запросу
    В этом режиме исполнение рыночного ордера осуществляется по цене, предварительно полученной от брокера. Перед отправкой рыночного ордера у брокера запрашиваются цены его исполнения. После их получения выполнение ордера по данной цене можно либо подтвердить, либо отклонить.

  • Исполнение по рынку
    В этом режиме исполнения рыночного ордера решение о цене исполнения принимает брокер без дополнительного согласования с трейдером. Отправка рыночного ордера в таком режиме подразумевает досрочное согласие с ценой, по которой он будет выполнен.

Внимание: выбор режима исполнения для каждого финансового инструмента осуществляется брокерской компанией.


Торговля — Управление торговыми позициями

Торговые позиции

Основой получения прибыли при работе на финансовых рынках является простое правило: покупать дешевле, а продавать дороже. Таким образом, вся работа на финансовых рынках сводится к последовательному совершению торговых операций по купле-продаже финансовых инструментов. Для этого потребуется открывать, изменять и закрывать торговые позиции. Торговой позицией назвается рыночное обязательство, количество купленных или проданных контрактов, по которым не было произведено зачетных сделок. Вся торговая деятельность в терминале происходит с использованием торговых позиций. Торговый терминал предоставляет широкий спектр возможностей по управлению торговыми позициями. Трейдер выдает приказы (ордера), а открытие или закрытие торговой позиции производит брокерская компания. Управление торговыми позициями заключается в:

  • открытии позиции — покупке или продаже финансового инструмента в результате исполнения рыночного или отложенного ордера;

  • изменении позиции — изменении уровней ордеров Стоп Лосс и Тейк Профит, связанных с открытой позицией;

  • установке отложенных ордеров — выставлении отложенных ордеров Buy Limit, Buy Stop, Sell Limit и Sell Stop;

  • изменении и удалении отложенных ордеров — изменении и удалении несработавших отложенных ордеров;

  • закрытии позиции — покупке или продаже финансового инструмента для имеющейся позиции с целью ее закрытия.


Управление торговыми позициями — Открытие позиций

Открытие позиций

Открытие позиции или вход в рынок — это первичная покупка или продажа определенного объема торгуемого финансового инструмента. Открытие позиции происходит как при исполнении рыночного ордера, так и при автоматическом исполнении отложенного ордера.

Рыночный ордер

Для открытия позиции с помощью рыночного ордера нужно выполнить команду меню "Сервис — Новый ордер", нажать кнопку Новый ордер панели инструментов "Стандартная", клавишу F9 либо дважды кликнуть на наименовании финансового инструмента в окне "Обзор рынка". Также можно выполнить команду "Новый ордер" контекстных меню окон "Обзор рынка" и "Терминал — Торговля". При этом для управления торговыми позициями откроется окно "Ордер". При открытии позиции в нем необходимо:

  • Символ — выбрать финансовый инструмент, по которому открывается позиция;

  • Объем — указать объем (количество лотов) сделки;

  • Стоп лосс — установить уровень ордера Стоп Лосс (необязательно);

  • Тейк профит — установить уровень ордера Тейк Профит (необязательно);

    Внимание: нулевые значения ордеров Стоп Лосс и Тейк Профит означают, что ордера не установлены вовсе.

  • Комментарий — написать комментарий (необязательно). Длина комментария не должна превышать 25 символов. Брокерская компания может добавить к комментарию свою информацию длиной до 6 символов либо полностью заменить его. После того как позиция открыта, комментарий изменять нельзя;

  • Использовать максимальное отклонение от запрошенной цены — включить/выключить отклонение. Если брокер выдает новую цену исполнения (перекотирует), вычисляется отклонение новой цены от первоначально запрошенной. При этом, если отклонение меньше или равно заданному параметру, происходит исполнение ордера по новой цене без дополнительного уведомления. В противном случае брокер возвращает новые цены, по которым может быть исполнен ордер;

  • Максимальное отклонение: — величина допустимого отклонения цены в пунктах.

    Внимание: отклонение цен при выставлении ордеров используется только в режиме немедленного исполнения.

После того как указаны все необходимые данные, необходимо нажать на кнопку "Sell" или "Buy". При этом брокеру отсылается ордер на открытие короткой или длинной позциии соответственно.

Внимание: если для выбранного финансового инструмента ордера исполняются по запросу, то для получения котировок необходимо сначала нажать кнопку "Запрос". Предложенные после запроса котировки будут активны всего несколько секунд. Если в течение этого времени не будет принято решение, то кнопки "Sell" и "Buy" будут снова заблокированы.

Если при открытии позиции уровни ордеров Стоп Лосс и Тейк Профит были слишком близко к текущей цене, появится сообщение "Неверный S/L или T/P". Необходимо отодвинуть уровни от текущей цены и повторить запрос на выставление ордера. Открытие торговой позиции произойдет после того, как брокерская компания совершит торговую операцию и установит Стоп Лосс и Тейк Профит. При этом во вкладке "Терминал — Торговля" появится строка состояния открытой позиции, а на графике (если включена опция "Показывать торговые уровни") появятся уровни цены открытия и Стоп Лосс и Тейк Профит.

Отложенные ордера

Чтобы открыть позицию при помощи отложенного ордера, необходимо сначала выставить его, как это описано в разделе "Установка отложенных ордеров". В случае соответствия текущих цен условию ордера произойдет автоматическое исполнение отложенного ордера, то есть открытие новой торговой позиции. При этом во вкладке "Терминал — Торговля" строка состояния отложенного ордера удаляется, и появляется новая строка состояния открытой позиции. Если к отложенному ордеру были прикреплены ордера Стоп Лосс и Тейк Профит, то они автоматически прикрепляются ко вновь открытой позиции.


Управление торговыми позициями — Изменение позиций

Изменение позиций

Изменение текущей позиции заключается в установке новых уровней прикрепленных ордеров Стоп Лосс или Тейк Профит. Для изменения позиции необходимо выполнить команду контекстного меню открытой позиции "Модифицировать или удалить ордер" либо дважды кликнуть левой кнопкой мыши на полях "Стоп Лосс" или "Тейк Профит" строки открытой позиции в окне "Терминал". Затем в появившемся окне необходимо задать новые значения ордеров Стоп Лосс или Тейк Профит и нажать кнопку "Изменить".

Для изменения значения Стоп Лосс и Тейк Профит необходимо записать новые значения в соответствующие поля. Для установки ордеров в пунктах от текущей цены необходимо задать требуемое значение в поле "Уровень" и нажать кнопку "Копировать". Если значения этих полей равны нулю, используется минимально допустимое отклонение, которое устанавливается брокером.

Если при изменении позиции уровни Стоп Лосс или Тейк Профит расположены слишком близко к текущей цене, кнопка "Изменить" блокируется. Необходимо отодвинуть уровни от текущей цены и повторить запрос на изменение позиции. Изменение торговой позиции произойдет после того, как брокерская компания установит новое значение Стоп Лосс и Тейк Профит. При этом во вкладке "Терминал — Торговля" в строке состояния открытой позиции произойдет изменение значений в полях "S/L" и "T/P". При этом, если включена опция "Показывать торговые уровни", изменятся положения модифицированных ордеров.

Внимание: нулевые значения в полях "Стоп Лосс" и "Тейк Профит" означают, что одноименные ордера не выставлены.


Управление торговыми позициями — Закрытие позиций

Закрытие позиций

Покупка или продажа финансового инструмента открывает торговую позицию. Далее, чтобы получить прибыль за счет разницы курсов, необходимо закрыть позицию. При закрытии торговой позиции совершается обратная по отношению к первой торговая операция. Например, если первой торговой операцией была покупка одного лота по GOLD, то для закрытия позиции нужно продать один лот того же финансового инструмента. В клиентском терминале различают закрытие одиночной позиции, закрытие позиции встречной позицией и закрытие нескольких встречных позиций.

Закрытие одной позиции

Автоматическое закрытие одиночной открытой торговой позиций производится при равенстве цен значениям ордеров Стоп Лосс или Тейк Профит.

Внимание: при закрытии длинной позиции значению уровней ордеров Стоп Лосс или Тейк Профит должна равняться цена Bid, а при закрытии короткой — цена Ask.

Для закрытия позиции вручную необходимо выполнить команду контекстного меню открытой позиции окно "Терминал — Торговля" либо дважды кликнуть левой кнопкой мыши на этой же позиции. Если исполнение торговых операций для выбранного инструмента производится по запросу, то сначала необходимо получить котировки, нажав на кнопку "Запрос". После этого активизируется кнопка, позволяющая закрыть позицию.

Внимание:
  • в режиме "Исполнение по запросу" предложенные котировки будут активны всего несколько секунд. Если в течение этого времени не будет принято решение, то кнопка "Закрыть ..." будет снова заблокирована;
  • клиентский терминал позволяет совершать частичное закрытие позиции. Для этого перед нажатием кнопки "Закрыть..." в поле "Объем" нужно указать меньшее, чем у открытой позиции, значение лотов;
  • брокер также может закрывать позиции. Например, это происходит при достижении уровня "Стоп Аут", который устанавливает брокер;
  • исторические графики в терминале строятся только по Bid-ценам. При этом часть отображаемых на графиках ордеров строятся по Ask-ценам. Чтобы включить отображение Ask-цены последнего бара, необходимо выставить флажок "Показывать линию Ask" в настройках терминала.

Закрытие встречных позициий

Встречной позицией по отношению к данной считается противоположная позиция по тому же финансовому инструменту. Если среди открытых позиций имеется одна или несколько встречных, то можно закрыть выбранную позицию вместе со встречной. Для этого необходимо сначала открыть окно "Ордер" (способы открытия описаны выше). Затем нужно в поле "Тип" выбрать "Закрыть встречной позицией". При этом в нижней части окна появится список всех встречных позиций. В этом списке необходимо выбрать встречную позицию, после чего активизируется кнопка "Закрыть ...". Она позволяет закрыть сразу две позиции. Если встречные позиции имели разное количество лотов, открытой остается только одна из них. Объем этой позиции (количество лотов) будет равен разности лотов закрытых позиций, а ее направление и цена открытия (короткая или длинная) — большей (по объему) из закрываемых позиций.

Закрытие нескольких встречных позиций

Закрытие нескольких встречных позиций позволяет закрыть не две встречные позиции по одному инструменту, а сразу несколько. Для проведения данной операции необходимо также открыть окно "Ордер" (способы открытия описаны выше). Затем в поле "Тип" выбрать "Множественное закрытие встречных позиций". При этом нижней части окна появится список всех встречных позиций и активизируется кнопка "Множественное закрытие встречных позиций ...". Она позволяет закрыть встречные позиции. Закрытие происходит попарно, в соответствии со временем открытия позиций, по алгоритму закрытия двух встречных позициий. Если разница сумм объемов противоположных позиций не равна нулю, в результате операции будет открыта новая позиция с объемом, равным этой разности. Вновь открытая позиция будет участвовать в дальнейшем процессе множественного закрытия, но в соответствии со своим временем открытия. И так — до тех пор, пока не закроются все позиции либо пока не откроется последняя результирующая позиция.

Внимание: после закрытия встречных позиций в окне "Терминал — История счета" появятся соответствующие записи. При этом в поле "Комментарий" записывается служебная информация о закрытии встречных позиций.


Управление торговыми позициями — Установка отложенных ордеров

Установка отложенных ордеров

Для установки отложенных ордеров необходимо открыть окно "Ордер". Это можно сделать командой меню "Сервис — Новый ордер", кнопкой Новый ордер панели инструментов "Стандартная", клавишей F9, командой "Новый ордер" контекстных меню окон "Обзор рынка" и "Терминал — Торговля", а также двойным щелчком на наименовании финансового инструмента в окне "Обзор рынка". В поле "Тип" этого окна необходимо выбрать "Отложенный ордер".

Далее потребуется выбрать финансовый инструмент (символ), указать объем, а также задать значения ордеров Стоп Лосс и Тейк Профит. Если необходимо, можно также записать комментарий в одноименном поле. В полях "Отложенный ордер" нужно:

  • Тип — выбрать тип отложенного ордера: Buy Limit, Buy Stop, Sell Limit или Sell Stop;

  • По цене — установить уровень цены, по достижении которого должен сработать ордер;

  • Истечение — задать срок действия ордера. Если до этого времени ордер не сработает, он будет удален автоматически.

    Внимание: срок действия ордера должен быть не менее 10 минут!

Кнопка "Установить ордер" отправляет ордер на исполнение, которое происходит в два этапа. После выдачи ордера брокерская компания производит его установку. При этом во вкладке "Терминал — Торговля" появится строка с номером и состоянием отложенного ордера. На графике, если включена опция "Показывать торговые уровни", появятся отметки уровней выставленного отложенного ордера (включая уровни Стоп Лосс и Тейк Профит). На втором этапе, если цены будут соответствовать условию ордера, происходит его удаление и открытие вместо него торговой позиции. При этом тикет открытой позиции будет совпадать с тикетом отложенного ордера. Эти изменения отражаются в окне "Терминал — Торговля".

Внимание: ордера Стоп Лосс или Тейк Профит срабатывают только на открытых позициях и не работают на отложенных ордерах.


Управление торговыми позициями — Изменение отложенных ордеров

Изменение отложенных ордеров

При работе на рынке часто возникает необходимость изменить либо удалить выставленный отложенный ордер. Чтобы это сделать, необходимо выполнить команду контекстного меню отложенного ордера "Модифицировать или удалить ордер" либо дважды щелкнуть левой кнопкой мыши на строке состояния отложенного ордера в окне "Терминал — Торговля". При этом откроется окно управления ордерами. В нем можно задать новую цену срабатывания отложенного ордера, новые уровни Стоп Лосс и Тейк Профит, а также изменить срок действия ордера. После модификации ордера необходимо нажать кнопку "Изменить".

Внимание: установка нулевых значений Стоп Лосс и Тейк Профит равносильна отключению одноименных ордеров.

При успешном изменении отложенного ордера в окне "Терминал — Торговля" произойдет изменение значений соответствующих полей. Если в настройках терминала включена опция "Показывать торговые уровни", на графике также произойдет перемещение уровней отложенного ордера и прикрепленных к нему ордеров Стоп Лосс и Тейк Профит.


Управление торговыми позициями — Удаление отложенных ордеров

Удаление отложенного ордера

При изменении рыночной ситуации может потребоваться удалить отложенный ордер. Для этого необходимо выполнить команду контекстного меню отложенного ордера "Модифицировать или удалить ордер" либо дважды щелкнуть левой кнопкой мыши на строке состояния отложенного ордера в окне "Терминал — Торговля". При этом откроется окно управления ордерами. В нем для удаления ордера необходимо нажать одноименную кнопку. Также отложенные ордера могут удаляться автоматически при наступлении времени, указанного в поле "Истечение". При удалении отложенного ордера в окне "Терминал — История счета" появляется соответствующая информация.


Советники, пользовательские индикаторы и скрипты — Руководство пользователя

Автотрейдинг

Автотрейдинг

Для эффективной работы на финансовых рынках можно разработать свою успешную торговую систему. Постоянно придерживаться выработанной торговой системы в ручном режиме очень сложно, из-за значительной роли эмоционального фактора. Механические торговые системы лишены этого недостатка.

Клиентский терминал предоставляет широкий спектр средств для разработки и использования механических торговых систем (МТС, экспертов, советников). Средства разработки позволяют создавать, отлаживать и тестировать советники. Эксперты способны не только выдавать рекомендательные торговые сигналы, но и полностью управлять торговой деятельностью в реальном режиме времени.

Для работы с советниками в терминал встроены язык программирования MetaQuotes Language 4, редактор MetaEditor и инструменты тестирования советников. При помощи этих средств можно создавать:

  • Советники — механические торговые системы, позволяющие полностью автоматизировать аналитико-торговую деятельность;

  • Пользовательские индикаторы — самостоятельно написанные технические индикаторы, предназначенные для анализа динамики цен;

  • Скрипты — программа, выполняемая один раз по запросу.


Автотрейдинг — Язык MQL 4

Язык MetaQuotes Language 4

В клиентский терминал встроен язык программирования торговых стратегий MetaQuotes Language 4 (MQL 4). Он позволяет писать собственные советники, автоматизирующие управление торговыми процессами и идеально подходящие для реализации собственных торговых стратегий. Кроме того, на MQL 4 можно создавать собственные пользовательские индикаторы, скрипты и библиотеки функций.

Синтаксис MQL 4 очень похож на синтаксис языка Си, он прост в изучении и использовании. В состав MQL 4 включено большое количество функций, необходимых для анализа котировок, управления позициями, вызова технических индикаторов и других. Для написания исходного текста программ используется редактор советников MetaEditor. В редактор встроен словарь MetaQuotes Language Dictionary, содержащий описания всех конструкций языка и функций.

Программы, написанные на MQL 4, имеют различные свойства и предназначение:

  • Советник — это механическая торговая система (МТС), запускающаяся с приходом нового тика. Он может не только работать в режиме информирования о торговых сигналах, но также самостоятельно совершать торговые операции. Терминал поддерживает тестирование стратегий на исторических данных, что позволяет выявить особенности поведения советника в различных рыночных условиях;

  • Пользовательский индикатор — самостоятельно написанный технический индикатор. Пользовательские индикаторы используются только для анализа динамики цен;

  • Скрипт — программы, предназначенные для одноразового выполнения каких-либо действий. В отличие от экспертов, скрипты запускаются не потиково, а по команде.


Автотрейдинг — MetaEditor

MetaEditor

Редактор MetaEditor является составной частью клиентского терминала. Он предназначен для создания, редактирования и компиляции исходного текста программ, написанных на языке MetaQuotes Language 4 (MQL4). С его помощью можно разрабатывать советники, пользовательские индикаторы, скрипты и библиотеки функций.

В редактор встроен мастер создания советников, который помогает быстро создавать новые MQL4-программы. При этом файл автоматически помещается в соответствующую папку клиентского терминала. При создании файла MQL4-программы можно также применять шаблоны. После этого можно приступать к непосредственному написанию текста программы. При этом можно использовать справочную информацию Словаря MQL4. В нем дано полное описание языка с примерами использования. Когда программа готова, необходимо ее скомпилировать в редакторе MetaEditor. В результате успешной компиляции создается исполняемый код программы, который можно запускать или тестировать в терминале.

Детальное описание редактора MetaEditor дано во встроенной справке по этой программе.


Автотрейдинг — Советники

Советники

Советниками (экспертами) в терминале называются программы, разработанные на языке программирования MetaQuotes Language 4 (MQL 4), с помощью которых автоматизируются аналитические и торговые процессы. Они позволяют оперативно проводить технический анализ ценовых данных и на основе полученных сигналов управлять торговой деятельностью. На советников можно возложить всю рутинную работу по проведению технического анализа и выполнению всех торговых операций. Советник может совершать аналитические и торговые операции по любым финансовым инструментам и периодам независимо от того, открыт соответствующий график или нет.

Работа с советниками предполагает:

  • Создание эксперта
    Для создания и компиляции советника используется встроенный редактор "MetaEditor". Он является составной частью клиентского терминала и представляет собой удобную среду разработки MQL4-программ.

  • Настройка работы советников
    Перед началом использования советников необходимо произвести их предварительную настройку. Общие для всех экспертов параметры работы задаются в окне настройки клиентского терминала. Кроме того, каждый советник обладает своими собственными настройками.

  • Запуск эксперта
    Для запуска эксперта необходимо наложить его на график. С приходом нового тика эксперт начинает исполняться.

  • Завершение работы эксперта
    Завершение работы советника происходит, когда он удаляется с графика.


Советники — Создание

Создание экспертов

Для создания советников используются язык программирования торговых стратегий MetaQuotes Language 4 (MQL 4) и редактор MetaEditor. Чтобы запустить редактор советников, необходимо выполнить команду "Создать" контекстного меню окна "Навигатор — Советники", команду меню "Сервис — Редактор MetaQuotes Language", нажать клавишу F4 или кнопку Редактор MetaEditor панели "Стандартная". При создании эксперта автоматически откроется мастер создания советников, позволяющий быстро приступить к работе с новой MQL4-программой. В нем в качестве типа создаваемого объекта необходимо указать "Советник" и заполнить поля требуемыми данными:

  • Имя — название советника;

  • Автор — имя автора;

  • Ссылка — адрес сайта разработчика;

  • Параметры — список входных параметров советника. Чтобы добавить новый параметр, необходимо нажать кнопку "Добавить", чтобы удалить — кнопку "Удалить".

После этого в редакторе открывается окно нового советника с заданными параметрами. Файл с исходным текстом (*.MQ4) советника автоматически помещается в папку /EXPERTS клиентского терминала. С этого момента можно приступать к написанию кода эксперта.

По завершении разработки необходимо скомпилировать советник. Для этого в редакторе советников необходимо выполнить команду меню "Файл — Компилировать", нажать клавишу F5 или кнопку Компилировать панели инструментов. В результате успешной компиляции создается исполняемый файл программы с расширением *.EX4, автоматически помещаемый в папку /EXPERTS. Список скомпилированных экспертов можно просмотреть в окне "Навигатор — Советники" клиентского терминала. Если компиляция не была успешно завершена, пиктограмма эксперта будет закрашена серым цветом. Это означает, что его использовать нельзя.

Редактирование советников

Чтобы приступить к редактированию уже существующего советника из терминала, необходимо выполнить команду "Изменить" контекстного меню окна "Навигатор — Советники". При этом откроется редактор советников, в который уже будет загружен исходный текст выбранного эксперта. После изменения исходного текста советника необходимо повторно скомпилировать его и получить новый исполняемый EX4-файл. В противном случае в терминале будет использоваться неизмененная, предыдущая версия эксперта.

Внимание: если компиляция не была успешно завершена, пиктограмма эксперта будет закрашена серым цветом. Это означает, что его использовать нельзя.


Автотрейдинг — Советники

Настройка работы советников

Перед началом использования советников необходимо произвести их предварительную настройку. Общие для всех экспертов параметры работы задаются в окне настройки клиентского терминала. Это окно можно открыть командой меню "Сервис — Настройки" или при помощи клавиш-акселераторов Ctrl+O. Для настройки параметров работы экспертов необходимо выбрать вкладку "Советники". В ней доступны:

  • Включить советники
    Эта опция позволяет разрешить или запретить использование всех советников. Если она отключена, с приходом нового тика для всех экспертов перестает запускаться функция start(). При этом вместо смайликов напротив названий экспертов в правом верхнем углу графиков появятся крестики. Чтобы включить советники, необходимо выставить флажок и нажать кнопку "ОК". С приходом нового тика они начнут работать, а крестики в правом верхнем углу графика вновь станут смайликами.

    Внимание:
    • эксперт запускается на выполнение с приходом нового тика и, чаще всего, успевает завершить свою работу до прихода следующего тика. Отключение советников не прерывает текущее исполнение уже работающих экспертов;
    • эта опция распространяется только на советники и не позволяет автоматически отключать пользовательские индикаторы и скрипты.

  • Отключить советники при смене счета
    Эта опция представляет собой защитный механизм, отключающий советники при смене счета. Она бывает полезна, например, при переключении с демонстрационного счета на реальный. Чтобы включить механизм, необходимо выставить флажок и нажать кнопку "ОК".

  • Отключить советники при смене профиля
    В профилях сохраняется большое количество информации о текущих настройках всех графиков в рабочей области. В частности, в профилях сохраняется информация о прикрепленных советниках. Эксперты, входящие в состав профиля, с приходом нового тика начнут работать. Включив эту опцию (выставив флажок), можно не допустить запуска экспертов при смене профиля.

  • Разрешить советнику торговать
    Советники способны работать в автоматическом режиме, без участия трейдера. Они могут как анализировать динамику цен, так и вести торговую деятельность. Эта опция предназначена для ограничения торговых функций экспертов. Такое ограничение бывает полезно при тестировании аналитических способностей эксперта в режиме реального времени (не путать с тестированием советника на исторических данных).

  • Ручное подтверждение
    Опция "Ручного подтверждение" активируется только в том случае, если советникам разрешено торговать. Если эта опция включена, и советник пытается провести торговую операцию, можно будет либо подтвердить ее, либо прервать вручную. Иными словами, при помощи ручного подтверждения можно контролировать торговую активность советника. Это может быть полезно при тестировании торговых функций советника в режиме реального времени (не путать с тестированием советника на исторических данных).

  • Разрешить импорт DLL
    Для расширения функциональности советники могут использовать DLL-библиотеки. Выставив этот флажок, можно использовать такие библиотеки без каких-либо ограничений. Если эта опция отключена, ни один эксперт не сможет воспользоваться внешними DLL-библиотеками. Рекомендуется запрещать импорт при работе с неизвестными экспертами.

  • Подтверждать вызов функций DLL
    Эта опция активируется только в том случае, если был разрешен импорт из DLL-библиотек. Она позволяет контролировать выполнение каждой вызываемой функции вручную. Если флажок не установлен, импорт из внешних библиотек контролироваться не будет. При работе с неизвестными экспертами рекомендуется включать эту опцию.

  • Разрешить импорт внешних экспертов
    Если при работе советника требуется экспортировать функций из других экспертов или библиотек MQL4, необходимо включить эту опцию. Если она отключена, ни один из запущенных экспертов не сможет запрашивать функции из других MQL4-программ. Рекомендуется отключать эту опцию при работе с неизвестными советниками.


Советники — Запуск

Запуск советников

После настройки общих параметров, можно запускать эксперты. Для этого достаточно лишь присоединиять советник к графику. Команда "Присоединить к графику" контекстного меню окна "Навигатор — Советники" или двойной клик левой кнопкой мыши на выбранном эксперте в том же окне позволяют наложить его на активный график. Более того, при помощи технологии "Drag'n'Drop" можно наложить советник на любой график. При этом на экране появится окно индивидуальных настроек советника. Во вкладке "Общие" можно:

  • Позиции — выбрать направление открытия позиций:

    1. Long&Short — в обе стороны;

    2. Only Long — только на покупку;

    3. Only Short — только на продажу.

  • Разрешить сигналы — разрешить/запретить советнику подавать сигналы;

  • Не повторять сигнал — запретить подачу сигналов о событиях после поступления первого сигнала;

  • Разрешить советнику торговать — разрешить/запретить проведение торговых операция в реальном времени;

  • Ручное подтверждение — запрашивать подтверждение на открытие позиции при проведении торговых операций;

  • Разрешить импорт DLL — разрешить/запретить импорт функций из DLL-файлов;

  • Подтверждать импорт функций DLL — запрашивать подтверждения при каждом вызове функций из DLL-файлов;

  • Разрешить импорт внешних экспертов — разрешить/запретить вызов функций из внешних экспертов.

Во вкладке "Входные параметры" можно изменить внешние переменные эксперта. К ним относятся переменные класса extern. Чтобы изменить параметр необходимо дважды кликнуть левой кнопкой мыши на его значении и записать новое. При этом можно изменять значение каждой переменной или загрузить уже сохраненный набор входных параметров (кнопка "Загрузить"). Сохранить текущий набор внешних переменных можно при помощи одноименной кнопки.

Кнопка "Сброс" возвращает все настройки по умолчанию. Во вкладке "Общие" выставляются заданные в настройках терминала параметры. А в качестве входных переменных выставляются параметры, указаные в исходном тексте программы. Чтобы подтвердить прикрепление советника с заданными параметрами, необходимо нажать кнопку "ОК". А отменить наложение эксперта можно нажав одноименную кнопку.

Внимание: индивидуальную настройку можно производить для уже прикрепленных экспертов. Однако, пока идет текущее исполнение, открыть страницу свойств советника нельзя. Это можно сделать только в промежутках между вызовами функции start(). При этом эксперт запускаться не будет, пока открыты его свойства. Если были изменены входные параметры советника, то по нажатии кнопки "ОК" происходит переинициализация эксперта с новыми входными параметрами.

После настройки эксперта произойдет его инициализация и с приходом нового тика советник начнет исполнятся. Свидетельством прикрепления советника является появление в правом верхнем углу графика имени эксперта и значка — смайлика. Если в настройках эксперта запрещено торговать, то вместо смайлика появится L. Крестик (û) означает, что все эксперты отключены.

Внимание: к одному графику можно присоединить только один советник. При наложении второго советника, первый удаляется.


Советники — Завершение работы

Завершение работы советника

Чтобы завершить работу эксперта, необходимо удалить его с графика. Перед завершением работы производится деинициализация эксперта. Для удаления эксперта с графика необходимо выполнить команду контекстного меню графика "Советники — Удалить" либо присоединить к графику другой советник. Кроме того, советник может удаляться с графика при смене профиля или шаблона.

Внимание:
  • при выключении клиентского терминала происходит завершение работы всех экспертов;
  • при закрытии графика происходит завершение прикрепленного к нему советника;
  • при наложении второго советника, первый удаляется после подтверждения;
  • удаление советника из окна "Навигатор" не завершает работу одноименного наложенного на график эксперта;
  • отключение советников в настройках клиентского терминала не является гарантией полного отключения экспертов. Эта опция прекращает запуск функции start() каждого советника, но функция init() продолжает выполнятся.


Автотрейдинг — Тестирование стратегий

Тестирование стратегий

Терминал позволяет не только писать советники, но и тестировать их перед использованием. Эта полезная функция позволяет проверить работоспособность и эффективность механической торговой системы на исторических данных. Тестирование дает возможность приступить к автотрейдингу, зная об особенностях поведения эксперта в различных рыночных условиях. Для этих целей в терминал встроено специальное окно "Тестер". При помощи этого окна можно также оптимизировать входные параметры экспертов.


Тестирование стратегий — Настройка

Настройка параметров тестирования

Прежде чем приступать к тестированию советников, необходимо произвести настройку. Это означает, что следует:

  • выбрать советник и задать его входные параметры

  • выбрать финансовый инструмент и его период

  • выбрать один из трех способов моделирования баров

  • задать временной диапазон тестирования (необязательно)

Для тестирования и оптимизации советников в терминале используется специальное окно "Тестер". Все вышеперечисленные параметры задаются во вкладке "Настройка" этого окна.

Советник и его параметры

В поле окна "Тестер — Советники" необходимо выбрать советник для тестирования. В этом поле нельзя выбрать любой файл советника. Здесь могут быть только доступные в клиентском терминале эксперты. Для этого они должны быть скомпилированными и находиться в папке /EXPERTS.

После того как выбран советник, необходимо провести дополнительную настройку тестирования и входных параметров. Это можно сделать нажатием кнопки "Свойства эксперта". При этом появится новое окно с тремя вкладками:

  • Тестирование — в этой вкладке задаются общие параметры тестирования. К ним относятся объем и валюта начального депозита, которые указываются в одноименных полях. Именно этим депозитом будет оперировать советник при тестировании. В этой вкладке также выбираются типы открываемых при тестировании позиций: Only Long — открывать только длинные позиции; Only Short — только короткие; Long and Short — открывать позиции в обе стороны. Каков бы ни был алгоритм советника, он будет открывать позиции только в заданных направлениях. Также можно включить генетический алгоритм оптимизации и выбрать оптимизируемый параметр (максимизация по значению баланса, фактора прибыльности, математического ожидания выигрыша либо минимизация по значению максимальной просадки или процента просадки.

  • Входные параметры — здесь в виде таблицы приводится список всех входных параметров. Входными параметрами называются переменные, которые влияют на работу эксперта и могут быть изменены прямо из клиентского терминала. Для изменения этих параметров нет необходимости изменять код эксперта. Количество входных переменных может варьироваться от эксперта к эксперту. При тестировании входные параметры советника задаются в поле "Значение". Данные, записываемые в полях "Старт", "Шаг" и "Стоп", не влияют на тестирование советника и необходимы лишь для оптимизации его параметров. Работа с этими параметрами описывается в разделе "Настройка оптимизации советников".

  • Оптимизация — настройки в этой вкладке позволяют управлять ограничениями проходов тестирования при оптимизации. Изменения параметров в этой вкладке не влияют на однократные тестирования эксперта.

Финансовый инструмент и его период

Чтобы приступить к тестированию, недостаточно лишь выбрать советник и настроить его. Необходимо также выбрать финансовый инструмент и период (таймфрейм) для тестирования. Все тестирование будет проходить именно на этих данных. При тестировании можно выбрать один из доступных в терминале инструментов или использовать внешний файл данных. В тестировании используются файлы исторических данных формата *.FXT, которые записываются в директории /TESTER. Эти файлы автоматически создаются при тестировании, если был выбран имеющийся в терминале инструмент.

Финансовый инструмент задается в поле "Символ", а таймфрейм — в поле "Период". Если файла данных по этому инструменту, периоду и методу моделирования не существует, он будет создан автоматически. При отсутствии исторических данных по инструменту и периоду, тестер автоматически скачает 512 последних баров истории.

Внимание: если по инструменту имеются какие-либо данные за пределами последних 512 баров, произойдет автоматическое скачивание исторических данных до самого последнего имеющегося бара. Это может вызвать резкое увеличение входящего трафика.

Методы моделирования

Исторические данные в терминале сохраняются только как бары и представляют собой записи в виде TOHLCV (формат HST). Эти данные могут использоваться для моделирования динамики цен при тестировании советников. В некоторых случаях для тестирования такой информации бывает недостаточно. Например, на дневном таймфрейме колебания цен внутри бара могут привести к срабатыванию советника. В то же время при тестировании срабатывания может не произойти. Иными словами, тестирование советника на основе одних только баров иногда бывает неточным и может дать ложное представление об эффективности эксперта.

Терминал позволяет тестировать советники с использованием различных методов моделирования исторических данных. За счет использования исторических данных более мелких периодов можно представлять колебания цен внутри баров, то есть динамика цен будет эмулироваться более точно. Например, при тестировании советника на часовых данных, динамику цен внутри бара можно смоделировать на основе минутных данных. Таким образом, моделирование существенно приближает исторические данные к реальным колебаниям цен и делает тестирование советников более достоверным.

Для тестирования можно выбрать один из трех методов моделирования исторических данных:

  • По ценам открытия (быстрый метод на сформировавшихся барах)
    Некоторые механические торговые системы не зависят от особенностей внутрибарного моделирования, они торгуют на сформировавшихся барах. То, что текущий ценовой бар полностью сформировался, можно узнать по появлению следующего. Именно для таких экспертов предназначен этот режим моделирования.

    В этом режиме сначала моделируется открытие бара (Open = High = Low = Close, Volume=1), что дает эксперту возможность точно идентифицировать окончание формирования предыдущего ценового бара. Именно на этом зарождающемся баре запускается тестирование эксперта. На следующем шаге выдается уже полностью сформированный текущий бар, но на нем тестирование не производится!

  • Контрольные точки (используется ближайший меньший таймфрейм)
    Метод моделирования контрольных точек предназначен для грубой оценки экспертов, торгующих внутри бара. Для этого метода необходимо наличие исторических данных ближайшего меньшего периода (таймфрейма). В некоторых случаях имеющиеся данные меньшего таймфрейма не полностью покрывают временной диапазон тестируемого таймфрейма. При отсутствии данных меньшего таймфрейма развитие бара генерируется на основе предопределенных волновых шаблонов, как это было в предыдущей, третьей версии клиентского терминала MetaTrader 3.

    Как только появляются исторические данные меньшего таймфрейма, то интерполяция применяется уже к этим данным. Однако точно существующие цены OHLC меньшего таймфрейма выступают в качестве контрольных точек. В большинстве случаев результаты тестирования экспертов по методу контрольных точек могут приниматься во внимание только как оценочные, а не как окончательные. Такие результаты имеют промежуточный оценочный характер.

  • Все тики (на основе всех наименьших доступных периодов) Этот режим позволяет наиболее точно смоделировать движение цены внутри бара. В отличие от "контрольных точек", потиковый метод использует для генерации данные не только ближайшего меньшего таймфрейма, но и всех доступных меньших таймфреймов. При этом, если для какого-то временного диапазона одновременно существуют данные более, чем одного таймфрейма, для генерации используются данные самого меньшего таймфрейма. Так же, как и в предыдущем методе, генерируются контрольные точки на основе данных OHLC наименьшего доступного таймфрейма. Для генерации движения цены между контрольными точками также используется интерполяция на основе предопределенных шаблонов, поэтому крайне желательно наличие минутных данных, покрывающих весь диапазон тестирования. Возможна ситуация, когда генерируется несколько одинаковых тиков подряд. В этом случае дублирующиеся котировки фильтруются, и фиксируется объем последней из таких котировок.

    Необходимо учитывать очень большой возможный объем сгенерированных потиковых данных. Это может сказаться на потребляемых ресурсах операционной системы и на скорости тестирования.

    Внимание:
    • не рекомендуется запускать потиковое тестирование при отсутствии более мелких таймфреймов, полностью покрывающих исследуемый период, иначе тестирование будет неточным;
    • моделирование по контрольным точкам в основном используется при оптимизации советников, а моделирование всех тиков — для тщательного тестирования.

Качество моделирования можно проверить в окне "Отчет". Для этого предназначено поле "Качество моделирования" и цветная полоса. Полоса представляет собой схематичное отображение процесса моделирования. Она может быть трех цветов:

  1. Серый — эта часть имеющихся данных не участвовала в тестировании. Серый цвет может появиться, если для тестирования был указан диапазон дат (описано ниже);

  2. Красный — на этом отрезке моделирование не проводилось за неимением данных более мелкого периода. При этом использовались только данные выбранного для тестирования таймфрейма;

  3. Зеленый — на данном участке моделирование проводилось. Причем, чем ярче цвет, тем более качественным было моделирование. Например, при тестировании на периоде H1 темно-зеленая полоса может свидетельствовать о том, что для тестирования использовались данные периода M30, а самая яркая — об использовании данных периода M1.

Временной диапазон

Диапазон дат позволяет тестировать советники не на всех имеющихся данных, а лишь на выбранном временном отрезке. Это бывает удобным при необходимости исследовать отдельную часть исторических данных. Ограничение диапазона дат можно использовать не только при тестировании эксперта, но и при генерации тестирующей последовательности баров (файла смоделированных данных, используемого для тестирования). Очень часто нет необходимости генерировать данные всей истории, особенно при потиковом моделировании, когда объем неиспользуемых данных может быть очень большим. Поэтому если при первоначальной генерации тестирующей последовательности была включена возможность использования диапазона дат, то бары, выходящие за пределы указанного диапазона, не генерируются, а просто переписываются в выходную последовательность. Данные не исключаются из последовательности, чтобы оставалась возможность правильно посчитать индикаторы на всей полученной истории. Необходимо заметить, что первые 100 баров также не генерируются. Это ограничение не зависит от установленного диапазона дат.

Чтобы включить ограничение по датам, необходимо выставить флажок "Использование дат" и указать требуемые значения в полях "От" и "До". После того, как произведены все настройки, можно нажать кнопку "Старт" и начать тестирование. После начала тестирования в нижней части окна можно просмотреть ориентировочное время завершения этого процесса.

Визуализация тестирования

Если включить флажок ""Визуализация", то после нажатия на кнопку "Старт" автоматически будет открыт график, на котором будет проигрываться смоделированная последовательность тиков. Скорость проигрывания можно регулировать. Можно приостановить проигрывание, нажав на кнопку "||". Повторное нажатие на эту кнопку возобновляет поступление смоделированных тиков. Нажатие на клавишу F12 вызывает моментальное появление следующего тика даже в состоянии паузы. Визуализацию можно пропустить до определенной даты. После установки нужной даты и нажатия на кнопку "Пропустить до" визуализация прекращается и возобновляется после достижения тестером указанной даты.

Внимание: если выставлен флажок "Оптимизация", по нажатии кнопки "Старт" вместо тестирования будет производиться оптимизация параметров советника.


Тестирование стратегий — Результаты

Результаты тестирования

После завершения тестирования можно просмотреть его результаты во вкладках: "Результаты", "График", "Отчет" и "Журнал".

Результаты

В этой вкладке в виде таблицы представлена информация обо всех проведенных торговых операциях:

  • Номер — порядковый номер торговой операции;

  • Время — время совершения операции;

  • Тип — тип совершенной операции (sell, buy, s/l, t/p, modify, close at stop и так далее);

  • Ордер — номер тикета торговой позиции или отложенного ордера (не путать с номером торговой операции, который описан выше);

  • Лоты — количество лотов, участвовавших в операции;

  • Цена — цена инструмента при совершении операции;

  • S/L — значение ордера Стоп Лосс. Отсутствие записей в этом поле свидетельствует о том, что ордер не выставлялся;

  • T/P — значение ордера Тейк Профит. Отсутствие записей в этом поле свидетельствует о том, что ордер не выставлялся;

  • Прибыль — прибыль/убыток. Значение прибыли/убытка проставляется только при закрытии позиций;

  • Баланс — значение баланса. Значение баланса записывается только при закрытии позиций.

Кликнув левой кнопкой мыши на любом заголовке столбца, можно отсортировать все записи в таблице по убыванию или по возрастанию. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать выбранные строки результатов в буфер обмена для дальнейшего использования в других приложениях. Если не выбрано ни одной строки, то в буфер обмена скопируется вся таблица. Также, чтобы скопировать всю таблицу в буфер обмена, можно выполнить команду "Копировать все". Отчет о результатах тестирования можно сохранить в HTML-файле на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как отчет". Команды "Установить начальную дату" и "Установить конечную дату" позволяют задать временной диапазон тестирования. При этом даты выбранных операций записываются в поля "Использовать дату от:" и "Использовать дату до:" в настройках тестирования. Это бывает полезным при необходимости тщательно протестировать советник или провести оптимизацию его параметров на данном диапазоне.

График

Во вкладке "График" автоматически рисуется график состояния баланса счета (синяя линия — "Баланс") и общего состояния счета с учетом открытых позиций (зеленая линия — "Средства"). Если на графике отображается лишь одна линия баланса, значит, линии "Баланс" и "Средства" совпадают на всем протяжении тестирования. График позволяет более наглядно отследить динамику результатов торговли при тестировании. Если в процессе тестирования происходило изменение размера лотов, в нижней части графика также появляется гистограмма изменения лотов.

Двойной клик левой кнопкой мыши на любой точке графика производит переключение во вкладку "Результаты" и выбирает соответствующую строку. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать изображение графика в буфер обмена для дальнейшего использования в других приложениях. График можно также сохранить в виде GIF-файла на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как рисунок" или нажать клавиши-акселераторы Ctrl+S. Команды "Установить начальную дату" и "Установить конечную дату" позволяют задать временной диапазон тестирования. При этом даты выбранных операций записываются в поля "Использовать дату от:" и "Использовать дату до:" во вкладке настроек тестирования. Это бывает полезным, если необходимо тщательно протестировать советник или провести оптимизацию его параметров на данном временном диапазоне.

Отчет

Во вкладке "Отчет" представлены обобщенные результаты тестирования советника и некоторые ключевые показатели. Такие отчеты позволяют быстро сравнивать между собой различные эксперты. В отчетах публикуются следующие данные:

  • Баров в истории — количество смоделированных исторических данных в барах;

  • Смоделировано тиков — количество смоделированных тиков;

  • Качество моделирования — качество смоделированных в процессе тестирования тиков в процентах. Моделирование схематично отображается в виде полосы в следующей строке отчета. Эта полоса может быть трех цветов:

    1. Серый — эта часть имеющихся данных не участвовала в тестировании. Серый цвет может появиться, если был указан диапазон дат в настройках тестирования;

    2. Красный — на этом отрезке моделирование не проводилось за неимением данных более мелкого периода. При этом использовались только данные выбранного в настройках тестирования периода;

    3. Зеленый — моделирование на данном участке проводилось. Причем, чем ярче цвет, тем более качественным было моделирование. Например, при тестировании на периоде H1 темно-зеленая полоса может свидетельствовать о том, что для тестирования использовались данные тридцатиминутного периода M30, а самая яркая — об использовании минутных данных;

    Внимание: если в качестве метода моделирования в настройках тестирования был выбран самый быстрый способ ("по ценам открытия"), вся полоса будет красной. При этом в графе "Качество моделирования" будет записано "n/a" — моделирование не проводилось;

  • Начальный депозит — объем начального депозита;

  • Чистая прибыль — финансовый результат всех сделок. Этот показатель представляет собой разность "Общей прибыли" и "Общего убытка";

  • Общая прибыль — сумма всех прибыльных сделок в денежных единицах;

  • Общий убыток — сумма всех убыточных сделок в денежных единицах;

  • Прибыльность — отношение общей прибыли к общему убытку в процентах. Единица означает, что сумма прибылей равна сумме убытков;

  • Матожидание выигрыша — математическое ожидание выигрыша. Этот статистически рассчитываемый показатель отражает среднюю прибыльность/убыточность одной сделки. Также можно считать, что он отражает предполагаемую прибыльность/убыточность следующей сделки;

  • Абсолютная просадка — наибольший убыток ниже значения начального депозита;

  • Максимальная просадка — наибольший убыток от локального максимума в валюте депозита и в проценте от депозита;

  • Всего сделок — общее количество торговых позиций;

  • Короткие позиции (% выигравших) — количество коротких позиций и процент прибыльных коротких позиций;

  • Длинные позиции (% выигравших) — количество длинных позиций и процент прибыльных длинных позиций;

  • Прибыльные сделки (% от всех) — количество прибыльных торговых позиций и их доля в общем количестве сделок, в процентах;

  • Убыточные сделки (% от всех) — количество убыточных торговых позиций и их доля в общем количестве сделок, в процентах;

  • Самая большая прибыльная сделка — наибольшая прибыль среди всех прибыльных позиций;

  • Самая большая убыточная сделка — наибольший убыток среди всех убыточных позиций;

  • Средняя прибыльная сделка — усредненное значение прибыли за сделку (сумма прибылей, поделенная на количество прибыльных сделок);

  • Средняя убыточная сделка — усредненное значение убытков за сделку (сумма убытков, поделенная на количество убыточных сделок);

  • Максимальное количество непрерывных выигрышей (прибыль) — наиболее длинная серия прибыльных торговых позиций и сумма их выигрышей;

  • Максимальное количество непрерывных проигрышей (убыток) — наиболее длинная серия убыточных торговых позиций и сумма их проигрышей;

  • Максимальная непрерывная прибыль (число выигрышей) — максимальная прибыль за одну серию прибыльных сделок и соответствующее ей количество прибыльных сделок;

  • Максимальный непрерывный убыток (число проигрышей) — максимальный убыток за одну серию убыточных сделок и соответствующее ему количество убыточных сделок;

  • Средний непрерывный выигрыш — среднее количество прибыльных позиций в непрерывных прибыльных сериях;

  • Средний непрерывный проигрыш — среднее количество убыточных позиций в непрерывных убыточных сериях.

Этот отчет можно скопировать в буфер обмена или сохранить на жестком диске в виде HTML-файла. Для этого необходимо выполнить команды контекстного меню "Скопировать" и "Сохранить как отчет" соответственно. Скопировать отчет в буфер обмена можно также при помощи клавиш-акселераторов Ctrl+C.

Вкладка "Журнал"

Во вкладке "Журнал" автоматически публикуются сообщения о ходе тестирования советника, включая все торговые операции. Этот журнал идентичен журналу окна "Терминал — Эксперты", за исключением того, что в окне тестера публикуются сообщения, связанные с тестированием советника, а не c его работой на рынке. После окончания тестирования эти данные выводятся в отдельный каталог /TESTER/LOGS. Файлы журнала тестирования хранятся в каталоге /EXPERTS/LOGS, имя файлов соответствует дате формирования журнала — YYYYMMDD.LOG. Для просмотра сохраненных журналов следует выполнить команду контекстного меню "Открыть" и выбрать нужный файл. Чтобы скопировать сообщение в буфер обмена, необходимо выполнить одноименную команду контекстного меню. Команда "Стереть все журналы" позволяет удалить все журналы из директории и очищает эту вкладку. Это бывает полезным для очистки жесткого диска от разросшихся файлов.


Тестирование стратегий — Файлы истории формата FXT

Файлы истории формата FXT

В своей работе тестер использует файл *.FXT со сгенерированной последовательностью баров. Каждая запись сгенерированной последовательности представляет собой состояние бара на тот или иной момент времени в пределах одного бара. Проводя моделирование баров, тестер берет из этого файла новые бары и обновляет текущий бар либо добавляет новый, если он только начал формироваться.

Ниже приведено краткое описание формата. Файл начинается с заголовка:

//+------------------------------------------------------------------+
//|                                                                  |
//+------------------------------------------------------------------+
struct TestHistoryHeader
  {
   int               version;            // 404
   char              copyright[64];      // copyright
   char              symbol[12];
   int               period;
   int               model;              // for what modeling type was the ticks sequence generated
   int               bars;               // amount of bars in history
   time_t            fromdate;           // ticks generated from this date
   time_t            todate;             // ticks generating stopped at this date
   double            modelquality;       // modeling quality
   //---- general parameters
   char              currency[12];       // currency base
   int               spread;
   int               digits;
   double            point;
   int               lot_min;            // minimum lot size
   int               lot_max;            // maximum lot size
   int               lot_step;
   int               stops_level;        // stops level value
   int               gtc_pendings;       // instruction to close pending orders at the end of day
   //---- profit calculation parameters
   double            contract_size;      // contract size
   double            tick_value;         // value of one tick
   double            tick_size;          // size of one tick
   int               profit_mode;        // profit calculation mode        { PROFIT_CALC_FOREX, PROFIT_CALC_CFD, PROFIT_CALC_FUTURES }
   //---- swap calculation
   int               swap_enable;        // enable swap
   int               swap_type;          // type of swap                   { SWAP_BY_POINTS, SWAP_BY_DOLLARS, SWAP_BY_INTEREST }
   double            swap_long;
   double            swap_short;         // swap overnight value
   int               swap_rollover3days; // three-days swap rollover
   //---- margin calculation
   int               leverage;           // leverage
   int               free_margin_mode;   // free margin calculation mode   { MARGIN_DONT_USE, MARGIN_USE_ALL, MARGIN_USE_PROFIT, MARGIN_USE_LOSS }
   int               margin_mode;        // margin calculation mode        { MARGIN_CALC_FOREX,MARGIN_CALC_CFD,MARGIN_CALC_FUTURES,MARGIN_CALC_CFDINDEX };
   int               margin_stopout;     // margin stopout level
   int               margin_stopout_mode;// stop out check mode            { MARGIN_TYPE_PERCENT, MARGIN_TYPE_CURRENCY }
   double            margin_initial;     // margin requirements
   double            margin_maintenance; // margin maintenance requirements
   double            margin_hedged;      // margin requirements for hedged positions
   double            margin_divider;     // margin divider
   char              margin_currency[12];// margin currency
   //---- commission calculation
   double            comm_base;          // basic commission
   int               comm_type;          // basic commission type          { COMM_TYPE_MONEY, COMM_TYPE_PIPS, COMM_TYPE_PERCENT }
   int               comm_lots;          // commission per lot or per deal { COMMISSION_PER_LOT, COMMISSION_PER_DEAL }
   //---- for internal use
   int               from_bar;           // fromdate bar number
   int               to_bar;             // todate bar number
   int               start_period[6];    // number of bar at which the smaller period modeling started
   int               set_from;           // begin date from tester settings
   int               set_to;             // end date from tester settings
   //----
   int               freeze_level;       // order's freeze level in points
   //----
   int               reserved[61];
  };

После этого идет массив сгенерированных баров:

#pragma pack(push,1)
struct TestHistory
  {
   time_t            otm;                // время бара
   double            open;               // значения OHLCV
   double            low;
   double            high;
   double            close;
   double            volume;
   time_t            ctm;                // текущее рабочее время внутри бара
   int               flag;               // флаг запуска эксперта (0-бар модифицируем, а эксперта не запускаем)
  };
#pragma pack(pop)


Автотрейдинг — Оптимизация экспертов

Оптимизация советников

Оптимизация представляет собой последовательные прогоны одного и того же советника с различными входными параметрами на одних и тех же данных. При этом можно подобрать такие параметры, при которых эффективность советника будет максимальной. Терминал обладает встроенными средствами, позволяющими автоматизировать этот процесс. Чтобы провести оптимизацию, необходимо выставить одноименный флажок в окне "Тестер" и нажать кнопку "Старт".


Оптимизация экспертов — Настройка

Настройка оптимизации советников

Оптимизация представляет собой последовательные прогоны одного и того же советника с различными входными параметрами на одних и тех же данных. При этом можно подобрать такие параметры, при которых эффективность советника будет максимальной. Терминал обладает встроенными средствами, позволяющими автоматизировать этот процесс. Прежде чем приступать к оптимизации параметров советника, необходимо произвести настройку. Это означает, что следует:

  • выбрать советника и задать его входные параметры

  • выбрать финансовый инструмент и его период

  • выбрать один из трех способов моделирования баров

  • задать временной диапазон для оптимизации (необязательно)

Для тестирования и оптимизации советников в терминале используется специальное окно "Тестер". Все вышеперечисленные настройки производятся во вкладке "Настройка" этого окна.

Советник и его параметры

В поле окна "Тестер — Советники" следует выбрать эксперт, параметры которого необходимо оптимизировать. В этом поле нельзя выбрать любой файл советника. Здесь могут быть лишь доступные в клиентском терминале файлы. Для этого они должны быть скомпилированными и находиться в папке /EXPERTS.

После того как выбран советник, необходимо провести дополнительную настройку и задать входные параметры. Это можно сделать нажатием кнопки "Свойства эксперта". При этом появится новое окно с тремя вкладками:

  • Тестирование — в этой вкладке задаются общие параметры оптимизации. К ним относятся объем и валюта начального депозита, которые указываются в одноименных полях. Именно этим депозитом будет оперировать советник во время оптимизации. В этой вкладке также выбираются типы открываемых позиций: Only Long — открывать только длинные позиции; Only Short — только короткие; Long and Short — открывать позиции в обе стороны. Каков бы ни был алгоритм советника, он будет открывать позиции только в заданных направлениях. Также можно включить генетический алгоритм оптимизации и выбрать оптимизируемый параметр (максимизация по значению баланса, фактора прибыльности, математического ожидания выигрыша либо минимизация по значению максимальной просадки или процента просадки);

  • Входные параметры — здесь в виде таблицы приводится список всех входных параметров. Входными параметрами называются переменные, которые влияют на работу эксперта и могут быть изменены прямо из клиентского терминала. Для изменения этих параметров нет необходимости изменять код эксперта. Количество входных переменных может варьироваться от эксперта к эксперту. При оптимизации входные параметры советника задаются в полях "Старт", "Шаг" и "Стоп". В этих полях задаются начальные значения, шаг изменения и конечные значения внешних переменных соответственно. Слева от названия переменных имеются галочки, включающие параметр в оптимизацию. Если переменная не отмечена галочкой, она не участвует в оптимизации. Ее значение в процессе оптимизации не изменяется, и используется параметр, записанный в поле "Значение". Количество прогонов эксперта напрямую зависит от этих параметров. Данные, записываемые в поле "Значение", не влияют на оптимизацию советника и необходимы лишь для его тестирования.

    Существует возможность загрузить уже сохраненный набор входных параметров (включая значения "Старт", "Шаг" и "Стоп"). Это можно сделать, нажав кнопку "Загрузить" и выбрав предварительно сохраненный набор параметров. Сохранить текущий набор внешних переменных можно при помощи одноименной кнопки.

  • Оптимизация — эта вкладка позволяет управлять ограничениями во время оптимизации. Если в процессе отдельного прогона будет достигнуто любое из условий, этот прогон советника прервется. К ограничивающим параметрам относятся:

    1. Минимальный баланс — минимальное значение баланса в валюте депозита;

    2. Максимальная прибыль — максимальная прибыль в валюте депозита;

    3. Минимальный уровень маржи % — минимальный уровень маржи в процентах;

    4. Максимальная просадка % — максимальная просадка в процентах;

    5. Непрерывный убыток — максимальный суммарный убыток в одной серии. Убыточной серией называются несколько следующих подряд убыточных сделок;

    6. Непрерывное количество убыточных сделок — максимальное количество убыточных сделок в одной серии;

    7. Непрерывный выигрыш — максимальная суммарная прибыль в одной серии. Прибыльной серией называются несколько следующих подряд прибыльных сделок;

    8. Непрерывное количество прибыльных сделок — максимальное количество прибыльных сделок в одной серии.

    Чтобы включить ограничивающее условие, необходимо выставить соответствующий флажок слева от него. Двойным кликом левой кнопки мыши в поле "Значение" можно изменить имеющийся параметр.

Финансовый инструмент и его период

Чтобы приступить к тестированию, недостаточно лишь выбрать советника и настроить его. Необходимо также выбрать финансовый инструмент и период (таймфрейм) для тестирований. Все тестирования будут проходить именно на этих данных. При тестированиях можно выбрать один из доступных в терминале инструментов или использовать внешний файл данных. В тестированиях используются файлы исторических данных формата *.FXT, которые записываются в директории /TESTER. Эти файлы автоматически создаются при тестированиях, если был выбран имеющийся в терминале инструмент.

Финансовый инструмент задается в поле "Символ", а таймфрейм — в поле "Период". Если файла данных по этому инструменту, периоду и методу моделирования не существует, он будет создан автоматически. При отсутствии исторических данных по инструменту и периоду, тестер автоматически скачает 512 последних баров истории.

Внимание: если по инструменту имеются какие-либо данные за пределами последних 512 баров, произойдет автоматическое скачивание исторических данных до самого последнего имеющегося бара. Это может вызвать резкое увеличение входящего трафика.

Методы моделирования

Исторические данные в терминале сохраняются только как бары и представляют собой записи в виде OHLC. Эти данные могут использоваться для моделирования динамики цен при оптимизации советников. В некоторых случаях для тестирования/оптимизации такой информации бывает недостаточно. Например, на дневных данных колебания цен внутри бара могут привести к срабатыванию советника. В то же время при оптимизации срабатывания может не произойти. Иными словами, оптимизация советника на основе одних только баров иногда бывает неточной и может давать ложное представление об эффективности эксперта с выбранными параметрами.

Терминал позволяет оптимизировать советники с использованием различных методов моделирования исторических данных. При этом динамика цен эмулируется более точно. За счет использования исторических данных более мелких периодов можно представлять колебания цен внутри баров. Например, при оптимизации советника на часовых данных, динамику цен внутри бара можно смоделировать на основе минутных данных. Таким образом, моделирование существенно приближает исторические данные к реальным колебаниям цен и делает оптимизацию советников более достоверной.

При настройке оптимизации можно выбрать один из трех методов моделирования исторических данных:

  • По ценам открытия (быстрый метод на сформировавшихся барах)
    Некоторые механические торговые системы не зависят от особенностей внутрибарного моделирования, они торгуют на сформировавшихся барах. То, что текущий ценовой бар полностью сформировался, можно узнать по появлению следующего. Именно для таких экспертов предназначен этот режим моделирования.

    В этом режиме сначала моделируется открытие бара (Open = High = Low = Close, Volume=1), что дает эксперту возможность точно идентифицировать окончание формирования предыдущего ценового бара. Именно на этом зарождающемся баре запускается тестирование эксперта. На следующем шаге выдается уже полностью сформированный текущий бар, но на нем тестирование не производится!

  • Контрольные точки (используется ближайший таймфрейм + фрактальная интерполяция)
    Метод моделирования контрольных точек предназначен для грубой оценки экспертов, торгующих внутри бара. Для этого метода необходимо наличие исторических данных ближайшего меньшего периода (таймфрейма). В большинстве случаев имеющиеся данные меньшего таймфрейма не полностью покрывают временной диапазон тестируемого таймфрейма. При отсутствии данных меньшего таймфрейма развитие бара генерируется на основе цен закрытия 12 предыдущих баров. То есть, движение внутри бара повторяет движение цены за последние 12 периодов. Это и есть фрактальная интерполяция.

    Как только появляются исторические данные меньшего таймфрейма, фрактальная интерполяция применяется уже к этим данным. Однако используется уже не 12, а всего 6 предыдущих баров. То есть воспроизводятся реально существующие цены Open, High, Low, Close плюс ещё две сгенерированных цены. Значение и местоположение этих двух сгенерированных цен зависит от движения цены на 6 предыдущих барах.

  • Все тики (на основе всех наименьших доступных периодов с фрактальной интерполяцией каждого тика)
    Этот режим позволяет наиболее точно смоделировать движение цены внутри бара. В отличие от "контрольных точек", потиковый метод использует для генерации данные не только ближайшего меньшего таймфрейма, но и всех доступных меньших таймфреймов. При этом, если для какого-то временного диапазона одновременно существуют данные более одного таймфрейма, то для генерации используются данные самого меньшего таймфрейма. Так же, как и в предыдущем методе, фрактально генерируются контрольные точки. Для генерации движения цены между контрольными точками также используется фрактальная интерполяция. Возможна ситуация, когда генерируется несколько одинаковых тиков подряд. В этом случае дублирующиеся котировки фильтруются, и фиксируется объем последней из таких котировок.

    Необходимо учитывать очень большой возможный объем сгенерированных потиковых данных. Это может сказаться на потребляемых ресурсах операционной системы и на скорости тестирования.

    Внимание:
    • не рекомендуется запускать потиковое тестирование при отсутствии более мелких таймфреймов, полностью покрывающих исследуемый период, иначе тестирование будет неточным;
    • моделирование по контрольным точкам в основном используется при оптимизации советников, а моделирование всех тиков — для тщательного тестирования.

Временной диапазон

Диапазон дат позволяет тестировать советники не на всех имеющихся данных, а лишь на выбранном временном отрезке. Это бывает удобным при необходимости исследовать отдельную часть исторических данных. Ограничение диапазона дат можно использовать не только при тестировании эксперта, но и при генерации тестирующей последовательности баров (файла смоделированных данных, используемого для тестирования). Очень часто нет необходимости генерировать данные всей истории, особенно при потиковом моделировании, когда объем неиспользуемых данных может быть очень большим. Поэтому если при первоначальной генерации тестирующей последовательности была включена возможность использования диапазона дат, то бары, выходящие за пределы указанного диапазона, не генерируются, а просто переписываются в выходную последовательность. Данные не исключаются из последовательности, чтобы оставалась возможность правильно посчитать индикаторы на всей полученной истории. Необходимо заметить, что первые 100 баров также не генерируются. Это ограничение не зависит от установленного диапазона дат.

Чтобы включить ограничение по датам, необходимо выставить флажок "Использование дат" и указать требуемые значения в полях "От" и "До". После того как произведены все настройки, можно нажать кнопку "Старт" и начать тестирование. После начала тестирования в нижней части окна можно просмотреть ориентировочное время завершения этого процесса.

Внимание:
  • если не выставлен флажок "Оптимизация", по нажатии кнопки "Старт" вместо оптимизации будет производиться тестирование советника;
  • при оптимизации, как и при тестировании, можно использовать собственные файлы истории.


Оптимизация экспертов — Результаты

Результаты оптимизации

После завершения оптимизации можно просмотреть ее результаты во вкладках "Результаты оптимизации" и "График оптимизации".

Результаты

В отличие от тестирования, оптимизация предполагает многократные прогоны механической торговой системы (МТС) с разными входными параметрами. Это делается с целью определения параметров советника, при которых его прибыльность будет максимальна. Чтобы провести оптимизацию, необходимо выставить одноименный флажок во вкладке настроек тестирования и нажать кнопку "Старт". После этого в окне появятся две новых вкладки: "Результаты оптимизации" и "График оптимизации".

Во вкладке "Результаты оптимизации", в отличие от результатов тестирования, публикуется не список всех операций, а окончательные отчеты каждого из прогонов. Вся информация представлена в виде таблицы с полями:

  • Проход — номер прогона;

  • Прибыль — чистая прибыль (валовая прибыль за вычетом валовых убытков);

  • Всего сделок — общее количество открытых торговых позиций;

  • Прибыльность — отношение общей прибыли к общему убытку в процентах. Единица означает, что сумма прибыли равна сумме убытков;

  • Матожидание выигрыша — математическое ожидание выигрыша. Этот статистически расчитываемый показатель отражает среднюю прибыльность/убыточность одной сделки. Также можно считать, что он отражает предполагаемую прибыльность/убыточность следующей сделки;

  • Просадка $ — максимальная просадка относительно начального депозита, в валюте депозита;

  • Просадка % — максимальная просадка относительно начального депозита, в процентах;

  • Входные параметы — изменяемые значения входных переменных при каждом прогоне.

Кликнув левой кнопкой мыши на заголовке любого столбца, можно отсортировать все записи в таблице по убыванию или по возрастанию. При выполнении команды контекстного меню "Установить входные параметры" в качестве базовых входных переменных эксперта (окно свойств эксперта, вкладка "Входные параметры") записываются данные выбранного прогона. При этом происходят переключение во вкладку "Настройка" и отключение режима оптимизации. Нажав кнопку "Старт", можно приступить к тестированию советника с выбранными входными переменными. Двойным кликом левой кнопки мыши на строке прогона во вкладке результатов оптимизации можно выполнить то же действие. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать выделенные строки результатов в буфер обмена для дальнейшего использования в других приложениях. Если не выбрано ни одной строки, то в буфер обмена скопируется вся таблица. Также, чтобы скопировать всю таблицу в буфер обмена, можно выполнить команду "Копировать все". Отчет о результатах оптимизации можно также сохранить в HTML-формате на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как отчет". Другие команды контекстного меню позволяют настраивать отображение результатов:

  • Пропустить бесполезные результаты — показать/скрыть результаты убыточных прогонов;

  • Показать входные параметры — показать/скрыть колонку "Входные параметры";

  • Авторазмер столбцов — установить размер столбцов автоматически при изменении размера окна.
    То же действие можно выполнить нажатием клавиши A;

  • Сетка — показать/скрыть сетку для разделения колонок.
    Те же действия можно выполнить, нажав клавишу G.

График

Во вкладке "График Оптимизации" автоматически рисуется график прибыли всех прогонов. График позволяет наглядно оценить прибыльность использования различных комбинаций входных параметров. В нижней части графика также приводится график, отражающий количество прибыльных (зеленый цвет) и убыточных (красный цвет) сделок при каждом прогоне.

Двойной клик левой кнопкой мыши на любой точке графика производит переключение во вкладку "Результаты" и выбирает соответствующий прогон. При помощи команды контекстного меню "Копировать" или клавиш-акселераторов Ctrl+C можно скопировать изображение графика в буфер обмена для дальнейшего использования в других приложениях. График можно также сохранить в виде GIF-файла на жестком диске. Для этого необходимо выполнить команду контекстного меню "Сохранить как рисунок" или нажать клавиши-акселераторы Ctrl+S.


Автотрейдинг — Пользовательские индикаторы

Пользовательские индикаторы

Пользовательским индикатором называется программа, самостоятельно разработанная пользователем на языке MetaQuotes Language 4 и выполняющая функцию технического индикатора. Техническим индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. Использование индикаторов позволяет ответить на вопросы о том, сохранится ли текущая тенденция и где произойдет разворот тренда. Индикаторы предназначены для того, чтобы сделать сложный процесс принятия торговых решения относительно простым и понятным. На основе алгоритмов индикаторов строятся торговые тактики и разрабатываются советники.

Внимание: пользовательские индикаторы предназначены только для анализа динамики цен финансовых инструментов, но не для совершения торговых операций.

Работа с пользовательскими индикаторами предполагает:

  • Создание индикатора
    Для создания и компиляции пользовательского индикатора используется встроенный редактор "MetaEditor". Он является составной частью клиентского терминала и представляет собой удобную среду разработки MQL4-программ.

  • Настройка работы индикатора
    Перед началом использования пользовательских индикаторов необходимо произвести их предварительную настройку. Общие для всех индикаторов параметры работы задаются в окне настройки клиентского терминала. Кроме того, каждый индикатор обладает своими собственными настройками.

  • Наложение индикатора
    При наложении индикатора на график просчитываются его параметры и осуществляется его отрисовка.

  • Удаление индикатора
    Если индикатор больше не нужен, его можно удалить с графика.


Пользовательские индикаторы — Создание

Создание пользовательских индикаторов

Для создания пользовательских индикаторов используются язык программирования торговых стратегий MetaQuotes Language 4 (MQL 4) и редактор редактор MetaEditor. Чтобы запустить редактор советников, необходимо выполнить команду "Создать" контекстного меню окна "Навигатор — Пользовательские индикаторы", команду меню "Сервис — Редактор MetaQuotes Language", нажать клавишу F4 или кнопку Редактор MetaEditor панели "Стандартная". При создании MQL4-программы автоматически откроется мастер создания советников, позволяющий быстро создавать новые MQL4-программы. В нем в качестве типа создаваемого объекта необходимо указать "Пользовательский индикатор" и заполнить поля требуемыми данными:

  • Имя — название индикатора;

  • Автор — имя автора;

  • Ссылка — адрес сайта разработчика;

  • Параметры — список входных параметров индикатора. Чтобы добавить новый параметр, необходимо нажать кнопку "Добавить", чтобы удалить — кнопку "Удалить".

Затем нужно определить, будет ли новый индикатор создаваться в отдельном подокне и какие у него будут границы. Кроме того, необходимо задать количество и параметры индикаторных массивов. Значения элементов индикаторных массивов используются для отображения на графике линий. Иными словами, при определении индикаторных массивов происходит определение линий будущего индикатора. После этого в редакторе открывается окно нового индикатора с заданными параметрами. Файл с исходным текстом (*.MQ4) индикатора автоматически помещается в папку /EXPERTS/INDICATORS клиентского терминала. С этого момента можно приступать к написанию текста пользовательского индикатора.

По завершении разработки необходимо скомпилировать индикатор. Для этого в редакторе советников следует выполнить команду меню "Файл — Компилировать", нажать клавишу F9 или кнопку Компилировать панели инструментов. В результате успешной компиляции создается исполняемый файл программы с расширением *.EX4, автоматически помещаемый в папку /EXPERTS/INDICATORS. Список пользовательских индикаторов можно просмотреть в окне "Навигатор — Пользовательские индикаторы" клиентского терминала.

Редактирование пользовательских индикаторов

Чтобы приступить к редактированию уже существующего индикатора из терминала, необходимо выполнить команду "Изменить" контекстного меню окна "Навигатор — Пользовательские индикаторы". При этом откроется редактор MetaEditor, в который уже будет загружен исходный код выбранного индикатора. После изменения исходного кода аналитического инструмента необходимо повторно скомпилировать его и получить новый исполняемый EX4-файл. В противном случае в терминале будет использоваться неизмененная, предыдущая версия индикатора.

Внимание: если индикатор скомпилирован с ошибками, его наложить нельзя. При этом окно свойств индикатора не появится, а в журнале экспертов появится запись о невозможности открыть файл с исполняемым кодом.


Пользовательские индикаторы — Настройка

Настройка пользовательских индикаторов

Перед началом использования индикаторов необходимо произвести их предварительную настройку. Общие для всех пользовательских индикаторов (и экспертов) параметры работы задаются в окне настройки клиентского терминала. Это окно можно открыть командой меню "Сервис — Настройки" или при помощи клавиш-акселераторов Ctrl+O. Для настройки параметров работы индикаторов необходимо выбрать вкладку "Советники". На работу пользовательских индикаторов оказывают влияние только две опции:

  • Разрешить импорт DLL
    Для расширения функциональности пользовательские индикаторы могут использовать DLL-библиотеки. Выставив этот флажок, можно использовать такие библиотеки без каких-либо ограничений. Если эта опция отключена, ни одна MQL4-программа не сможет воспользоваться внешними DLL-библиотеками.

  • Разрешить импорт внешних экспертов
    Если при работе индикатора требуется экспортировать функции из других экспертов или MQL4-библиотек, необходимо включить эту опцию. Если она отключена, ни один из запущенных индикаторов не сможет запрашивать функции из других MQL4-программ.


Пользовательские индикаторы — Наложение на график

Наложение пользовательских индикаторов на график

После настройки общих параметров пользовательские индикаторы можно накладывать на график. Двойным кликом левой кнопкой мыши на выбранном индикаторе в окне "Навигатор — Пользовательские индикаторы" или выполнением команды контекстного меню "Присоединить к графику" можно наложить индикатор на активный график. Более того, при помощи технологии "Drag'n'Drop" можно наложить аналитический инструмент на любой график. При этом автоматически появится окно настройки с несколькими вкладками:

  • Общие
    Во вкладке "Общие" можно управлять импортом из библиотек DLL и MQL4. Кроме того, если индикатор строится в отдельном подокне, отсюда можно задать его границы. Для этого необходимо выставить соответствующие флажки и записать требуемые значения в полях.

  • Входные параметры
    Во вкладке "Входные параметры" сгруппированы внешние переменные, которыми можно управлять прямо из терминала. Чтобы изменить требуемую переменную, необходимо дважды щелкнуть по ее значению в таблице и записать новое.

  • Цвета
    Вкладка "Цвета" предназначена для управления выводимыми на экран элементами индикатора. Кроме цветов, можно изменять ширину и стиль линий.

  • Уровни
    Из вкладки "Уровни" в окне индикатора можно выставлять горизонтальные линии на любом уровне. Чтобы создать новый уровень, необходимо нажать кнопку "Добавить", а чтобы удалить — одноименную кнопку. Также здесь можно изменять цвет, толщину и стиль уровней.

    Внимание: для индикаторов, строящихся непосредственно на графике цен, эта вкладка недоступна.

  • Отображение
    Во вкладке "Отображение" можно ограничить использование индикатора по таймфреймам. Это бывает полезно, если индикатор для разных периодов должен иметь разные настройки. Можно, например, наложить две копии одного индикатора с разными настройками на один график и ограничить их использование по таймфреймам: на более мелких периодах будет работать первый индикатор, а на больших таймфреймах — второй. Опция "Показывать в Окне Данных" позволяет скрывать/показывать информацию о данном индикаторе в одноименном окне.

Сразу после этого начинаются пересчет значений индикатора и его отрисовка на графике. Пользовательские индикаторы, как и технические, могут строиться в создаваемом отдельном окне индикатора с собственной вертикальной шкалой (например, MACD) или накладываться прямо на график цен (например, Moving Average).


Пользовательские индикаторы — Удаление

Удаление пользовательского индикатора с графика

Чтобы завершить работу индикатора, необходимо удалить его с графика. При этом прекращаются пересчет его значений и отрисовка индикатора. Для удаления индикатора с графика следует выполнить команду его контекстного меню "Удалить", "Удалить окно индикатора" или команду контекстного меню графика "Список индикаторов — Удалить".

Внимание: удаление пользовательского индикатора из окна "Навигатор" не завершает работу одноименного, наложенного на график аналитического инструмента.


Автотрейдинг — Скрипты

Скрипты

Скриптом называется программа, написанная на языке MetaQuotes Language 4 (MQL 4) и предназначенная для одноразового выполнения любых действий. Скрипт может выполнять как аналитические, так и торговые функции. В отличие от советников, скрипты исполняются по запросу, а не потиково. Иными словами, если советник работает практически постоянно, то скрипт, отработав один раз, самостоятельно завершает работу.

Работа со скриптами предполагает:

  • Создание скрипта
    Для создания и компиляции скрипта используется встроенный редактор "MetaEditor". Он является составной частью клиентского терминала и представляет собой удобную среду разработки MQL4-программ.

  • Настройка работы скриптов
    Перед началом использования скриптов необходимо произвести их предварительную настройку. Общие для всех скриптов параметры работы задаются в окне настройки клиентского терминала. Кроме того, каждый скрипт обладает своими собственными настройками.

  • Запуск скрипта
    Для запуска скрипта необходимо наложить его на график. Сразу после этого запускается алгоритм скрипта.

  • Удаление скрипта
    Завершение работы скрипта происходит, когда он удаляется с графика.


Скрипты — Создание

Создание скриптов

Для создания скриптов используются язык программирования торговых стратегий MetaQuotes Language 4 (MQL 4) и редактор MetaEditor. Чтобы запустить редактор советников, необходимо выполнить команду "Создать" контекстного меню окна "Навигатор — Скрипты", команду меню "Сервис — Редактор MetaQuotes Language", нажать клавишу F4 или кнопку Редактор MetaEditor панели "Стандартная". При создании MQL4-программы автоматически откроется мастер создания советников, позволяющий быстро создавать новые MQL4-программы. В нем в качестве типа создаваемого объекта необходимо указать "Скрипт" и заполнить поля требуемыми данными:

  • Имя — название скрипта;

  • Автор — имя автора;

  • Ссылка — адрес сайта разработчика.

После этого в редакторе открывается окно нового скрипта. Файл с исходным текстом (*.MQ4) скрипта автоматически помещается в папку /EXPERTS/SCRIPTS клиентского терминала. С этого момента можно приступать к написанию исходного текста программы.

По завершении разработки необходимо скомпилировать скрипт. Для этого в редакторе советников необходимо выполнить команду меню "Файл — Компилировать", нажать клавишу F5 или кнопку Компилировать панели инструментов. В результате успешной компиляции создается исполняемый файл программы с расширением *.EX4, автоматически помещаемый в папку /EXPERTS/SCRIPTS. Список всех скриптов можно просмотреть в окне "Навигатор — Скрипты" клиентского терминала.

Редактирование скриптов

Чтобы приступить к редактированию уже существующего скрипта из терминала, необходимо выполнить команду "Изменить" контекстного меню окна "Навигатор — Скрипты". При этом откроется редактор советников, в который уже будет загружен исходный текст выбранного скрипта. После изменения исходного кода необходимо повторно скомпилировать его и получить новый исполняемый EX4-файл. В противном случае в терминале будет использоваться неизмененная, предыдущая версия MQL4-программы.


Скрипты — Настройка

Настройка работы скриптов

Перед началом использования скриптов необходимо произвести их предварительную настройку. Общие для всех скриптов параметры работы задаются в окне настройки клиентского терминала. Это окно можно открыть командой меню "Сервис — Настройки" или при помощи клавиш-акселераторов Ctrl+O. Для настройки параметров работы скриптов необходимо выбрать вкладку "Советники". На работу скриптов оказывают влияние только пять опций:

  • Разрешить советнику торговать
    Скрипты, как и советники, способны работать в автоматическом режиме. Они могут как анализировать динамику цен, так и вести торговую деятельность. Эта опция предназначена для ограничения торговых функций скриптов и экспертов.

  • Ручное подтверждение
    Опция "Ручное подтверждение" активируется только в том случае, если скриптам разрешено торговать. Если эта опция включена, и скрипт пытается провести торговую операцию, можно будет либо подтвердить ее, либо прервать вручную. Иными словами, при помощи ручного подтверждения можно контролировать торговую активность скриптов и экспертов.

  • Разрешить импорт DLL
    Для расширения функциональности скрипты могут использовать DLL-библиотеки. Выставив этот флажок, можно использовать такие библиотеки без каких-либо ограничений. Если эта опция отключена, ни один скрипт не сможет воспользоваться внешними DLL-библиотеками.

  • Подтверждать вызов функций DLL
    Эта опция активируется только в том случае, если был разрешен импорт из DLL-библиотек. Она позволяет контролировать выполнение каждой вызываемой функции вручную. Если флажок не установлен, импорт из внешних библиотек контролироваться не будет.

  • Разрешить импорт внешних экспертов
    Если при работе скрипта требуется экспортировать функций из других экспертов или библиотек MQL4, необходимо включить эту опцию. Если она отключена, ни один скрипт не сможет запрашивать функции из других MQL4-программ.


Скрипты — Запуск

Запуск скриптов

После настройки общих параметров, скрипт можно запускать. Для этого достаточно лишь присоединить его к графику. При этом, если в исходном тексте программы есть директива "#property show_inputs", автоматически появится окно настройки скрипта. Во вкладке "Общие" этого окна можно:

  • Позиции — выбрать направление открытия позиций:

    1. Long&Short — в обе стороны;

    2. Only Long — только на покупку;

    3. Only Short — только на продажу.

  • Разрешить сигналы — разрешить/запретить скрипту подавать сигналы;

  • Не повторять сигнал — запретить подачу сигналов о событиях после поступления первого сигнала;

  • Разрешить советнику торговать — разрешить/запретить проведение торговых операция в реальном времени;

  • Ручное подтверждение — запрашивать подтверждение на открытие позиции при проведении торговых операций;

  • Разрешить импорт DLL — разрешить/запретить импорт функций из DLL-файлов;

  • Подтверждать импорт функций DLL — запрашивать подтверждения при каждом вызове функций из DLL-файлов;

  • Разрешить импорт внешних экспертов — разрешить/запретить вызов функций из внешних экспертов.

Во вкладке "Входные параметры" можно изменить внешние переменные скрипта. К ним относятся переменные класса extern. Чтобы изменить параметр, необходимо дважды кликнуть левой кнопкой мыши на его значении и записать новое. При этом можно изменять значение каждой переменной или загрузить уже сохраненный набор входных параметров (кнопка "Загрузить"). Сохранить текущий набор внешних переменных можно при помощи одноименной кнопки.

Кнопка "Сброс" возвращает все настройки по умолчанию. Во вкладке "Общие" выставляются заданные в настройках терминала параметры. А в качестве входных переменных выставляются параметры, указаные в исходном тексте программы. Чтобы подтвердить запуск скрипта с заданными парметрами, необходимо нажать кнопку "ОК". А отменить запуск скрипта можно, нажав одноименную кнопку.

Внимание: в отличие от советников и пользовательских индикаторов, индивидуальные свойства скрипта задаются только при его запуске.

Сразу после этого скрипт начнет исполнятся. Двойной клик левой кнопкой мыши на выбранном скрипте в окне "Навигатор — Скрипты" или команда "Присоединить к графику" контекстного меню позволяют наложить скрипт на активный график. Более того, при помощи технологии "Drag'n'Drop" можно наложить скрипт на любой график. Свидетельством работы скрипта можно считать появление в контекстном меню графика команды "Удалить скрипт", которая бывает активной только во время работы этой MQL4-программы.

Внимание: к одному графику можно присоединить только один скрипт.


Скрипты — Завершение работы

Завершение работы скриптов

Обычно скрипт завершает работу сам. Но его можно удалить вручную. При этом выполняется деинициализация скрипта, и происходит выгрузка его из памяти. Для удаления скрипта с графика необходимо выполнить команду контекстного меню графика "Удалить скрипт" либо присоединить к графику другой скрипт. Кроме того, скрипт удаляется с графика при смене символа или таймфрейма.

Внимание:
  • при выключении клиентского терминала происходит завершение работы всех работающих скриптов;
  • удаление скрипта из окна "Навигатор" не завершает работу одноименной наложенной на график MQL4-программы.


Сервис — Конфигурация при старте

Конфигурация при старте

Клиентский терминал может быть запущен с предопределёнными настройками. Для этого в качестве параметра клиентскому терминалу передаётся имя конфигурационного файла.

Например:

  terminal.exe config\start.ini
  terminal.exe test1.txt
  terminal.exe "C:\Program Files\MetaTrader 4\config\settings25.ini"

Если не указан полный путь к файлу (Drive:\SubDirectory\FileName), то поиск файла будет осуществляться в директории клиентского терминала. Конфигурационный файл содержит строки следующего вида:
[Параметр] = [Значение]

Комментарии начинаются с символа "точка с запятой" (;) и не обрабатываются.

Параметры конфигурационного файла можно разделить на несколько групп: общие настройки, настройки прокси-сервера (вкладка "Сервер" в таблице настроек терминала), настройки FTP (вкладка "Публикация" в таблице настроек терминала), настройки экспертов (вкладка "Советники" в таблице настроек терминала), настройки однократного запуска эксперта или скрипта, настройки запуска тестера стратегий.

Общие настройки

  • Profile - имя поддиректории в директории profiles. В клиентском терминале будут открыты графики в соответствии с указанным профилем. Если данный параметр не указан, то будет открыт текущий профиль.

  • MarketWatch - имя файла (каталог \symbolsets), в котором содержится список инструментов для отображения в окне обзора рынка. Такой файл может получить при помощи команды контекстного меню окна "Обзор Рынка - Набор символов - Сохранить как".

  • Login - номер счета, к которому нужно подключиться при запуске. Если данный параметр отсутствует, то будет использован текущий логин.

  • Password - пароль для входа в систему. Этот параметр будет проигнорирован, если клиентский терминал хранит личные данные на диске и подключаемый номер счета содержится в списке.

  • Server - имя торгового сервера, к которому должно быть произведено подключение. Имя сервера совпадает с именем соответствующего srv-файла, хранящемся в директории config. Этот параметр будет проигнорирован, если информация о подключаемом аккаунте сохранена на диске.

  • AutoConfiguration - "true" или "false" в зависимости от того, должна ли быть включена настройка автоконфигурации. Если данный параметр отсутствует, то будет использовано значение из текущих настроек сервера.

  • DataServer - адрес датацентра. При включенной автоконфигурации сервера эта запись может быть проигнорированна. Если данный параметр отсутствует, то будет использовано значение из текущих настроек сервера.

  • EnableDDE - "true" или "false" в зависимости от того, должен ли быть включен DDE-сервер. Если данный параметр отсутствует, то будет использовано значение из текущих настроек сервера.

  • EnableNews - "true" или "false" в зависимости от того, должен ли быть разрешен прием новостей или нет. Если данный параметр отсутствует, то будет использовано значение из текущих настроек сервера.

Пример:

  ; common settings
  Profile=test 3
  MarketWatch=set2.set
  Login=12345
  Password=xxxxxx
  Server=MetaQuotes-demo
  AutoConfiguration=false
  DataServer=192.168.0.1:443
  EnableDDE=true
  EnableNews=false

Настройки прокси-сервера

  • ProxyEnable - "true" или "false" в зависимости от того, должен ли использоваться прокси-сервер для связи с торговым сервером.

  • ProxyServer - адрес прокси-сервера.

  • ProxyType - тип прокси-сервера. Может принимать значения "HTTP", "SOCKS4" или "SOCKS5".

  • ProxyLogin - логин для авторизации на прокси-сервере.

  • ProxyPassword - пароль для доступа на прокси-сервер.

Если какой-либо из перечисленных параметров отсутствует, то используются текущие настройки клиентского терминала (настройки прокси во вкладке "Сервер" в таблице настроек клиентского терминала).

Пример:

  ; proxy settings
  ProxyEnable=true
  ProxyServer=proxy.company.com:3128
  ProxyType=HTTP
  ProxyLogin=user45
  ProxyPassword=xxx

Настройки FTP

  • FTPEnable - разрешить/запретить публикации. Принимаемые значения "true" или "false".

  • FTPPassiveMode - включить/выключить пассивный режим передачи данных. Принимаемые значения "true" или "false".

  • FTPAccount - номер счета, данные о состоянии которого должны отсылаться на FTP.

  • FTPServer - адрес FTP-сервера.

  • FTPLogin - логин для авторизации на FTP-сервере.

  • FTPPassword - пароль для доступа на FTP-сервер.

  • FTPPath - имя каталога на FTP-сервере, в который помещается отчет.

  • FTPPeriod - периодичность отправки отчета на FTP-сервер в минутах.

Если какой-либо из перечисленных параметров отсутствует, то используются текущие настройки клиентского терминала (вкладка "Публикация" в таблице настроек терминала).

Пример:

  ; ftp settings
  FTPEnable=true
  FTPPassiveMode=false
  FTPAccount=12345
  FTPServer=ftp.company.com
  FTPLogin=admin
  FTPPassword=pAssWOrd123
  FTPPath=/inetpub
  FTPPeriod=10

Настройки экспертов

  • ExpertsEnable - включить/выключить экспертов.

  • ExpertsDllImport - разрешить/запретить импорт DLL.

  • ExpertsDllConfirm - включить/выключить ручное подтверждение вызова DLL-функций.

  • ExpertsExpImport - разрешить/запретить импорт функций из внешних экспертов или MQL4-библиотек.

  • ExpertsTrades - разрешить/запретить советникам торговать.

  • ExpertsTradesConfirm - включить/выключить ручное подтверждение совершения советником торговых операций.

Внимание: все параметры группы экспертов могут принимать значения только "true" или "false".

Если какой-либо из перечисленных параметров отсутствует, то используются текущие настройки клиентского терминала (вкладка "Советники" в таблице настроек терминала).

Пример:

  ; experts settings
  ExpertsEnable=true
  ExpertsDllImport=true
  ExpertsDllConfirm=true
  ExpertsExpImport=true
  ExpertsTrades=true
  ExpertsTradesConfirm=false

Настройки однократного запуска эксперта и/или скрипта

  • Symbol - название инструмента, график которого должен быть открыт сразу после старта терминала. После закрытия клиентского терминала информация об этом дополнительном графике не сохраняется. При повторном запуске терминала, без конфигурационного файла, этот график открыт не будет. Если данный параметр отсутствует, то никакой дополнительный график не открывается.

  • Period - период графика (M1, M5, M15, M30, H1, H4, D1, W1, MN). При отсутствии данного параметра используется H1.

  • Template - имя файла шаблона (каталог \templates), который должен быть применен к графику.

  • Expert - имя эксперта, который должен быть запущен после старта клиентского терминала. Эксперт запускается на графике, который открыт в соответствии с параметрами Symbol и Period. Если параметр Symbol отсутствует, то никакой дополнительный график не открывается, а эксперт запускается на первом графике текущего профайла. Если в текущем профайле нет графиков, то эксперт не будет запущен. Если этот параметр отсутствует, то никакой эксперт также не запускается.

  • ExpertParameters - имя файла с параметрами советника (каталог \experts\presets). Такой файл можно создать в окне свойств эксперта, нажав кнопку "Входные параметры - Сохранить". Обычно используется для хранения параметров, отличающихся от умолчательных. При отсутствии этого параметра используются параметры по умолчанию.

  • Script - имя скрипта, который должен быть запущен после старта клиентского терминала. Скрипт запускается по тем же правилам, что и эксперт (описано выше).

  • ScriptParameters - имя файла с параметрами скрипта (каталог \experts\presets). Этот файл формируется точно так же, как и для эксперта.

Пример:

  ; open chart and run expert and/or script
  Symbol=EURUSD
  Period=H4
  Template=popular.tpl
  Expert=MACD Sample
  ExpertParameters=macd.set
  Script=period_converter
  ScriptParameters=

Настройки запуска тестера стратегий

  • TestExpert - имя эксперта, который должен быть запущен на тестирование. Если этот параметр отсутствует, то никакое тестирование не запускается.

  • TestExpertParameters - имя файла с параметрами (каталог \tester). Такой файл можно создать в окне свойств тестируемого эксперта, нажав кнопку "Входные параметры - Сохранить" Обычно используется для хранения параметров, отличающихся от умолчательных. Другие параметры тестируемого эксперта из вкладок "Тестирование" и "Оптимизация" (а также из вкладки "Входные параметры" в случае отсутствия данного параметра) заполняются значениями, сохраненными автоматически в файле \tester\[имя эксперта].ini после последнего тестирования.

  • TestSymbol - название инструмента, на данных которого должно производиться тестирование эксперта. В случае отсутствия этого параметра используется последнее использованное в тестере значение.

  • TestPeriod - период графика (M1, M5, M15, M30, H1, H4, D1, W1, MN). При отсутствии данного параметра используется H1.

  • TestModel - 0, 1 или 2 в зависимости от модели тестирования (Все тики, Контрольные точки, По ценам открытия). В случае отсутствия этого параметра используется значение 0 (Все тики).

  • TestOptimization - включить/выключить оптимизация. Принимаемые значения "true" или "false". В случае отсутствия этого параметра используется значение "false".

  • TestDateEnable - включить/выключить опцию "Использовать даты". Принимаемые значения "true" или "false". В случае отсутствия этого параметра используется значение "false".

  • TestFromDate - дата начала диапазона тестирования в виде YYYY.MM.DD. В случае отсутствия этого параметра подразумевается 1970.01.01.

  • TestToDate - дата конца диапазона тестирования в виде YYYY.MM.DD. В случае отсутствия этого параметра подразумевается 1970.01.01.

  • TestReport - имя файла отчета тестирования. Файл будет создан в директории клиентского терминала. Можно указывать относительный путь, например: tester\MovingAverageReport". Если в имени файла отчета не указано расширение, то будет подставлено расширение ".htm". В случае отсутствия данного параметра отчет тестирования формироваться не будет.

  • TestReplaceReport - разрешить/запретить повторную запись файла отчета. Принимаемые значения "true" или "false". Если указано значение "false" и файл отчета с таким именем уже существует, то к имени файла отчета будет добавлен порядковый номер в квадратных скобках. Например, "MovingAverageReport[1].htm". В случае отсутствия этого параметра используется значение "false".

  • TestShutdownTerminal - разрешить/запретить вылючение терминала после тестирования. Принимаемые значения "true" или "false". В случае отсутствия этого параметра используется значение "false". Если в процессе тестирования пользователь нажал кнопку "Стоп", то значение этого параметра сбрасывается в "false", так как пользователь принял управление на себя.

Пример:

  ; start strategy tester
  TestExpert=Moving Average
  TestExpertParameters=ma0.set
  TestSymbol=EURUSD
  TestPeriod=H1
  TestModel=2
  TestOptimization=false
  TestDateEnable=true
  TestFromDate=1970.01.01
  TestToDate=2006.06.06
  TestReport=MovingAverageReport
  TestReplaceReport=false
  TestShutdownTerminal=true


Сервис — Архив котировок

Архив котировок

Технический анализ — это исследование динамики рынка с целью прогнозирования дальнейшей динамики цен. Чаще всего такой анализ осуществляется при помощи графиков. Поэтому очень важно иметь исторические данные цен по всем используемым финансовым инструментам и периодам. Исторические данные постоянно формируются и хранятся на сервере. Подключаясь к нему, клиентский терминал скачивает все необходимые данные. В дальнейшем они используются для построения графиков, тестирования и оптимизации экспертов. Для управления историческими данными в терминале имеется специальное окно "Архив котировок". Это окно можно открыть, выполнив команду меню "Сервис — Архив котировок" либо нажав клавишу F2.

После закрытия терминала все накопленные исторические данные сохраняются в "Архиве котировок". Причем размеры файлов исторических котировок не превышают заданных в настройках значений. Если объем накопленных исторических данных превышает величину, установленную в поле " Макс. баров истории:", то при сохранении удаляются самые старые бары. Для каждого таймфрейма формируется отдельный файл истории с именем SSSSSSPP.hst (где SSSSSS - обозначение финансового инструмента, PP - временной период в минутах) и сохраняется в директории /HISTORY. В дальнейшем сохраненные данные используются для построения графиков, а также для тестирования торговых стратегий.

В окне "Архив котировок" можно изменять имеющиеся данные. Для этого сначала необходимо выбрать требуемые инструмент и период в левой части окна. При этом произойдет загрузка соответствующих данных, которые будут представлены в виде таблицы. Чтобы добавить запись о новом баре, следует нажать одноименную кнопку, заполнить необходимые поля в новом окне и нажать кнопку "OK". После этого новый бар появится в исторической базе. Выделив существующую запись и нажав кнопку "Правка", можно изменить соответствующий бар. Для удаления бара из истории необходимо выделить его и нажать одноименную кнопку.

Загрузка исторических данных

С сервера исторических данных можно загрузить котировки по основным валютным парам начиная с 1999 года. Для этого необходимо выбрать нужный инструмент и нажать кнопку "Загрузить".

Внимание: загруженные данные могут отличаться от исторических данных, хранящихся на торговом сервере брокера.

После нажатия на кнопку будут загружены данные периода M1. Остальные периоды будут пересчитаны из М1 автоматически. При этом время скачанных данных автоматически пересчитывается в соответствии с часовым поясом текущего активного счета.

При загрузке исторических данных рекомендуется контролировать количество баров в истории и на графиках.

Внимание: использование глубокой истории требует много ресурсов компьютера.

Обновление котировок на сервере исторических данных происходит еженедельно. В дальнейшем, при повторных запросах данных, будут загружаться только обновленные котировки.

Экспорт и импорт исторических данных

Исторические данные можно экспортировать в файлы форматов CSV, PRN и HTM. Для этого необходимо в левой части окна "Архив котировок" выбрать требуемый инструмент и нажать кнопку "Экспорт". Далее следует выбрать один из трех файловых форматов и указать путь размещения на жестком диске.

Кроме экспорта, доступен также импорт исторических данных в терминал. Импортироваться могут файлы в форматах CSV, PRN, TXT, HTM и HST.

Исторические данные в файле могут быть представлены в следующем виде (вместо пробела может быть любой разделитель полей):

  • YYYY.MM.DD HH:MM O H L C V

  • YYYY-MM-DD HH:MM O H L C V

  • YYYY/MM/DD HH:MM O H L C V

  • DD.MM.YYYY HH:MM O H L C V

  • DD-MM-YYYY HH:MM O H L C V

  • DD/MM/YYYY HH:MM O H L C V

При импорте в левой части окна "Архив котировок" необходимо сначала выбрать инструмент и период, для которых он будет производиться. Затем необходимо настроить параметры импорта, нажав кнопку "Импорт":

  • Разделитель — разделитель данных в импортируемом файле. В качестве разделителя можно выбрать запятую, точку с запятой, пробел или знак табуляции;

  • Пропуск столбцов — пропускать колонки при импортировании. Это бывает полезным, если импортируемый файл имеет больше типов данных, чем требуется;

  • Пропуск строк — пропускать ряды (строки) при импортировании;

  • Сдвиг часов — сдвинуть данные на несколько часов во времени;

  • Только выделенные — импортировать только выделенные данные. Выделение данных производится по строкам, при этом используются клавиши "Ctrl" и "Shift";

  • Объемы — разрешить/запретить импорт объемов.

После завершения импорта исторические данные можно использовать для отображения графиков и тестирования советников.

Формат файлов истории (HST-файлы)

Сначала идет заголовок базы

struct HistoryHeader
{
  int               version;            // версия базы
  char              copyright[64];      // копирайт
  char              symbol[12];         // инструмент
  int               period;             // период инструмента
  int               digits;             // число знаков после запятой в инструменте
  time_t            timesign;           // временной отпечаток создания базы
  time_t            last_sync;          // время последней синхронизации
  int               unused[13];         // для будущего использования
};

затем массив баров (выравнивание однобайтовое)

#pragma pack(push,1)
//---- Стандартное представление котировки в базе
struct RateInfo
{
  time_t            ctm;                // текущее время в секундах
  double            open;
  double            low;
  double            high;
  double            close;
  double            vol;
};
#pragma pack(pop)


Сервис — Экспорт котировок

Экспорт котировок

Исходными данными, на базе которых строится вся аналитическая работа пользователя терминала, являются данные о динамике цен финансовых инструментов. Эту информацию поставляет брокерская компания. Ценовые данные позволяют строить графики финансовых инструментов, исследовать финансовые рынки, использовать различные торговые тактики и принимать торговые решения. Котировки представляют собой файлы с записями в формате "SYMBOL, BID, ASK, DATE" (финансовый инструмент, цена покупки, цена продажи, дата и время) и поступают в терминал автоматически после установки связи с сервером.

Терминал позволяет экспортировать текущие котировки в другие программы в режиме реального времени по протоколу "DDE" (Dynamic Data Exchange). Это — протокол операционных систем MS Windows для динамической передачи данных между различными приложениями. Котировки по DDE выдаются только по приходе новых тиков (режим ADVISE), а не сразу же по запросу (режим REQUEST) с выдачей последней известной цены. N/A выдается при первом запросе REQUEST, а после прихода новой цены появляются котировки.

Для активизации режима экспорта котировок из клиентского терминала по протоколу DDE необходимо включить опцию "Разрешить DDE сервер" в настройках терминала.

Внимание: исторические данные по протоколу DDE не транслируются. Передача текущих котировок производится только при работающем клиентском терминале.

Форматы DDE-запросов с их возможными результатами на примере файла "DDE-sample.xls":

   запрос BID:    = MT4|BID!USDCHF         результат:  1.5773
   запрос ASK:    = MT4|ASK!USDCHF         результат:  1.5778
   запрос HIGH:   = MT4|HIGH!USDCHF        результат:  1.5801
   запрос LOW:    = MT4|LOW!USDCHF         результат:  1.5741
   запрос TIME:   = MT4|TIME!USDCHF        результат:  21.05.02 9:52
   запрос QUOTE:  = MT4|QUOTE!USDCHF       результат:  21.05.02 9:52 1.5773 1.5778 1.5776
Внимание: для правильного отображения данных в MS Excel нужно включить опцию в меню "Сервис — Параметры — Переход — Преобразование формул в формат Excel при вводе".


Сервис — Глобальные переменные

Глобальные переменные

В клиентском терминале существует возможность запускать одновременно несколько советников. Иногда бывает необходимо, чтобы они обменивались информацией между собой. Для оперативной передачи небольших объемов информации между советниками, а также для организации бесконфликтной работы одновременно нескольких экспертов в терминале существуют глобальные переменные. В отличие от переменных, объявленных в исходном тексте эксперта на глобальном уровне и доступных только в пределах соответствующего модуля, глобальные переменные существуют независимо от советников. Их значения сохраняются между запусками терминала, в отличие от переменных, объявленных на глобальном уровне (значения которых устанавливаются при каждой загрузке эксперта и теряются при завершении работы). Глобальные переменные существуют в течение четырех недель после последнего обращения к ним из экспертов либо после изменения вручную.

В терминале имеется специальное окно управления глобальными переменными. Чтобы его вызвать, необходимо выполнить команду меню "Сервис — Глобальные переменные" или нажать клавишу F3. В этом окне в виде таблицы перечислены все глобальные переменные, их значение и время последнего обращения к ним. При помощи кнопок в правой части окна можно добавить новую переменную или удалить уже имеющуюся. Чтобы изменить название или значение переменной, следует дважды кликнуть левой кнопкой мыши на соответствующей ячейке. При этом время обращения к переменной будет изменено автоматически.


Сервис — Спецификация контрактов

Спецификация контрактов

Это информационное окне позволяет просматривать спецификации контрактов на финансовые инструменты. В нем в виде таблицы сгруппированы основные параметры:

  • Спред — разница между ценами покупки и предложения (Bid и Ask) в пунктах;

  • Точность — количество знаков после запятой (десятичной точки) в представлении цены;

  • Уровень стопов — минимальное расстояние от текущей цены в пунктах, на котором могут выставляться Стоп Лосс и Тейк Профит;

  • Отложенные ордеры GTC — принудительное закрытие отложенных ордеров в конце торговой сессии. "Да" означает, что отложенные ордера закрываться не будут;

  • Размер контракта — стоимость одного лота в базовой валюте инструмента;

  • Стоимость тика — размер минимального изменения цены инструмента в валюте котировки;

  • Размер тика — минимальный шаг изменения цены инструмента в пунктах;

  • Способ вычисления прибыли — принятый метод расчета прибыли (Forex, CFD, Futures);

  • Тип свопа — тип расчета ролловеров (в пунктах, в базовой валюте депозита или в процентах);

  • Своп длинной позиции — размер ролловера для длинной позиции;

  • Своп короткой позиции — размер ролловера для короткой позиции;

  • Способ вычисления свободной маржи — принятый метод расчета свободной маржи (Forex, CFD, Futures)

  • Хеджированная маржа — размер залоговых средств для перекрытых позиций.

Окно спецификаций финансовых инструментов можно вызвать, нажав кнопку "Свойства" окна управления финансовыми инструментами или кнопку "Свойства символа" окна "Тестер — Настройка".


Сервис — Языковая поддержка

Языковая поддержка

Интерфейс клинетского терминала — мультиязычный. Его можно представить в любом из доступных языков. Такая особенность программы не только делает ее удобной в использовании. Она также позволяет сократить количество ошибок, возникающих в процессе торговли из-за непонимания иностранных терминов. Список всех доступных языков можно посмотреть в меню "Вид — Languages". Выбрав требуемый язык из списка, можно переключить интерфейс терминала на него. Языковые изменения вступают в силу после перезапуска программы.


Сервис — Datacenter.ini

Datacenter.ini

Для администраторов дилинговых залов, которые хотят принудительно перенаправлять клиентский трафик, предусмотрена дополнительная возможность. При помощи конфигурационного файла datacenter.ini можно жестко задать используемый клиентским терминалом Дата Центр. Конфигурационный файл datacenter.ini должен располагаться в директории /config клиентского терминала.

При включенной галочке "Автоконфигурация Дата Центра" в настройках сервера будет производиться попытка открытия и анализ файла datacenter.ini. Если в этом файле для текущего сервера будет найден датацентр, то соединение будет производиться именно с этим датацентром. Для одного сервера может быть задано не более одного датацентра.

Формат строки файла datacenter.ini:

[имя сервера][разделитель][адрес датацентра]

где:

  • имя сервера - наименование соответствующего файла .srv;

  • разделитель - запятая или любое количество пробелов;

  • адрес датацентра - IP адрес : номер порта.

Строки, начинающиеся точкой с запятой (;), считаются комментарием и не обрабатываются.

Пример файла datacenter.ini:

  ;----------------
  ;комментарий
  ;----------------
  MetaQuotes-demo1  192.168.1.4:443
  MetaQuotes-demo2, 192.168.1.4:444
  ;----------------
  MetaQuotes-demo3  192.168.1.5:445
  MetaQuotes-demo4, 192.168.1.5:446